开发者门户通信问题

您正在查看的是 Apigee Edge 文档。
转到 Apigee X 文档
信息

问题

您可能会遇到由开发者门户与 Edge 之间的通信问题引起的以下一个或多个问题:

  1. 无法执行以下任务:
  2. 创建或更新 SmartDocs。
  3. 注册开发者应用。
  4. 列出 API 产品。
  5. 访问开发者门户上的 SmartDocs 模型页面(在开发者门户管理菜单中依次选择内容 > SmartDocs)时返回的错误。


  6. 未生成开发者应用分析数据。

错误消息

  1. 访问开发者门户中的“SmartDocs”标签页时返回的错误:

    The website encountered an unexpected error. Please try again later.
    
  2. 在开发者门户中注册开发者应用时返回的错误:

    There was an error trying to create the App. Please try again later.
    

可能的原因

在大多数情况下,问题是由于指定的 devadmin 凭据不正确或分配给 devadmin 用户角色的权限不足

验证开发门户的边缘连接配置,方法是转到配置 > 开发门户,并确保“连接状态”字段显示“连接成功”。否则,开发门户将无法正确连接到边缘管理服务器。

诊断

  1. 在开发者门户上启用“DEBUG”日志记录,方法是依次前往 Configuration > Dev Portal,然后在 Edge logging 阈值下选择“Debug”。默认情况下,系统不会记录 Management API 调用。
  1. 重现问题。
  1. 如需访问日志,请前往报告 -> 近期日志消息

  1. 打开“LogPlugin”类型的“Message”,详细了解实际错误。

显示“401 Unauthorized Error”错误的输出示例

分辨率

根据遇到的错误,按照下表中所列的相应步骤操作:

错误

解决步骤

401 未经授权

在开发者门户上更新正确的开发者管理员凭据,并再次测试连接。请参阅添加和管理用户帐号

403 已禁止

更新 Edge 组织的 devadmin 用户角色,以获得资源所需的权限。请参阅设置用户角色和权限