4.18.01.02 - Edge for Private Cloud release notes

On May 18, 2018, we released a new version of Apigee Edge for Private Cloud.

Update procedure

To update your installation, perform the following procedure on the Edge nodes:

  1. On all Edge nodes:

    1. Clean Yum repos:
      sudo yum clean all
    2. Download the latest Edge 4.18.01 bootstrap_4.18.01.sh file to /tmp/bootstrap_4.18.01.sh:
      curl https://software.apigee.com/bootstrap_4.18.01.sh -o /tmp/bootstrap_4.18.01.sh
    3. Install the Edge 4.18.01 apigee-service utility and dependencies:
      sudo bash /tmp/bootstrap_4.18.01.sh apigeeuser=uName apigeepassword=pWord

      Where uName:pWord are the username and password you received from Apigee. If you omit pWord, you will be prompted to enter it.

    4. Update the apigee-setup utility:
      sudo /opt/apigee/apigee-service/bin/apigee-service apigee-setup update
    5. Use the source command to execute the apigee-service.sh script:
      source /etc/profile.d/apigee-service.sh
  2. Update all Message Processor nodes:
    /opt/apigee/apigee-setup/bin/update.sh -c edge -f configFile

    Where configFile specifies the config file you used to install Edge.

  3. Update all Edge UI nodes:
    /opt/apigee/apigee-setup/bin/update.sh -c ui -f configFile

    Where configFile specifies the config file you used to install Edge.

  4. Update all Qpid nodes:
    /opt/apigee/apigee-setup/bin/update.sh -c qpid -f configFile

    Where configFile specifies the config file you used to install Edge.

Bugs fixed

The following bugs are fixed in this release.

Issue ID Description Build number
79221633 Improve NIOManager thread pool management edge-gateway-4.18.01-0.0.1607
74393594 Fix drilldown feature in custom reports edge-ui-4.18.01-0.0.20043
72173268 Update qpid-cpp-server package to resolve apigee-qpidd upgrade issue apigee-qpidd-4.18.01-0.0.855