4.17.05.02 - Notas da versão do Edge para nuvem privada

Você está vendo a documentação do Apigee Edge.
Acesse a documentação da Apigee X.
informações

Na quarta-feira, 15 de novembro de 2017, lançamos uma nova versão do Apigee Edge para nuvem privada.

Procedimento de atualização

Para atualizar a instalação, execute o seguinte procedimento nos nós de borda:

  1. Em todos os nós de borda:

    1. Limpe os repositórios do Yum:
      > sudo yum clean all
    2. Atualize o arquivo bootstrap_4.17.05.sh do Edge 4.17.05 em /tmp/bootstrap_4.17.05.sh:
      > curl https://software.apigee.com/bootstrap_4.17.05.sh -o /tmp/bootstrap_4.17.05.sh
    3. Instale o utilitário apigee-service e as dependências do Edge 4.17.05:
      > sudo bash /tmp/bootstrap_4.17.05.sh apigeeuser=uName apigeepassword=pWord

      em que uName:pWord são o nome de usuário e a senha que você recebeu da Apigee. Se você omitir o caractere pWord, será necessário inseri-lo.
    4. Atualize o utilitário apigee-setup:
      > sudo /opt/apigee/apigee-service/bin/apigee-service apigee-setup update.
    5. Acesse o arquivo apigee-service.sh:
      > source /etc/profile.d/apigee-service.sh
  2. Atualize todos os nós do OpenLDAP:
    >/opt/apigee/apigee-setup/bin/update.sh -c ldap -f configFile

  3. Atualize todos os nós do Servidor de gerenciamento:
    >/opt/apigee/apigee-setup/bin/update.sh -cedge -f configFile

  4. Atualize todos os nós do roteador e do processador de mensagens:
    >/opt/apigee/apigee-setup/bin/update.sh -c edge -f configFile

    em que configFile especifica o arquivo de configuração usado para instalar o Edge.

Bugs corrigidos

Os bugs abaixo foram corrigidos nesta versão.

Id do problema Descrição Número da versão
APIRT-3081.

Mensagem de erro da política de limite de taxa simultânea emitindo

A política de limite de taxa simultânea estava emitindo erros "java.lang.IllegalMonitorStateException" e "Messaging.adaptors.http.flow.Service)." Esses erros foram corrigidos.

edge-gateway-0.0.1413.
DBS-1773

Erros ao instalar o OpenLDAP

As versões anteriores do Instalador do Edge tentaram instalar a versão incorreta do OpenLDAP. Esse problema foi corrigido nessa versão.

apigee-openldap-2.4-0.0.1004.
MGMT-3782 Foi corrigido o erro no valor do nível de consistência para a zona de identidade edge-gateway-4.17.05-0.0.1413.
A definir 250

Adição do comando de senha ofuscada

Foi adicionado um comando para gerar uma senha ofuscada para que qualquer componente possa gerar uma senha criptografada. É possível gerar uma senha ofuscada usando o seguinte comando no servidor de gerenciamento de borda:

> /opt/apigee/apigee-service/bin/apigee-service edge-management-server generate-obfuscated-password

Digite a nova senha e confirme no prompt. Por motivos de segurança, o texto da senha não é exibido. Este comando retorna a senha no formulário:

OBF:58fh40h61svy156789gk1saj
MD5:902fobg9d80e6043b394cb2314e9c6

Consulte Como configurar o TLS/SSL para o Edge local.

edge-gateway-4.17.05-0.0.1413.
A definir-261 Várias correções de segurança apigee-service-4.17.05-0.0.974