4.18.01.02 - Private Cloud के रिलीज़ नोट के लिए Edge

Apigee Edge दस्तावेज़ देखा जा रहा है.
Apigee X दस्तावेज़ पर जाएं.
जानकारी

हमने 18 मई, 2018 को Private Cloud के लिए, Apigee Edge का नया वर्शन रिलीज़ किया है.

अपडेट करने की प्रोसेस

इंस्टॉल करने की प्रक्रिया को अपडेट करने के लिए, एज नोड पर यह तरीका अपनाएं:

  1. सभी Edge नोड पर:

    1. यम के सही रिपोज़ को साफ़ करें:
      sudo yum clean all
    2. सबसे नई Edge 4.18.01 bootstrap_4.18.01.sh फ़ाइल को /tmp/bootstrap_4.18.01.sh में डाउनलोड करें:
      curl https://software.apigee.com/bootstrap_4.18.01.sh -o /tmp/bootstrap_4.18.01.sh
    3. Edge 4.18.01 apigee-service यूटिलिटी और डिपेंडेंसी इंस्टॉल करें:
      sudo bash /tmp/bootstrap_4.18.01.sh apigeeuser=uName apigeepassword=pWord

      यहां uName:pWord, Apigee से मिला उपयोगकर्ता नाम और पासवर्ड है. pWord को छोड़ने पर, आपको इसे डालने के लिए कहा जाएगा.

    4. apigee-setup सुविधा को अपडेट करें:
      sudo /opt/apigee/apigee-service/bin/apigee-service apigee-setup update
    5. apigee-service.sh स्क्रिप्ट को चलाने के लिए, source निर्देश का इस्तेमाल करें:
      source /etc/profile.d/apigee-service.sh
  2. सभी मैसेज प्रोसेसर नोड अपडेट करें:
    /opt/apigee/apigee-setup/bin/update.sh -c edge -f configFile

    जहां configFile उस कॉन्फ़िगरेशन फ़ाइल को दिखाता है जिसका इस्तेमाल आपने Edge को इंस्टॉल करने के लिए किया था.

  3. सभी Edge यूज़र इंटरफ़ेस (यूआई) नोड अपडेट करें:
    /opt/apigee/apigee-setup/bin/update.sh -c ui -f configFile

    जहां configFile उस कॉन्फ़िगरेशन फ़ाइल को दिखाता है जिसका इस्तेमाल आपने Edge को इंस्टॉल करने के लिए किया था.

  4. सभी Qpid नोड अपडेट करें:
    /opt/apigee/apigee-setup/bin/update.sh -c qpid -f configFile

    जहां configFile उस कॉन्फ़िगरेशन फ़ाइल को दिखाता है जिसका इस्तेमाल आपने Edge को इंस्टॉल करने के लिए किया था.

गड़बड़ियां ठीक की गईं

इस रिलीज़ में इन गड़बड़ियों को ठीक किया गया है.

समस्या आईडी ब्यौरा बिल्ड नंबर
79221633 NIOManager के थ्रेड पूल को मैनेज करने की सुविधा को बेहतर बनाना edge-gateway-4.18.01-0.0.1607
74393594 कस्टम रिपोर्ट में ड्रिल-डाउन सुविधा को ठीक करना edge-ui-4.18.01-0.0.20043
72173268 apigee-qpidd अपग्रेड करने से जुड़ी समस्या को हल करने के लिए, qpid-cpp-सर्वर पैकेज अपडेट करें apigee-qpidd-4.18.01-0.0.855