Waktu tunggu laporan Analytics

Anda sedang melihat dokumentasi Apigee Edge.
Buka Dokumentasi Apigee X.
info

ini.

Gejala

Dasbor Analytics (Performa Proxy, Performa Target, Laporan Kustom, dll.) di Waktu tunggu UI Edge.

Pesan error

Anda melihat pesan error berikut saat waktu tunggu dasbor Analytics habis:

The report timed out: Try again with a smaller date range or a larger aggregation interval.

Kemungkinan penyebab

Tabel berikut mencantumkan kemungkinan penyebab masalah ini:

Penyebab Untuk
Konfigurasi hardware tidak memadai Pengguna Edge Private Cloud
Data Analytics dalam jumlah besar di Database Postgres Pengguna Edge Private Cloud
Tidak cukup waktu untuk mengambil data Analytics Pengguna Edge Private Cloud dan Public Cloud

Konfigurasi hardware tidak memadai

Diagnosis

Jika salah satu komponen Edge berada di bawah kapasitas (jika memiliki lebih sedikit kapasitas CPU, RAM, atau IOPS dari yang diperlukan), Server Postgres/Server Qpid mungkin berjalan lambat yang menyebabkan Analytics waktu tunggu habis.

Resolusi

Pastikan semua komponen Edge mematuhi persyaratan hardware minimum seperti yang dijelaskan dalam Hardware Persyaratan.

Data Analytics dalam jumlah besar di Database Postgres

Diagnosis

  1. Pada node Postgres, login ke PostgreSQL:
    psql -h /opt/apigee/var/run/apigee-postgresql -U apigee apigee
    
  2. Periksa durasi ketersediaan data di Database Postgres menggunakan kueri SQL berikut:
    select min(client_received_start_timestamp), max(client_received_start_timestamp) from
      analytics."orgname.envname.fact";
    
  3. Dapatkan ukuran semua tabel di Database Postgres:
    SELECT relname as "Table",pg_size_pretty(pg_total_relation_size(relid)) As "Size",
      pg_size_pretty(pg_total_relation_size(relid) - pg_relation_size(relid)) as "External Size"
      FROM pg_catalog.pg_statio_user_tables ORDER BY pg_total_relation_size(relid) DESC;
    

Berdasarkan {i>output<i} yang diperoleh pada langkah #2 dan #3, jika Anda melihat bahwa durasi lokasi data yang telah disimpan panjang (lebih panjang dari interval retensi Anda) dan/atau tabel ukuran sangat besar, maka itu menunjukkan bahwa Anda memiliki data analitik dalam jumlah besar di di database Postgres. Hal ini dapat menyebabkan dasbor Analytics kehabisan waktu.

Resolusi

Pangkas data yang berada di luar interval retensi yang diperlukan:

  1. Tentukan interval retensi, yaitu durasi yang ingin Anda pertahankan Data analisis di Database Postgres.

    Misalnya, Anda ingin menyimpan data Analytics selama 60 hari.

  2. Jalankan perintah berikut untuk memangkas data untuk organisasi dan lingkungan tertentu:
    /opt/apigee/apigee-service/bin/apigee-service apigee-postgresql pg-data-purge
        org env num_days_to_purge_back_from_current_date
    
  3. Untuk informasi selengkapnya, lihat Memangkas data Analytics.

Jika masalah berlanjut, lanjutkan ke Tidak cukup waktu untuk mengambil Analytics data Anda.

Waktu tidak cukup untuk mengambil data Analytics

Diagnosis

  1. Periksa apakah Anda dapat melihat data di Tab Jam/Hari pada dasbor Analytics (Proxy Performa/Performa Target).
  2. Jika Anda dapat melihat data hanya di tab Jam atau tab Jam dan Hari, namun mendapatkan kesalahan waktu tunggu laporan hanya saat mencoba menampilkan tab Minggu atau Khusus, maka menunjukkan bahwa volume data yang perlu diambil dari {i>database <i}Postgres sangat besar. Hal ini dapat menyebabkan UI Edge kehabisan waktu.

Resolusi

UI Edge memiliki waktu tunggu default 120 detik untuk mengambil dan menampilkan Analisis layanan otomatis dan data skalabel. Jika volume data Analytics yang akan diambil sangat besar, 120 detik mungkin tidak memadai. Tingkatkan nilai waktu tunggu UI Edge menjadi 300 detik dengan mengikuti petunjuk dalam Tetapkan waktu tunggu yang digunakan oleh UI Edge untuk panggilan pengelolaan Edge API (pelanggan lokal saja).

Muat ulang dasbor Analytics mana pun dan periksa apakah Anda dapat melihat data untuk semua tab - Jam, Hari, Minggu, dan Kustom.

Jika masalah berlanjut, hubungi Dukungan Apigee Edge.