Custom domain does not match CNAME record in integrated developer portal

You're viewing Apigee Edge documentation.
Go to the Apigee X documentation.
info

Symptom

The custom domain configuration in the integrated developer portal will not work if the custom domain does not match the CNAME (canonical name) record: Publish > Portals > Developer Portal > Settings > Domains.

Error Message

The following error message is displayed:

Domain does not match CNAME record

The error message is displayed in the Edge UI as shown below:

Portals > Developer Portal > Settings > Domains" title="Domains">

Possible Causes

Cause Description Troubleshooting instructions applicable for
Missing or incorrect CNAME record for the domain The custom domain should have a CNAME record pointing to {orgname}-portal.apigee.net. If not, custom domain configuration will fail. Edge Public Cloud users

Cause: Missing or incorrect CNAME record for the domain

Diagnosis

Do the following steps to diagnose the issue:

  1. Execute the following command to find the DNS configuration of the custom domain name:
    dig +noall +answer {custom-domain}
  2. The output of the above command should contain a CNAME record pointing to {org}-portal.apigee.net domain name. For example:
    dig +noall +answer {custom-domain}
    
    {custom-domain}	{TTL}	IN	CNAME	{orgname}-portal.apigee.net.
  3. If the output of the command shows that the custom domain does not have a CNAME record or contains the CNAME record that does not match{org}-portal.apigee.net,then that’s the cause for the virtual host creation to fail. As a result, the above error message is displayed to the user on the custom domain configuration page of the Edge UI.

Resolution

If the custom domain does not contain a CNAME record pointing to {orgname}-portal.apigee.net, then do the following steps to resolve the issue:

  1. Remove any existing CNAME records found in the custom domain DNS configuration.
  2. Add a CNAME record to your domain name (that you would like to use in the custom domain page) to point to {orgname}-portal.apigee.net.
  3. Select the specific custom domain name (that has CNAME record pointing to {orgname}-portal.apigee.net) from the drop down menu for the Domain in the custom domain configuration page.
  4. If you have uploaded a wildcard certificate to the keystore, then do the following:
    1. Select the domain name from the drop down menu, and
    2. Fill in the correct sub domain name
  5. Configure keystore, alias, domain name in the integrated developer portal custom domain configuration page.
  6. Click Save.

If the problem still persists, go to Must gather diagnostic information.

Must gather diagnostic information

If the problem persists after following the above instructions, gather the following diagnostic information and share it with Apigee Edge Support:

  • Apigee Edge Cloud organization name
  • Apigee Edge Cloud integrated developer portal name
  • Name of the keystore created in the portal environment
  • Alias name
  • Custom domain name
  • A screenshot of the custom domain configuration page capturing the error message