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Symptom
You will observe the error
Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm
during the installation
or migration to newer version of Apigee Edge for Private Cloud.
Error message
You will observe the following error:
Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm. Skipping.
This error typically happens while installing the apigee-setup utility
and
dependencies:
[root@machinename ~]# sudo bash /tmp/bootstrap_4.50.00.sh apigeeuser=USERNAME Apigee bootstrap 1.0-38 (OPDK_5000, 2020.11.30,19:31) === Obtaining creds for software.apigee.com: Please enter value for password: === Begin work ... === Checking for presence of misc commands: === Checking distro: === Checking architecture: === Checking OS: === Checking SELinux status === Configuring package manager: + rpm -qa apigee* + rpm -e apigee-repo error: package apigee-repo is not installed (error can be ignored) + rpm -e apigeeprio-repo error: package apigeeprio-repo is not installed (error can be ignored) + yum install -y https://apigee:***@software.apigee.com/apigee-repo.rpm Loaded plugins: enabled_repos_upload, langpacks, package_upload, priorities, : product-id, protectbase, search-disabled-repos, subscription- : manager HTTP error (410 - Gone): Unit d98c371e-06bc-4afc-a216-effb1ebc9bce has been deleted Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm. Skipping. Error: Nothing to do Uploading Enabled Repositories Report Loaded plugins: langpacks, priorities, product-id, protectbase, subscription- : manager HTTP error (410 - Gone): Unit d98c371e-06bc-4afc-a216-effb1ebc9bce has been deleted bootstrap_4.50.00.sh: Error: Repo configuration failed [root@machinename ~]#
Possible causes
Here are the possible causes for this error:
Cause | Description | Troubleshooting instructions applicable for |
---|---|---|
Internet connection or network connectivity issues | There is no outbound internet connection or there are network connectivity issues. | Edge Private Cloud users only |
Incorrect username or password | Using incorrect username or password for software.apigee.com repository. |
Edge Private Cloud users only |
Password contains special characters | Password for software.apigee.com repository contains special characters. |
Edge Private Cloud users only |
Cause: Internet connection or network connectivity issues
Diagnosis
- Check to see if you have the outbound internet connection on the machine where you are seeing the above error.
- If you have an outbound internet connection, then test your network connectivity to
software.apigee.com
using one of the following mechanisms:netcat
Using netcat:
If you have installed
netcat
, then run the following command:nc -v software.apigee.com 443
You should get a message similar to the following:
Connection to software.apigee.com 443 port [tcp/https] succeeded!
OR
Connected to IP_ADDRESS:443
- If you don’t see any of the above messages or if you see errors, then you have a
network connectivity issue to
software.apigee.com.
telnet
Using telnet:
If you don't have
netcat
installed, you can use the followingtelnet
command to check the internet connectivity:telnet software.apigee.com 443
You should see the following output if it connects:
Connected to software.apigee.com
- If you don’t see any of the above messages or if you see errors, then you have a
network connectivity issue to
software.apigee.com.
Resolution
If you don’t have an internet connection or one of the commands (netcat
or
telnet
) fails, then you have limited or no network connectivity. Work with your
network administrator to fix the issue.
Cause: Incorrect username or password
Diagnosis
Validate that you are passing the correct username and password to the command that installs the Apigee Edge
apigee-service utility
:sudo bash /tmp/bootstrap_4.50.00.sh apigeeuser=USERNNAME apigeepassword=PASSWORD
You can also make a direct call to the URL
software.apigee.com
and check the output:curl -i -u USERNNAME>:PASSWORD https://software.apigee.com/apigee-repo.rpm
- If you get a
401 Unauthorized
error, then that indicates that you are using an incorrect username and/or password.
Resolution
Ensure that you are using the correct username and password while installing
apigee-setup utility
.
Cause: Password contains special characters
Diagnosis
- Verify that the password for
software.apigee.com
does not contain any special characters. For example:>
,$
,@
, or*
. - If the password has any special characters, then that’s the cause for this error.
Resolution
- Use the backslash escape character (
\
) before any special character. - For example, if your password is
pa$$w0rd
, then you should specify the password aspa\$\$w0rd
.