Timeout dei report di Analytics

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Informazioni

Sintomo

Le dashboard di Analytics (Rendimento proxy, Rendimento target, Report personalizzati e così via) nella Timeout UI perimetrale.

Messaggi di errore

Quando si verifica il timeout delle dashboard di Analytics, viene visualizzato il seguente messaggio di errore:

The report timed out: Try again with a smaller date range or a larger aggregation interval.

Possibili cause

Nella tabella seguente sono elencate le possibili cause di questo problema:

Causa Per
Configurazione hardware inadeguata Utenti Edge Private Cloud
Grande quantità di dati di Analytics nel database Postgres Utenti Edge Private Cloud
Tempo insufficiente per recuperare i dati di Analytics Utenti Edge di cloud privato e pubblico

Configurazione hardware inadeguata

Diagnosi

Se uno dei componenti Edge è al di sotto della capacità (se ha meno capacità di CPU, RAM o IOPS) del necessario), allora i server Postgres/i server Qwiklabs potrebbero funzionare lentamente, causando Analytics le dashboard in timeout.

Risoluzione

Assicurati che tutti i componenti Edge rispettino i requisiti hardware minimi descritti in Hardware Requisiti.

Grande quantità di dati di Analytics nel database Postgres

Diagnosi

  1. Nel nodo Postgres, accedi a PostgreSQL:
    psql -h /opt/apigee/var/run/apigee-postgresql -U apigee apigee
    
  2. Controlla per quanto tempo i dati sono disponibili nel database Postgres utilizzando il seguente query SQL:
    select min(client_received_start_timestamp), max(client_received_start_timestamp) from
      analytics."orgname.envname.fact";
    
  3. Ottieni le dimensioni di tutte le tabelle nel database Postgres:
    SELECT relname as "Table",pg_size_pretty(pg_total_relation_size(relid)) As "Size",
      pg_size_pretty(pg_total_relation_size(relid) - pg_relation_size(relid)) as "External Size"
      FROM pg_catalog.pg_statio_user_tables ORDER BY pg_total_relation_size(relid) DESC;
    

In base all'output ottenuto ai passaggi n. 2 e n. 3, se noti che la durata per i dati archiviati sono lunghi (più lunghi dell'intervallo di conservazione) e/o la tabella sono molto grandi, significa che disponi di grandi quantità di dati di analisi nel il database Postgres. Questo potrebbe causare il timeout delle dashboard di Analytics.

Risoluzione

Elimina i dati che superano l'intervallo di conservazione richiesto:

  1. Determina l'intervallo di conservazione, ovvero la durata per cui vuoi conservare Dati di analisi nel database Postgres.

    Ad esempio, vuoi conservare i dati di Analytics relativi a un periodo di 60 giorni.

  2. Esegui questo comando per eliminare i dati per un'organizzazione e un ambiente specifici:
    /opt/apigee/apigee-service/bin/apigee-service apigee-postgresql pg-data-purge
        org env num_days_to_purge_back_from_current_date
    
  3. Per saperne di più, consulta Informazioni su come eliminare i dati di Analytics.

Se il problema persiste, vai alla sezione Tempo insufficiente per recuperare i dati di Analytics. i tuoi dati.

Tempo insufficiente per recuperare i dati di Analytics

Diagnosi

  1. Controlla se riesci a visualizzare i dati nella scheda Ora/Giorno della dashboard di Analytics ( rendimento/rendimento del target).
  2. Se è possibile visualizzare i dati solo nella scheda Ora o nelle schede Ora e Giorno, ma e vengono visualizzati errori di timeout del report solo quando tenti di visualizzare le schede Settimana o Personalizzate, indica che il volume di dati da recuperare dal database Postgres è molto grandi. Questo potrebbe causare il timeout della UI Edge.

Risoluzione

La UI di Edge ha un timeout predefinito di 120 secondi per il recupero e la visualizzazione dei dati di analisi e i dati di Google Cloud. Se il volume dei dati di Analytics da recuperare è molto grande, 120 secondi potrebbero non essere sufficienti. Aumenta il valore di timeout dell'UI perimetrale a 300 secondi seguendo le istruzioni riportate in Imposta il timeout utilizzato dalla UI Edge per le chiamate di gestione delle API Edge (clienti on-premise ).

Ricarica una delle dashboard di Analytics e controlla se riesci a visualizzare i dati per tutti i Ora, Giorno, Settimana e Personalizzato.

Se il problema persiste, contatta l'assistenza Apigee Edge.