Вы просматриваете документацию Apigee Edge .
Перейдите к документации Apigee X. информация
Симптом
Панели аналитики (производительность прокси-сервера, целевая производительность, пользовательские отчеты и т. д.) в тайм-ауте пользовательского интерфейса Edge.
Сообщения об ошибках
Когда истекает время ожидания информационных панелей Analytics, вы видите следующее сообщение об ошибке:
The report timed out: Try again with a smaller date range or a larger aggregation interval.
Возможные причины
В следующей таблице перечислены возможные причины этой проблемы:
Причина | Для |
---|---|
Неправильная конфигурация оборудования | Пользователи Edge Private Cloud |
Большой объем аналитических данных в базе данных Postgres | Пользователи Edge Private Cloud |
Недостаточно времени для получения данных Google Analytics. | Пользователи Edge частного и публичного облака |
Неправильная конфигурация оборудования
Диагностика
Если какой-либо из пограничных компонентов имеет недостаточную мощность (если у них меньше ресурсов ЦП, ОЗУ или операций ввода-вывода в секунду, чем требуется), то серверы Postgres/серверы Qpid могут работать медленно, что приводит к тайм-ауту информационных панелей Analytics.
Разрешение
Убедитесь, что все компоненты Edge соответствуют минимальным требованиям к оборудованию, как описано в разделе «Требования к оборудованию» .
Большой объем аналитических данных в базе данных Postgres
Диагностика
- На узле Postgres войдите в PostgreSQL:
psql -h /opt/apigee/var/run/apigee-postgresql -U apigee apigee
- Проверьте продолжительность, в течение которой данные доступны в базе данных Postgres, с помощью следующего SQL-запроса:
select min(client_received_start_timestamp), max(client_received_start_timestamp) from analytics."orgname.envname.fact";
- Получите размеры всех таблиц в базе данных Postgres:
SELECT relname as "Table",pg_size_pretty(pg_total_relation_size(relid)) As "Size", pg_size_pretty(pg_total_relation_size(relid) - pg_relation_size(relid)) as "External Size" FROM pg_catalog.pg_statio_user_tables ORDER BY pg_total_relation_size(relid) DESC;
Судя по результатам, полученным на шагах № 2 и № 3, если вы заметили, что продолжительность хранения данных велика (больше вашего интервала хранения) и/или размеры таблиц очень велики, это означает, что у вас есть большие объемы аналитических данных в базе данных Postgres. Это может привести к тайм-ауту информационных панелей Analytics.
Разрешение
Сократите данные, выходящие за рамки требуемого интервала хранения:
- Определите интервал хранения, то есть продолжительность, в течение которой вы хотите хранить данные Analytics в базе данных Postgres.
Например, вы хотите сохранить данные Analytics за 60 дней.
- Запустите следующую команду, чтобы сократить данные для конкретной организации и среды:
/opt/apigee/apigee-service/bin/apigee-service apigee-postgresql pg-data-purge org env num_days_to_purge_back_from_current_date
- Дополнительную информацию см. в разделе Данные Pruning Analytics .
Если проблема не устранена, перейдите к разделу «Недостаточно времени для получения данных Analytics» .
Недостаточно времени для получения данных Google Analytics.
Диагностика
- Проверьте, можете ли вы просматривать данные на вкладке «Час/День» информационной панели Analytics (Производительность прокси/Целевая производительность).
- Если вы можете просматривать данные только на вкладке «Час» или на вкладках «Час» и «День», но получаете ошибки времени ожидания отчета только при попытке просмотреть вкладки «Неделя» или «Пользовательские», это указывает на то, что объем данных, который необходимо получить из база данных Postgres очень велика. Это может привести к тайм-ауту пользовательского интерфейса Edge.
Разрешение
Пользовательский интерфейс Edge имеет время ожидания по умолчанию 120 секунд для получения и отображения данных Analytics. Если объем извлекаемых данных Analytics очень велик, 120 секунд может оказаться недостаточно. Увеличьте значение тайм-аута пользовательского интерфейса Edge до 300 секунд, следуя инструкциям в разделе Установка тайм-аута, используемого пользовательским интерфейсом Edge для вызовов управления API Edge (только для локальных клиентов).
Перезагрузите любую панель аналитики и проверьте, можете ли вы просмотреть данные для всех вкладок — «Час», «День», «Неделя» и «Пользовательский».
Если проблема не устранена, обратитесь в службу поддержки Apigee Edge .