Stai visualizzando la documentazione di Apigee Edge.
Vai alla sezione
Documentazione di Apigee X. Informazioni
Sintomo
Potresti riscontrare uno o più dei seguenti problemi, causati da problemi di comunicazione tra il portale per gli sviluppatori ed Edge:
- Impossibile eseguire le seguenti attività:
- Crea o aggiorna SmartDocs.
- Registrazione di app sviluppatore.
- Elenca i prodotti basati su API.
- Errore restituito durante l'accesso alla pagina dei modelli SmartDocs sul portale per gli sviluppatori (seleziona
Contenuti > SmartDocumenti nel menu di amministrazione del Portale per gli sviluppatori).
- Generazione dell'analisi dell'app dello sviluppatore non in corso.
Messaggi di errore
- Errore restituito durante l'accesso alla scheda "SmartDocs" nel portale per sviluppatori:
The website encountered an unexpected error. Please try again later.
- Errore restituito durante la registrazione di un'app per sviluppatori nel portale per gli sviluppatori:
There was an error trying to create the App. Please try again later.
Possibili cause
Nella maggior parte dei casi, il problema è dovuto a un errore di devadmin. credenziali specificate o autorizzazioni insufficienti assegnate il ruolo utente devadmin.
Convalida la configurazione della connessione perimetrale per il portale per sviluppatori andando su Configurazione > Portale per sviluppatori e verifica che il campo Stato connessione mostra Connessione riuscita. In caso contrario, il portale per sviluppatori non riesce a connettersi correttamente Edge Management Server.
Diagnosi
- Attiva "DEBUG" accedi al portale per sviluppatori accedendo Configurazione > Dev Portal e selezionando Debug in Edge logging soglia. Per impostazione predefinita, le chiamate all'API di gestione non vengono registrate.
- Riproduci il problema.
- Per accedere al log, vai a Report -> Diario recente Messaggi.
- Apri il "Messaggio" di tipo "LogConnectin" per saperne di più sul l'errore effettivo.
Esempio di output che mostra l'errore 401 Autorizzazione non autorizzata
Risoluzione
Segui i passaggi appropriati elencati nella tabella seguente a seconda dell'errore riscontrato:
Errore |
Procedura per la risoluzione |
401 Autorizzazione non autorizzata |
Aggiornare le credenziali devadmin corrette sul portale per gli sviluppatori e testare la connettività di nuovo. Vedi Aggiungere e gestire account utente. |
403 Accesso negato |
Aggiorna il ruolo utente devadmin sull'organizzazione Edge in modo che abbia le autorizzazioni necessarie per la risorsa. Consulta la sezione Impostazione di autorizzazioni e ruoli utente. |