Problemas de comunicación en el portal para desarrolladores

Estás viendo la documentación de Apigee Edge.
Ve a la Documentación de Apigee X.
información

Síntoma

Es posible que encuentres uno o varios de los siguientes problemas causados por los problemas de comunicación entre el portal para desarrolladores y Edge:

  1. No se pudieron realizar las siguientes tareas:
  2. Crea o actualiza SmartDocs.
  3. Registra las apps de desarrollador.
  4. Enumera productos de API.
  5. Se muestra un error al acceder a la página de modelos de SmartDocs en el portal para desarrolladores (selecciona Contenido > SmartDocs en el menú de administración del portal para desarrolladores).


  6. No se están generando las estadísticas de aplicaciones del desarrollador.

Mensajes de error

  1. Se muestra un error al acceder a la pestaña "SmartDocs" en el portal para desarrolladores:

    The website encountered an unexpected error. Please try again later.
    
  2. Se muestra un error cuando se registra una app de desarrollador en el portal para desarrolladores:

    There was an error trying to create the App. Please try again later.
    

Causas posibles

En la mayoría de los casos, el problema se debe a un desarrollo incorrecto. credenciales especificadas o permisos insuficientes asignados a el rol del usuario devadmin.

Para validar la configuración de la conexión de Edge para el portal para desarrolladores, dirígete a Configuración > Portal para desarrolladores y asegúrate de que el campo Estado de conexión muestra Connection Successful. De lo contrario, el portal para desarrolladores no podrá conectarse correctamente al portal servidor de Edge Management.

Diagnóstico

  1. Habilitar “DEBUG” en el portal para desarrolladores, en Configuración > Portal para desarrolladores y selecciona Depurar en Registro perimetral umbral. De forma predeterminada, las llamadas a la API de Management no se registran.
  1. Reproduce el problema.
  1. Para acceder al registro, navegue a Informes -> Registro reciente Mensajes

  1. Abre el "Message" del tipo "LogPlugin" para obtener más información sobre el el error real.

Resultado de muestra que muestra el error 401 No autorizado

Solución

Sigue los pasos adecuados que se indican en la siguiente tabla según el error que se haya encontrado:

Error

Pasos para la resolución

401 Unauthorized

Actualiza las credenciales correctas de devadmin en el portal para desarrolladores y prueba la conectividad de nuevo. Consulta Agrega y administra cuentas de usuario.

403 Forbidden

Actualiza el rol de usuario devadmin en la organización de Edge para tener los permisos necesarios para el recurso. Consulta Configurar permisos y roles de usuarios.