<ph type="x-smartling-placeholder"></ph>
Vous consultez la documentation Apigee Edge.
Accédez à la page
Documentation sur Apigee X. En savoir plus
Symptôme
Vous pouvez rencontrer un ou plusieurs des problèmes suivants en raison de problèmes de communication entre le portail des développeurs et Edge:
- Impossible d'effectuer les tâches suivantes:
- créer ou mettre à jour des SmartDocs ;
- Enregistrer des applications de développeur.
- Lister les produits d'API
- Une erreur est renvoyée lors de l'accès à la page des modèles SmartDocs sur le portail des développeurs (sélectionnez
Contenu > les SmartDocs dans le menu d'administration du portail des développeurs).
- Les données analytiques de l'application du développeur ne sont pas générées.
Messages d'erreur
- L'erreur suivante s'affiche lors de l'accès à l'onglet "SmartDocs" du portail des développeurs:
The website encountered an unexpected error. Please try again later.
- Erreur affichée lors de l'enregistrement d'une application de développeur dans le portail des développeurs:
There was an error trying to create the App. Please try again later.
Causes possibles :
Dans la plupart des cas, le problème est dû à un devadmin incorrect identifiants spécifiés ou autorisations insuffisantes le rôle utilisateur "devadmin".
Validez la configuration de la connexion Edge pour le portail de développement en accédant à Configuration > Portail des développeurs et vérification du champ "État de la connexion" affiche "Connexion réussie". Sinon, le portail des développeurs ne pourra pas se connecter correctement Serveur de gestion Edge.
Diagnostic
- Activer DEBUG sur le portail des développeurs en accédant à Configuration > Portail des développeurs, puis en sélectionnant "Déboguer" sous "Journalisation périphérique" de sortie. Par défaut, les appels de l'API Management ne sont pas consignés.
- Reproduisez le problème.
- Accédez au journal en cliquant sur Rapports -> Journal récent Messages.
- Ouvrez le "Message" de type "LogPlugin" pour en savoir plus sur le erreur réelle.
Exemple de résultat affichant l'erreur 401 (erreur non autorisée)
Solution
Suivez les étapes décrites dans le tableau ci-dessous en fonction de l'erreur rencontrée:
Erreur |
Procédure de résolution |
401 Opération non autorisée |
Mettez à jour les identifiants devadmin appropriés sur le portail des développeurs et testez la connectivité. à nouveau. Consultez Ajouter et gérer des comptes utilisateur. |
403 Interdit |
Mettez à jour le rôle d'utilisateur devadmin sur l'organisation Edge afin de disposer des autorisations requises pour la ressource. Consultez la section Définir des rôles utilisateur et des autorisations. |