Problemas de comunicación en el portal para desarrolladores

Estás consultando la documentación de Apigee Edge.
Consulta la documentación de Apigee X.
Información

Síntoma

Es posible que encuentres uno o más de los siguientes problemas causados por problemas de comunicación entre el portal para desarrolladores y Edge:

  1. No se pueden realizar las siguientes tareas:
  2. Crear o actualizar SmartDocs
  3. Registra las apps de desarrollador.
  4. Enumerar productos de API
  5. Se muestra un error al acceder a la página de modelos de SmartDocs en el Portal para desarrolladores (selecciona Contenido > SmartDocs en el menú de administración del portal para desarrolladores).


  6. No se están generando las estadísticas de aplicaciones para desarrolladores.

Mensajes de error

  1. Se muestra un error al acceder a la pestaña "SmartDocs" en el portal para desarrolladores:

    The website encountered an unexpected error. Please try again later.
    
  2. Se muestra un error cuando se registra una app de desarrollador en el portal para desarrolladores:

    There was an error trying to create the App. Please try again later.
    

Causas posibles

En la mayoría de los casos, el problema se debe a que se especificaron credenciales de devadmin incorrectas o a que se asignaron permisos insuficientes a la función de usuario devadmin.

A fin de validar la configuración de conexión perimetral del portal para desarrolladores, navega a Configuración > Portal para desarrolladores y asegúrate de que el campo de estado de la conexión muestre la conexión correcta. De lo contrario, el portal para desarrolladores no podrá conectarse de forma correcta al servidor de Edge Management.

Diagnóstico

  1. Habilita el registro “DEBUG” en el portal para desarrolladores. Para ello, navega a Configuración > Portal para desarrolladores y selecciona Depuración en el umbral de registros de Edge. De forma predeterminada, las llamadas a la API de Management no se registran.
  1. Reproduce el problema.
  1. Para acceder al registro, navega a Informes -> Mensajes de registro recientes.

  1. Abre el mensaje del tipo “LogPlugin” para obtener más información sobre el error real.

Resultado de muestra que muestra el error 401 de no autorización

Resolución

Sigue los pasos correspondientes que se indican en la siguiente tabla según el error encontrado:

Error

Pasos para resolver el problema

401 Unauthorized

Actualiza las credenciales de devadmin correctas en el portal para desarrolladores y vuelve a probar la conectividad. Consulta el artículo Cómo agregar y administrar cuentas de usuario.

403 Forbidden

Actualiza la función de usuario de administrador de desarrollo en la organización de Edge a fin de que tenga los permisos necesarios para el recurso. Consulta Configura las funciones y los permisos del usuario.