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Documentazione di Apigee X. Informazioni
Sintomo
Si è verificato un errore durante l'invio di una richiesta API attiva utilizzando SmartDocs dallo sviluppatore portale.
Messaggi di errore
L'errore comune visualizzato sul Portale per gli sviluppatori è "Si è verificato un errore interno. Riprova la richiesta".
Possibili cause
Questo errore può verificarsi quando il portale per gli sviluppatori non riesce a ottenere una risposta dal backend (smartdocs) proxy o l'endpoint effettivo).
Diagnosi
Attiva "Strumenti per sviluppatori" nel browser e controlla la scheda Rete per identificare l'errore effettivo.
Nella tabella seguente sono elencati gli errori più comuni e le relative cause tipiche:
Errore |
Cause tipiche |
ERR_NAME_NOT_RESOLVED |
proxy SmartDocs configurato in modo errato o firewall di rete limitazioni |
Contenuto misto |
Portale configurato su HTTPS, richiesta di SmartDocs tramite HTTP |
500 - Errore interno del server |
Esaminiamo ciascuna di queste cause una per una e i passaggi per risolvere il problema.
proxy SmartDocs configurato in modo errato o firewall di rete limitazioni
Il messaggio "ERR_NAME_NOT_RESOLVED" indica che l'URL del proxy smartdocs non è configurato correttamente o la rete da cui si accede al portale è impossibile effettuare una chiamata all'URL del proxy smartdocs a causa di restrizioni del firewall. Gli smartdocs deve essere accessibile da internet o dalla rete interna (per le API interne).
Risoluzione
Assicurati che sia possibile accedere al proxy Smartdocs da tutte le reti richieste eseguendo il deployment il proxy smartdocs a un host virtuale su Edge con un nome host accessibili da internet.
Portale configurato tramite HTTPS, richiesta SmartDocs su HTTP
L'errore "Contenuti misti" indica che il proxy Smartdocs è essere richiamati tramite HTTP da una pagina caricata tramite HTTPS.
Risoluzione
Esponi il proxy Smartdocs su https per risolvere il problema. Puoi farlo eseguendo il deployment proxy smartdocs per includere un host virtuale configurato per l'utilizzo di TLS/SSL (in genere l'host virtuale "sicuro").
proxy SmartDocs che restituisce un'eccezione
Il messaggio 500 - Errore interno del server può essere causato da un problema con il proxy "smartdocs". In questo caso, noti che il proxy smartdocs restituisce questo .
Diagnosi
Utilizza lo strumento Trace per diagnosticare gli errori con il proxy "smartdocs", come descritto di seguito. Per ulteriori informazioni, consulta la sezione Utilizzo dello strumento Trace.
- Attiva la traccia per il proxy "smartdocs" in l'organizzazione "VALIDATE" per individuare il criterio specifico che restituisce l'errore 500 Internal Server Error.
- Seleziona il criterio specifico nella traccia per identificare la causa dell'errore.
Risoluzione
Correggi l'errore identificato. Se hai bisogno di aiuto, contatta l'assistenza Apigee Edge.
I processori di messaggi Edge non sono in grado di chiamare l'endpoint API pubblicato
500 - L'errore interno del server può verificarsi anche quando i processori di messaggi appartenenti l'organizzazione che ospita il proxy Smartdocs non è in grado di chiamare l'endpoint API.
Diagnosi
Utilizza lo strumento Trace per diagnosticare gli errori con il proxy "smartdocs", come descritto di seguito. Per ulteriori informazioni, consulta la sezione Utilizzo dello strumento Trace.
- Attiva trace per "smartdocs" proxy nell'organizzazione "VALIDATE" per individuare il criterio specifico che restituisce l'errore interno 500 del server.
- Nella traccia UI di esempio mostrata sopra, è stato rilevato che il criterio JavaScript "BuildTargetAPIRequest" non riesce a eseguire l'URL di destinazione.
- Ottenere l'URL di destinazione dal criterio JavaScript "BuildTargetAPIRequest".
- Effettua una chiamata diretta all'URL dai nodi del processore di messaggi associati a
"VALIDATE" dell'organizzazione come mostrato di seguito:
curl -v <target URL>
- Correggi gli eventuali errori rilevati.
Risoluzione
- Assicurati che le API pubblicate sul portale per gli sviluppatori possano essere richiamate dai processori di messaggi associati all'organizzazione "VALIDATE" e correggi eventuali errori riscontrati.
- Se sei in grado di eseguire la chiamata API direttamente dal processore di messaggi, molto probabile che dovreste essere in grado di eseguire l'API anche tramite SmartDocs.
- Esegui la chiamata API tramite SmartDocs e controlla se il problema è stato risolto.