Error interno del portal para desarrolladores

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Síntoma

Se produjo un error al realizar una solicitud a la API activa con SmartDocs del desarrollador portal.

Mensajes de error

El error más común que aparece en el portal para desarrolladores es el siguiente: "Se produjo un error interno. Vuelve a enviar la solicitud".

Causas posibles

Este error puede ocurrir cuando el portal para desarrolladores no recibe una respuesta del backend (documentos inteligentes o el extremo real).

Diagnóstico

Habilita las "Herramientas para desarrolladores" en tu navegador y revisa la pestaña Red para hacer lo siguiente: identificar el error real.

En la siguiente tabla, se indican los errores comunes y sus causas típicas:

Error

Causas típicas

ERR_NAME_NOT_RESOLVED

El proxy de SmartDocs está mal configurado o el firewall de red restricciones

Contenido mixto

Portal configurado a través de HTTPS, solicitud de SmartDocs HTTP

500: Error interno del servidor

Veamos cada una de estas causas una por una y los pasos para resolver el problema.

El proxy de SmartDocs está mal configurado o el firewall de red restricciones

El mensaje “ERR_NAME_NOT_RESOLVED” indica que La URL del proxy de smartdocs está mal configurada o la red desde la que se accede al portal No se puede realizar una llamada a la URL del proxy de Smartdocs debido a restricciones del firewall. Los Smartdocs se debe poder acceder a él desde Internet o desde la red interna (para las APIs internas).

Solución

Asegúrese de que se pueda acceder al proxy de Smartdocs desde todas las redes requeridas implementando el proxy de Smartdocs a un host virtual en Edge con un nombre de host y accesible desde Internet.

Portal configurado a través de HTTPS, solicitud de SmartDocs a través de HTTP

El error “Contenido mixto” indica que el proxy de smartdocs está que se llama a través de HTTP desde una página cargada en HTTPS.

Solución

Se expuso el proxy de Smartdocs a través de HTTPS para resolver el problema. Puedes hacerlo implementando el que incluya un host virtual configurado para usar TLS/SSL (por lo general, el host virtual “seguro”).

El proxy de SmartDocs muestra una excepción

El mensaje 500: Error interno del servidor puede deberse a un problema con el proxy de “documentos inteligentes”. En este caso, observas que el proxy de smartdocs devuelve .

Diagnóstico

Utilizar la herramienta Trace para diagnosticar errores con el proxy de “smartdocs”, como se describe a continuación. Para obtener más información, consulta Cómo usar la herramienta Trace.

  1. Habilitar el seguimiento para el proxy “smartdocs” en la organización “VALIDATE” para localizar la política específica que y se muestra el error interno del servidor 500.

  1. Selecciona la política específica en el seguimiento para identificar la causa del error.

Solución

Corrige el error identificado. Si necesitas ayuda, comunícate con el equipo de asistencia de Apigee Edge.

Los procesadores de mensajes perimetrales no pueden llamar al extremo de API publicado

500 - Error interno del servidor también puede ocurrir cuando los procesadores de mensajes que pertenecen al que aloja el proxy de Smartdocs no puede llamar al extremo de la API.

Diagnóstico

Utilizar la herramienta Trace para diagnosticar errores con el proxy de “smartdocs”, como se describe a continuación. Para obtener más información, consulta Cómo usar la herramienta Trace.

  1. Habilita el seguimiento para “documentos inteligentes”. proxy en la organización “VALIDATE” para ubicar la política específica que muestra el error interno del servidor 500.

  1. En el ejemplo de seguimiento de IU que se muestra arriba, se ve que la política de JavaScript “BuildTargetAPIRequest” no puede ejecutar la URL de destino.
  1. Obtén la URL de destino de la política de JavaScript “BuildTargetAPIRequest”.
  1. Realiza una llamada directa a la URL desde los nodos del procesador de mensajes asociados con Organización “VALIDATE” como se muestra a continuación:
    curl -v <target URL>
    
  1. Corrige cualquier error observado.

Solución

  1. Asegúrate de que las APIs publicadas en el portal para desarrolladores se puedan invocar desde Message Processors asociada con la organización “VALIDATE” y corregir cualquier error que encuentran.
  1. Si puedes ejecutar la llamada a la API directamente desde Message Processor, es muy probable que también pueda ejecutar la API mediante SmartDocs.
  1. Ejecuta la llamada a la API con SmartDocs y verifica si se solucionó el problema.