Внутренняя ошибка портала разработчика

Вы просматриваете документацию Apigee Edge .
Перейдите к документации Apigee X.
информация

Симптом

Возникла ошибка при выполнении запроса API в реальном времени с помощью SmartDocs с портала разработчика.

Сообщения об ошибках

Распространенная ошибка, наблюдаемая на портале разработчика: « Произошла внутренняя ошибка». Пожалуйста, повторите ваш запрос ».

Возможные причины

Эта ошибка может возникнуть, когда порталу разработчика не удается получить ответ от серверной части (прокси-сервера smartdocs или фактической конечной точки).

Диагностика

Включите «Инструменты разработчика» в своем браузере и проверьте вкладку «Сеть», чтобы определить фактическую ошибку.

Распространенные ошибки и их типичные причины перечислены в следующей таблице:

Ошибка

Типичная причина(ы)

ERR_NAME_NOT_RESOLVED

Прокси-сервер SmartDocs неправильно настроен или ограничения сетевого брандмауэра

Смешанный контент

Портал настроен через HTTP, запрос SmartDocs через HTTP

500 — Внутренняя ошибка сервера

Давайте рассмотрим каждую из этих причин одну за другой и шаги по решению проблемы.

Прокси-сервер SmartDocs неправильно настроен или ограничения сетевого брандмауэра

Сообщение « ERR_NAME_NOT_RESOLVED » указывает на то, что URL-адрес прокси-сервера smartdocs настроен неправильно или сеть, из которой осуществляется доступ к порталу, не может выполнить вызов URL-адреса прокси-сервера smartdocs из-за ограничений брандмауэра. Прокси-сервер smartdocs должен быть доступен из Интернета или из внутренней сети (для внутренних API).

Разрешение

Убедитесь, что к прокси-серверу smartdocs можно получить доступ из всех необходимых сетей, развернув прокси-сервер smartdocs на виртуальном хосте в Edge с именем хоста, доступным из Интернета.

Портал настроен через HTTPS, запрос SmartDocs через HTTP

Ошибка « Смешанный контент » указывает на то, что прокси-сервер smartdocs вызывается по HTTP со страницы, загруженной по HTTPS.

Разрешение

Откройте прокси-сервер SmartDocs через https, чтобы решить проблему. Это можно сделать, развернув прокси-сервер smartdocs, включив в него виртуальный хост , настроенный на использование TLS/SSL (обычно «безопасный» виртуальный хост).

Прокси SmartDocs возвращает исключение

Сообщение 500 — внутренняя ошибка сервера может быть вызвано проблемой с прокси-сервером «smartdocs». В этом случае вы заметите, что прокси-сервер smartdocs возвращает эту ошибку.

Диагностика

Используйте инструмент «Трассировка» для диагностики ошибок с помощью прокси-сервера «smartdocs», как описано ниже. Дополнительную информацию см. в разделе Использование инструмента «Трассировка» .

  1. Включите трассировку для прокси-сервера « smartdocs » в организации « VALIDATE », чтобы найти конкретную политику, которая возвращает 500 Internal Server Error.

  1. Выберите конкретную политику в трассировке, чтобы определить причину ошибки.

Разрешение

Исправьте выявленную ошибку. Если вам нужна помощь, обратитесь в службу поддержки Apigee Edge .

Пограничные процессоры сообщений не могут вызвать опубликованную конечную точку API

500 — внутренняя ошибка сервера также может возникнуть, когда процессоры сообщений, принадлежащие организации, в которой размещен прокси-сервер Smartdocs, не могут вызвать конечную точку API.

Диагностика

Используйте инструмент «Трассировка» для диагностики ошибок с помощью прокси-сервера «smartdocs», как описано ниже. Дополнительную информацию см. в разделе Использование инструмента «Трассировка» .

  1. Включите трассировку для прокси-сервера « smartdocs » в организации « VALIDATE », чтобы найти конкретную политику, которая возвращает 500 Internal Server Error.

  1. В примере трассировки пользовательского интерфейса, показанном выше, видно, что политика JavaScript « BuildTargetAPIRequest » не может выполнить целевой URL-адрес.
  1. Получите целевой URL-адрес из политики JavaScript « BuildTargetAPIRequest ».
  1. Выполните прямой вызов URL-адреса из узлов процессора сообщений, связанных с организацией « VALIDATE », как показано ниже:
    curl -v <target URL>
  1. Исправьте обнаруженную ошибку.

Разрешение

  1. Убедитесь, что API, опубликованные на портале разработчика, можно вызывать из процессоров сообщений, связанных с организацией « VALIDATE », и исправьте любые возникшие ошибки.
  1. Если вы можете выполнить вызов API непосредственно из процессора сообщений, весьма вероятно, что вы также сможете выполнить API через SmartDocs.
  1. Выполните вызов API через SmartDocs и проверьте, устранена ли проблема.