Ошибка установки: невозможно открыть apigee-repo.rpm.

Вы просматриваете документацию Apigee Edge .
Перейдите к документации Apigee X.
информация

Симптом

Во время установки или перехода на более новую версию Apigee Edge для частного облака вы увидите ошибку Cannot open: https:// USERNAME : PASSWORD @software.apigee.com/apigee-repo.rpm

Сообщение об ошибке

Вы увидите следующую ошибку:

Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm. Skipping.

Эта ошибка обычно возникает при установке apigee-setup utility и зависимостей:

[root@machinename ~]# sudo bash /tmp/bootstrap_4.50.00.sh apigeeuser=USERNAME
Apigee bootstrap 1.0-38 (OPDK_5000, 2020.11.30,19:31)

=== Obtaining creds for software.apigee.com:

Please enter value for password:

=== Begin work ...

=== Checking for presence of misc commands:

=== Checking distro:

=== Checking architecture:

=== Checking OS:

=== Checking SELinux status

=== Configuring package manager:
+ rpm -qa apigee*
+ rpm -e apigee-repo
error: package apigee-repo is not installed
(error can be ignored)
+ rpm -e apigeeprio-repo
error: package apigeeprio-repo is not installed
(error can be ignored)
+ yum install -y https://apigee:***@software.apigee.com/apigee-repo.rpm
Loaded plugins: enabled_repos_upload, langpacks, package_upload, priorities,
: product-id, protectbase, search-disabled-repos, subscription-
: manager
HTTP error (410 - Gone): Unit d98c371e-06bc-4afc-a216-effb1ebc9bce has been deleted
Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm. Skipping.
Error: Nothing to do
Uploading Enabled Repositories Report
Loaded plugins: langpacks, priorities, product-id, protectbase, subscription-
: manager
HTTP error (410 - Gone): Unit d98c371e-06bc-4afc-a216-effb1ebc9bce has been deleted
bootstrap_4.50.00.sh: Error: Repo configuration failed

[root@machinename ~]#

Возможные причины

Вот возможные причины этой ошибки:

Причина Описание Инструкции по устранению неполадок применимы для
Проблемы с подключением к Интернету или сетью Нет исходящего подключения к Интернету или возникли проблемы с сетевым подключением. Только для пользователей Edge Private Cloud
Неверное имя пользователя или пароль Использование неправильного имени пользователя или пароля для репозитория software.apigee.com . Только для пользователей Edge Private Cloud
Пароль содержит специальные символы Пароль для репозитория software.apigee.com содержит специальные символы. Только для пользователей Edge Private Cloud

Причина: проблемы с подключением к Интернету или сетевым подключением.

Диагностика

  1. Проверьте, есть ли у вас исходящее подключение к Интернету на компьютере, на котором вы видите вышеуказанную ошибку.
  2. Если у вас есть исходящее подключение к Интернету, проверьте сетевое подключение к software.apigee.com , используя один из следующих механизмов:

    неткэт

    Использование Netcat:

    1. Если у вас установлен netcat , выполните следующую команду:

      nc -v software.apigee.com 443
      

      Вы должны получить сообщение, подобное следующему:

      Connection to software.apigee.com 443 port [tcp/https] succeeded!

      ИЛИ

      Connected to IP_ADDRESS:443
    2. Если вы не видите ни одного из приведенных выше сообщений или видите ошибки, значит, у вас возникла проблема с сетевым подключением к software.apigee.com.

    телнет

    Используя телнет:

    1. Если у вас не установлен netcat , вы можете использовать следующую команду telnet для проверки подключения к Интернету:

      telnet software.apigee.com 443
      

      При подключении вы должны увидеть следующий вывод:

      Connected to software.apigee.com
    2. Если вы не видите ни одного из приведенных выше сообщений или видите ошибки, значит, у вас возникла проблема с сетевым подключением к software.apigee.com.

Разрешение

Если у вас нет подключения к Интернету или одна из команд ( netcat или telnet ) не выполнена, значит, у вас ограничено сетевое подключение или оно отсутствует. Чтобы устранить проблему, обратитесь к сетевому администратору.

Причина: Неверное имя пользователя или пароль.

Диагностика

  1. Убедитесь, что вы передаете правильное имя пользователя и пароль команде, которая устанавливает apigee-service utility :

    sudo bash /tmp/bootstrap_4.50.00.sh apigeeuser=USERNNAME apigeepassword=PASSWORD
    
  2. Вы также можете напрямую вызвать URL-адрес software.apigee.com и проверить вывод:

    curl -i -u USERNNAME>:PASSWORD https://software.apigee.com/apigee-repo.rpm
    
  3. Если вы получаете ошибку 401 Unauthorized , это означает, что вы используете неправильное имя пользователя и/или пароль.

Разрешение

Убедитесь, что вы используете правильное имя пользователя и пароль при установке apigee-setup utility .

Причина: Пароль содержит специальные символы.

Диагностика

  1. Убедитесь, что пароль для software.apigee.com не содержит специальных символов. Например: > , $ , @ или * .
  2. Если в пароле есть специальные символы, это причина данной ошибки.

Разрешение

  1. Используйте escape-символ обратной косой черты ( \ ) перед любым специальным символом.
  2. Например, если ваш пароль — pa$$w0rd , вам следует указать пароль как pa\$\$w0rd .

Ссылки

Установите утилиту настройки Edge apigee.