El dominio personalizado no coincide con el registro CNAME en el portal integrado para desarrolladores

Estás viendo la documentación de Apigee Edge.
Ve a la Documentación de Apigee X.
información

Síntoma

La configuración del dominio personalizado en el portal integrado para desarrolladores no funcionará si El dominio no coincide con el registro CNAME (nombre canónico): Publicar > Portales > Desarrollador Portal > Configuración > Dominios.

Mensaje de error

Se muestra el siguiente mensaje de error:

Domain does not match CNAME record

El mensaje de error se muestra en la IU de Edge como se indica a continuación:

Portales > Portal para desarrolladores > Configuración > Dominios" title="Dominios">

Causas posibles

Causa Descripción Instrucciones de solución de problemas aplicables para
Falta el registro CNAME del dominio o es incorrecto El dominio personalizado debe tener un registro CNAME que apunte a {orgname}-portal.apigee.net De lo contrario, fallará la configuración del dominio personalizado. Usuarios de la nube pública perimetral

Causa: Falta el registro CNAME del dominio o es incorrecto

Diagnóstico

Sigue estos pasos para diagnosticar el problema:

  1. Ejecuta el siguiente comando para buscar la configuración de DNS del nombre de dominio personalizado:
    dig +noall +answer {custom-domain}
  2. El resultado del comando anterior debe contener un registro CNAME que apunte a Nombre de dominio {org}-portal.apigee.net. Por ejemplo:
    dig +noall +answer {custom-domain}
    
    {custom-domain}	{TTL}	IN	CNAME	{orgname}-portal.apigee.net.
  3. Si el resultado del comando muestra que el dominio personalizado no tiene un registro CNAME. contiene el registro CNAME que no coincide{org}-portal.apigee.net,entonces es la causa de que falle la creación del host virtual. Como resultado, el mensaje de error anterior se que se muestra al usuario en la página de configuración del dominio personalizado de la IU de Edge.

Solución

Si el dominio personalizado no contiene un registro CNAME que apunte a {orgname}-portal.apigee.net y, luego, sigue estos pasos para resolver el problema:

  1. Quita todos los registros CNAME existentes que se encuentren en la configuración de DNS del dominio personalizado.
  2. Agrega un registro CNAME a tu nombre de dominio (que deseas usar en la página de dominio personalizado) para que apunte a {orgname}-portal.apigee.net.
  3. Selecciona el nombre de dominio personalizado específico (que tenga el registro CNAME que apunte a {orgname}-portal.apigee.net) en el menú desplegable del Dominio en la la página de configuración del dominio personalizado.
  4. Si subiste un certificado comodín al almacén de claves, sigue estos pasos:
    1. Selecciona el nombre del dominio en el menú desplegable.
    2. Completa el nombre de subdominio correcto
  5. Configura el almacén de claves, alias o nombre de dominio en la página de configuración de dominio personalizado del portal para desarrolladores integrado.
  6. Haz clic en Guardar.

Si el problema persiste, consulta Recopila información de diagnóstico.

Se debe recopilar información de diagnóstico

Si el problema persiste después de seguir las instrucciones anteriores, realiza el siguiente diagnóstico y compartirla con el equipo de asistencia de Apigee Edge:

  • Nombre de la organización de Apigee Edge Cloud
  • Nombre del portal para desarrolladores integrado de Apigee Edge Cloud
  • Nombre del almacén de claves creado en el entorno del portal
  • Nombre del alias
  • Nombre de dominio personalizado
  • Una captura de pantalla de la página de configuración del dominio personalizado donde aparece el mensaje de error