El dominio personalizado no coincide con el registro CNAME en el portal integrado para desarrolladores

Estás consultando la documentación de Apigee Edge.
Consulta la documentación de Apigee X.
Información

Síntoma

La configuración del dominio personalizado en el portal para desarrolladores integrado no funcionará si el dominio personalizado no coincide con el registro CNAME (nombre canónico): Publicar > Portales > Portal para desarrolladores > Configuración > Dominios.

Mensaje de error

Se muestra el siguiente mensaje de error:

Domain does not match CNAME record

El mensaje de error aparece en la IU de Edge como se indica a continuación:

Portales > Portal para desarrolladores > Configuración > Dominios" title="Domains">

Causas posibles

Causa Descripción Instrucciones de solución de problemas aplicables para
Falta el registro CNAME del dominio o es incorrecto El dominio personalizado debe tener un registro CNAME que dirija a {orgname}-portal.apigee.net. De lo contrario, la configuración del dominio personalizado fallará. Usuarios de la nube pública perimetral

Causa: Falta el registro CNAME del dominio o es incorrecto

Diagnóstico

Sigue estos pasos para diagnosticar el problema:

  1. Ejecuta el siguiente comando para buscar la configuración de DNS del nombre de dominio personalizado:
    dig +noall +answer {custom-domain}
  2. El resultado del comando anterior debe contener un registro CNAME que dirija al nombre de dominio {org}-portal.apigee.net. Por ejemplo:
    dig +noall +answer {custom-domain}
    
    {custom-domain}	{TTL}	IN	CNAME	{orgname}-portal.apigee.net.
  3. Si el resultado del comando muestra que el dominio personalizado no tiene un registro CNAME o contiene el registro CNAME que no coincide{org}-portal.apigee.net,, esa es la causa de que falle la creación del host virtual. Como resultado, se muestra al usuario el mensaje de error anterior en la página de configuración de dominio personalizado de la IU de Edge.

Resolución

Si el dominio personalizado no contiene un registro CNAME que dirija a {orgname}-portal.apigee.net, sigue estos pasos para resolver el problema:

  1. Quita todos los registros CNAME existentes que se encuentren en la configuración de DNS del dominio personalizado.
  2. Agrega un registro CNAME a tu nombre de dominio (que te gustaría usar en la página de dominio personalizado) para que apunte a {orgname}-portal.apigee.net.
  3. Selecciona el nombre de dominio personalizado específico (que tiene un registro CNAME que apunta a {orgname}-portal.apigee.net) en el menú desplegable de Dominio en la página de configuración de dominio personalizado.
  4. Si subiste un certificado comodín al almacén de claves, haz lo siguiente:
    1. Selecciona el nombre del dominio en el menú desplegable.
    2. Completa el nombre de subdominio correcto
  5. Configura el almacén de claves, el alias y el nombre de dominio en la página de configuración de dominio personalizado del portal para desarrolladores integrado.
  6. Haz clic en Guardar.

Si el problema persiste, consulta Recopila información de diagnóstico.

Se debe recopilar información de diagnóstico

Si el problema persiste después de seguir las instrucciones anteriores, recopila la siguiente información de diagnóstico y compártela con el equipo de asistencia de Apigee Edge:

  • Nombre de la organización de Apigee Edge Cloud
  • Nombre del portal para desarrolladores integrado de Apigee Edge Cloud
  • Nombre del almacén de claves creado en el entorno del portal
  • Nombre del alias
  • Nombre de dominio personalizado
  • Captura de pantalla de la página de configuración de dominio personalizado que captura el mensaje de error