El certificado TLS venció en la configuración del dominio personalizado del portal para desarrolladores integrado

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Información

Síntoma

La configuración del dominio personalizado en el portal para desarrolladores integrado no funcionará si la cadena de certificados de TLS venció: Publicar > Portals > Portal para desarrolladores > Configuración > Dominios.

Mensaje de error

Se muestra el siguiente mensaje de error:

Certificate expired

El mensaje de error aparece en la IU de Edge como se indica a continuación:

Portales > Portal para desarrolladores > Configuración > Dominios" title="Domains">

Causas posibles

Causa Description> Instrucciones de solución de problemas aplicables para
Venció la cadena de certificados TLS Si la cadena de certificados de TLS proporcionada venció, fallará la configuración del dominio personalizado. Usuarios de la nube pública perimetral

Causa: Venció la cadena de certificados de TLS

Diagnóstico

Sigue estos pasos para diagnosticar el problema:

  1. Verifica la fecha y hora de vencimiento de la cadena de certificados de TLS.
  2. Si se venció la cadena de certificados TLS específica, se producirá un error en el proceso de creación del host virtual en el portal para desarrolladores integrado. Como resultado, se muestra al usuario el mensaje de error anterior en la página de configuración de dominio personalizado de la IU de Edge.

Resolución

Si comprobaste que la cadena de certificados TLS venció, realiza los siguientes pasos para resolver el problema:

  1. Obtén una cadena de certificados TLS nueva de la autoridad certificadora correspondiente.
  2. Convierte la cadena de certificados TLS al formato PEM.
  3. Valida que la cadena de certificados de TLS sea válida.
  4. Quita la cadena de certificados TLS existente del almacén de claves específico.
  5. Sube el archivo que contiene la cadena de certificados de TLS en formato PEM y el archivo que contiene la clave privada al almacén de claves con un alias de clave en la IU de Edge o la API de Management.
  6. Configura el almacén de claves, el alias y el nombre de dominio en la página de configuración de dominio personalizado del portal para desarrolladores integrado.
  7. Haz clic en Guardar.

Si el problema persiste, consulta Recopila información de diagnóstico.

Se debe recopilar información de diagnóstico

Si el problema persiste después de seguir las instrucciones anteriores, recopila la siguiente información de diagnóstico y compártela con el equipo de asistencia de Apigee Edge:

  • Nombre de la organización de Apigee Edge Cloud
  • Nombre del portal para desarrolladores integrado de Apigee Edge Cloud
  • Nombre del almacén de claves creado en el entorno del portal
  • Nombre del alias
  • Nombre de dominio personalizado
  • Captura de pantalla de la página de configuración de dominio personalizado que captura el mensaje de error