Stai visualizzando la documentazione di Apigee Edge.
Vai alla sezione
Documentazione di Apigee X. Informazioni
Sintomo
I problemi relativi ai dati, comunemente noti come problemi di cablaggio, possono manifestarsi come uno dei seguenti sintomi:
- Errori durante l'avvio dei server di gestione
- Errori di deployment
- Errori Datastore nella UI
- Problemi di connettività tra data center tra processori di messaggi e server di gestione
- Analytics non mostra dati
Questi problemi non riguardano l'infrastruttura di ZooKeeper, ma i dati non validi che è disponibile nell'albero di ZooKeeper.
Possibili cause
Le cause tipiche di questo problema sono:
- Nodi collegati con il nome della regione o del pod errato durante l'installazione a causa di errori nella file di installazione invisibile.
- Un'installazione non riuscita di un componente crea registrazioni duplicate quando si reinstalla il componente più volte. In questo caso, è necessaria la pulizia per rimuovere la registrazione con UUID errati.
Diagnosi
Per effettuare la diagnosi, raccogli i seguenti dati:
- Diagramma della topologia, con nome host e indirizzi IP di ciascun nodo e il componente Apigee
esistenti sul nodo. Una mappatura come la seguente, che utilizza il profilo dell'installazione di Apigee,
molto utile:
DC-1 DS: ip1 hostname DS: ip2 hostname DS: ip3 hostname MS: ip4 hostname RMP: ip5 hostname RMP: ip6 hostname SAX: ip7 hostname DC-2 DS: ip8 hostname DS: ip9 hostname DS: ip10 hostname MS: ip11 hostname RMP: ip12 hostname RMP: ip13 hostname SAX: ip14 hostname
- Genera l'output dell'albero di ZooKeeper per controllare il cablaggio:
/opt/apigee/apigee-zookeeper/contrib/zk-tree.sh > zk-tree-output.txt
- Per semplificare la verifica dei dati nella struttura di ZooKeeper, esegui la seguente API di gestione
per ottenere l'elenco degli UUID del server in ciascun data center:
Server gateway
curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=gateway®ion=region-name"
Server centrali
curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=central®ion=region-name"
Server di Analytics
curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=analytics®ion=region-name"
- Controlla gli UUID su ogni componente e assicurati che corrispondano a ciò che vedi in ZooKeeper
albero:
Router
curl 0:8081/v1/servers/self/uuid
Processore di messaggi
curl 0:8082/v1/servers/self/uuid
Agente Qpid
curl 0:8083/v1/servers/self/uuid
Agente Postgres
curl 0:8084/v1/servers/self/uuid
- Utilizza i dati UUID per cercare nell'output ad albero di ZooKeeper generato nel passaggio 2 per convalidare il valore il cablaggio dei componenti e rimuovere eventuali registrazioni duplicate per il componente che hanno il UUID errati.
- Utilizza le chiamate API di gestione elencate qui per la correzione della registrazione del datastore. Componenti come Router, Messaggi Processori, Postgres e Qpid si autoregistrano in ZooKeeper durante l'avvio.
Risoluzione
I problemi relativi ai dati di ZooKeeper devono essere affrontati caso per caso. Dati in ZooKeeper si basa sulle topologie Apigee Edge e varia in base a ciascun caso d'uso. Se uno dei problemi quando si manifestano i sintomi, raccogli i dati come spiegato nella sezione precedente e Contatta l'assistenza Apigee Edge.