Problemas con los datos de Zookeeper

Estás viendo la documentación de Apigee Edge.
Ve a la Documentación de Apigee X.
información

Síntoma

Los problemas relacionados con los datos, conocidos comúnmente como problemas de cableado, los siguientes síntomas:

  • Fallas durante el inicio de los servidores de administración
  • Fallas de implementación
  • Errores de Datastore en la IU
  • Problemas de conectividad entre centros de datos entre procesadores de mensajes y servidores de administración
  • Estadísticas sin datos

Estos problemas no están relacionados con la infraestructura de ZooKeeper, sino con datos no válidos que está disponible en el árbol de ZooKeeper.

Causas posibles

Las causas típicas de este problema son las siguientes:

  1. Nodos conectados a la región o al nombre del Pod incorrectos durante la instalación debido a errores en el archivo de instalación silencioso.
  2. Una instalación con errores de un componente crea registros duplicados cuando vuelves a instalar el varias veces. En este caso, la limpieza es necesaria para quitar el registro con el UUIDs incorrectos.

Diagnóstico

Para diagnosticar, recopila los siguientes datos:

  1. Diagrama de topología con el nombre de host y las direcciones IP de cada nodo y qué componente de Apigee existen en el nodo. Se usaría una asignación como la siguiente con el perfil de la instalación de Apigee serán más útiles:
    DC-1
    DS: ip1 hostname
    DS: ip2 hostname
    DS: ip3 hostname
    MS: ip4 hostname
    RMP: ip5 hostname
    RMP: ip6 hostname
    SAX: ip7 hostname
    
    DC-2
    DS: ip8 hostname
    DS: ip9 hostname
    DS: ip10 hostname
    MS: ip11 hostname
    RMP: ip12 hostname
    RMP: ip13 hostname
    SAX: ip14 hostname
    
  2. Genera un resultado de árbol de ZooKeeper para verificar el cableado:
    /opt/apigee/apigee-zookeeper/contrib/zk-tree.sh > zk-tree-output.txt
    
  3. Para facilitar la verificación de los datos en el árbol de ZooKeeper, ejecuta la siguiente API de administración. llamadas para obtener la lista de UUID del servidor en cada uno de los centros de datos:

    Servidores de puerta de enlace

    curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=gateway&region=region-name"
    

    Servidores centrales

    curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=central&region=region-name"
    

    Servidores de Analytics

    curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=analytics&region=region-name"
    
  4. Verifica los UUID de cada componente y asegúrate de que coincidan con lo que ves en ZooKeeper árbol:

    Router

    curl 0:8081/v1/servers/self/uuid
    

    Message Processor

    curl 0:8082/v1/servers/self/uuid
    

    Agente de Qpid

    curl 0:8083/v1/servers/self/uuid
    

    Agente de Postgres

    curl 0:8084/v1/servers/self/uuid
    
  5. Utiliza los datos del UUID para buscar el resultado del árbol de ZooKeeper generado en el paso 2 para validar el el cableado de los componentes y quitar los registros duplicados del componente que tiene el UUIDs incorrectos.
  6. Utiliza las llamadas a la API de administración que se enumeran . aquí para corregir el registro del almacén de datos. Los componentes como routers, mensajes Los procesadores, Postgres y Qpid se registran automáticamente en ZooKeeper durante el tiempo de inicio.

Solución

Los problemas relacionados con los datos de ZooKeeper deben abordarse caso por caso. Datos en ZooKeeper se basa en topologías de Apigee Edge y varía según cada caso de uso. Si uno de los problemas tiene síntomas, recopile los datos como se explicó en la sección anterior y comunícate con el equipo de asistencia de Apigee Edge.