Masalah Data Zookeeper

Anda sedang melihat dokumentasi Apigee Edge.
Buka Dokumentasi Apigee X.
info

ini.

Gejala

Masalah terkait data, umumnya disebut masalah {i>wiring<i}, dapat terlihat sebagai salah satu gejala berikut:

  • Kegagalan saat memulai server Pengelolaan
  • Kegagalan deployment
  • Error Datastore pada UI
  • Masalah konektivitas lintas pusat data antara Pemroses Pesan dan server Pengelolaan
  • Analytics tidak menampilkan data

Masalah ini tidak terkait dengan infrastruktur ZooKeeper, tapi terkait dengan data tidak valid yang tersedia di pohon ZooKeeper.

Kemungkinan penyebab

Penyebab umum untuk masalah ini adalah:

  1. Node yang dihubungkan ke region atau nama pod yang salah selama penginstalan karena terjadi kesalahan pada instalasi otomatis.
  2. Penginstalan komponen yang gagal akan membuat pendaftaran duplikat saat Anda menginstal ulang komponen beberapa kali. Dalam hal ini, pembersihan diperlukan untuk menghapus pendaftaran dengan UUID salah.

Diagnosis

Untuk mendiagnosis, kumpulkan data berikut:

  1. Diagram topologi, dengan nama host dan alamat IP setiap node dan komponen Apigee ada pada node. Pemetaan seperti berikut ini menggunakan profil penginstalan Apigee akan membantu:
    DC-1
    DS: ip1 hostname
    DS: ip2 hostname
    DS: ip3 hostname
    MS: ip4 hostname
    RMP: ip5 hostname
    RMP: ip6 hostname
    SAX: ip7 hostname
    
    DC-2
    DS: ip8 hostname
    DS: ip9 hostname
    DS: ip10 hostname
    MS: ip11 hostname
    RMP: ip12 hostname
    RMP: ip13 hostname
    SAX: ip14 hostname
    
  2. Buat output hierarki ZooKeeper untuk memeriksa jaringan kabel:
    /opt/apigee/apigee-zookeeper/contrib/zk-tree.sh > zk-tree-output.txt
    
  3. Untuk memudahkan verifikasi data di hierarki ZooKeeper, jalankan API pengelolaan berikut untuk mendapatkan daftar UUID server di setiap pusat data:

    Server Gateway

    curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=gateway&region=region-name"
    

    Server Pusat

    curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=central&region=region-name"
    

    Server Analytics

    curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=analytics&region=region-name"
    
  4. Periksa UUID setiap komponen dan pastikan UUID ini cocok dengan yang Anda lihat di ZooKeeper hierarki:

    Router

    curl 0:8081/v1/servers/self/uuid
    

    Pemroses Pesan

    curl 0:8082/v1/servers/self/uuid
    

    Agen Qpid

    curl 0:8083/v1/servers/self/uuid
    

    Agen Postgres

    curl 0:8084/v1/servers/self/uuid
    
  5. Gunakan data UUID untuk mencari {i>output<i} pohon ZooKeeper yang dihasilkan pada langkah #2 untuk memvalidasi jaringan kabel dan menghapus pendaftaran duplikat untuk komponen yang memiliki UUID salah.
  6. Menggunakan panggilan API pengelolaan yang tercantum di sini untuk mengoreksi pendaftaran datastore. Komponennya seperti {i>Router<i}, {i>Message<i} Prosesor, Postgres, dan Qpid mendaftar sendiri ke ZooKeeper selama waktu startup.

Resolusi

Masalah terkait data ZooKeeper perlu ditangani secara kasus per kasus. Data di ZooKeeper didasarkan pada topologi Apigee Edge dan bervariasi sesuai dengan kasus penggunaan. Jika salah satu masalah gejala yang dialami, kumpulkan data seperti yang dijelaskan di bagian sebelumnya dan hubungi Dukungan Apigee Edge.