Problemas con los datos de Zookeeper

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Información

Síntoma

Los problemas relacionados con los datos, comúnmente conocidos como problemas de cableado, pueden manifestarse como uno de los siguientes síntomas:

  • Fallas durante el inicio de los servidores de administración
  • Fallas de implementación
  • Errores de Datastore en la IU
  • Problemas de conectividad entre centros de datos entre procesadores de mensajes y servidores de administración
  • Analytics no muestra datos

Estos problemas no están relacionados con la infraestructura de ZooKeeper, sino con datos no válidos que están disponibles en el árbol de ZooKeeper.

Causas posibles

Las causas típicas de este problema son las siguientes:

  1. Nodos conectados a la región o al nombre de Pod incorrectos durante la instalación debido a errores en el archivo de instalación silencioso.
  2. Una instalación con errores de un componente crea registros duplicados cuando reinstalas el componente varias veces. En este caso, se requiere una limpieza para quitar el registro con los UUID incorrectos.

Diagnóstico

Para realizar un diagnóstico, recopila los siguientes datos:

  1. Diagrama de topología, con el nombre de host y las direcciones IP de cada nodo y qué componente de Apigee existe en el nodo. Una asignación como la siguiente que usa el perfil de la instalación de Apigee sería más útil:
    DC-1
    DS: ip1 hostname
    DS: ip2 hostname
    DS: ip3 hostname
    MS: ip4 hostname
    RMP: ip5 hostname
    RMP: ip6 hostname
    SAX: ip7 hostname
    
    DC-2
    DS: ip8 hostname
    DS: ip9 hostname
    DS: ip10 hostname
    MS: ip11 hostname
    RMP: ip12 hostname
    RMP: ip13 hostname
    SAX: ip14 hostname
    
  2. Genera un resultado de árbol de ZooKeeper para verificar el cableado:
    /opt/apigee/apigee-zookeeper/contrib/zk-tree.sh > zk-tree-output.txt
    
  3. Para facilitar la verificación de los datos en el árbol de ZooKeeper, ejecuta las siguientes llamadas a la API de administración a fin de obtener la lista de UUIDs de servidor en cada uno de los centros de datos:

    Servidores de puerta de enlace

    curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=gateway&region=region-name"
    

    Servidores centrales

    curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=central&region=region-name"
    

    Servidores de estadísticas

    curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=analytics&region=region-name"
    
  4. Verifica los UUID de cada componente y asegúrate de que coincidan con lo que ves en el árbol de ZooKeeper:

    Router

    curl 0:8081/v1/servers/self/uuid
    

    Message Processor

    curl 0:8082/v1/servers/self/uuid
    

    Agente de Qpid

    curl 0:8083/v1/servers/self/uuid
    

    Agente de Postgres

    curl 0:8084/v1/servers/self/uuid
    
  5. Usa los datos de UUID para buscar el resultado de árbol de ZooKeeper generado en el paso 2 a fin de validar el cableado de los componentes y quitar los registros duplicados del componente que tienen los UUID incorrectos.
  6. Usa las llamadas a la API de administración que se enumeran aquí para corregir el registro del almacén de datos. Los componentes como routers, procesadores de mensajes, Postgres y Qpid se registran en ZooKeeper durante el tiempo de inicio.

Resolución

Los problemas relacionados con los datos de ZooKeeper deben abordarse caso por caso. Los datos de ZooKeeper se basan en topologías de Apigee Edge y varían según cada caso de uso. Si se experimenta uno de los síntomas del problema, recopila los datos como se explica en la sección anterior y comunícate con el equipo de asistencia de Apigee Edge.