Timeout dei report di Analytics

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Sintomo

Le dashboard di Analytics (Prestazioni proxy, Prestazioni target, report personalizzati e così via) nel timeout dell'interfaccia utente perimetrale.

Messaggi di errore

Quando si verifica il timeout delle dashboard di Analytics, viene visualizzato il seguente messaggio di errore:

The report timed out: Try again with a smaller date range or a larger aggregation interval.

Possibili cause

Nella tabella seguente sono elencate le possibili cause di questo problema:

Causa Per
Configurazione hardware inadeguata Utenti del cloud privato perimetrale
Quantità elevata di dati di Analytics nel database Postgres Utenti del cloud privato perimetrale
Tempo insufficiente per recuperare i dati di Analytics Utenti di cloud privato e pubblico Edge

Configurazione hardware inadeguata

Diagnostica

Se uno qualsiasi dei componenti perimetrali è al di sotto della capacità (se ha una capacità di CPU, RAM o IOPS inferiore al necessario), i server Postgres/Qpid Server potrebbero essere eseguiti lentamente, causando il timeout delle dashboard di Analytics.

Risoluzione

Assicurati che tutti i componenti Edge soddisfino i requisiti hardware minimi descritti in Requisiti hardware.

Grande quantità di dati di analisi nel database Postgres

Diagnostica

  1. Sul nodo Postgres, accedi a PostgreSQL:
    psql -h /opt/apigee/var/run/apigee-postgresql -U apigee apigee
    
  2. Controlla il periodo di tempo per cui i dati sono disponibili nel database Postgres utilizzando la seguente query SQL:
    select min(client_received_start_timestamp), max(client_received_start_timestamp) from
      analytics."orgname.envname.fact";
    
  3. Ottieni le dimensioni di tutte le tabelle nel database Postgres:
    SELECT relname as "Table",pg_size_pretty(pg_total_relation_size(relid)) As "Size",
      pg_size_pretty(pg_total_relation_size(relid) - pg_relation_size(relid)) as "External Size"
      FROM pg_catalog.pg_statio_user_tables ORDER BY pg_total_relation_size(relid) DESC;
    

In base all'output ottenuto nei passaggi 2 e 3, se noti che la durata di archiviazione dei dati è lunga (più lunga dell'intervallo di conservazione) e/o le dimensioni della tabella sono molto grandi, significa che il database Postgres contiene grandi quantità di dati di analisi. Questo potrebbe causare il timeout delle dashboard di Analytics.

Risoluzione

Elimina i dati che superano l'intervallo di conservazione richiesto:

  1. Determina l'intervallo di conservazione, ovvero il periodo di tempo per cui vuoi conservare i dati di Analytics nel database Postgres.

    Ad esempio, vuoi conservare i dati di Analytics per un periodo di 60 giorni.

  2. Esegui questo comando per eliminare i dati per un'organizzazione e un ambiente specifici:
    /opt/apigee/apigee-service/bin/apigee-service apigee-postgresql pg-data-purge
        org env num_days_to_purge_back_from_current_date
    
  3. Per ulteriori informazioni, consulta la sezione Eliminazione dei dati di Analytics.

Se il problema persiste, vai alla sezione Tempo insufficiente per recuperare i dati di Analytics.

Tempo insufficiente per recuperare i dati di Analytics

Diagnostica

  1. Verifica se riesci a visualizzare i dati nella scheda Ora/giorno della dashboard di Analytics (Rendimento proxy/Rendimento target).
  2. Se riesci a visualizzare i dati solo nelle schede Ora o Ora e Giorno, ma ricevi errori di timeout del report solo quando cerchi di visualizzare le schede Settimana o Personalizzato, significa che il volume di dati che devono essere recuperati dal database Postgres è molto grande. Questo potrebbe causare il timeout dell'interfaccia utente Edge.

Risoluzione

La UI perimetrale ha un timeout predefinito di 120 secondi per il recupero e la visualizzazione dei dati di Analytics. Se il volume dei dati di Analytics da recuperare è molto elevato, 120 secondi potrebbero non essere sufficienti. Aumenta il valore di timeout della UI perimetrale a 300 secondi seguendo le istruzioni riportate in Impostare il timeout utilizzato dalla UI perimetrale per le chiamate di gestione delle API Edge (solo clienti on-premise).

Ricarica una delle dashboard di Analytics e controlla se riesci a visualizzare i dati di tutte le schede: Ora, Giorno, Settimana e Personalizzato.

Se il problema persiste, contatta l'assistenza Apigee Edge.