Problemi di comunicazione con il Portale per gli sviluppatori

Stai visualizzando la documentazione di Apigee Edge.
Vai alla documentazione di Apigee X.
informazioni

Sintomo

Potresti riscontrare uno o più dei seguenti problemi causati da problemi di comunicazione tra il Portale per gli sviluppatori ed Edge:

  1. Impossibile eseguire le seguenti attività:
  2. Creare o aggiornare SmartDocumenti.
  3. Registra le app degli sviluppatori.
  4. Elenca i prodotti API.
  5. Errore restituito durante l'accesso alla pagina dei modelli SmartDocumenti sul Portale per gli sviluppatori (seleziona Contenuti > SmartDocs nel menu di amministrazione del Portale per gli sviluppatori).


  6. Analisi dell'app sviluppatore non generata.

Messaggi di errore

  1. Errore restituito durante l'accesso alla scheda "SmartDocumenti" nel portale per gli sviluppatori:

    The website encountered an unexpected error. Please try again later.
    
  2. Errore restituito durante la registrazione di un'app per sviluppatori nel portale per gli sviluppatori:

    There was an error trying to create the App. Please try again later.
    

Possibili cause

Nella maggior parte dei casi, il problema è dovuto a credenziali devadmin errate o a autorizzazioni insufficienti assegnate al ruolo utente devadmin.

Convalida la configurazione della connessione perimetrale per il portale per sviluppatori andando a Configurazione > Portale di sviluppo e assicurandoti che il campo Stato connessione mostri Connessione riuscita. In caso contrario, il portale per sviluppatori non sarà in grado di connettersi correttamente al server Edge Management.

Diagnostica

  1. Abilita il logging "DEBUG" sul portale dev andando a Configurazione > Portale di sviluppo e selezionando Debug sotto la soglia di logging perimetrale. Per impostazione predefinita, le chiamate all'API di gestione non vengono registrate.
  1. Riproduci il problema.
  1. Per accedere al log, vai a Report -> Messaggi di log recenti.

  1. Apri il "Messaggio" di tipo "LogPlugin" per scoprire di più sull'errore effettivo.

Esempio di output che mostra l'errore 401 Autorizzazione non autorizzata

Risoluzione

Segui i passaggi appropriati elencati nella tabella seguente in base all'errore riscontrato:

Errore

Procedura per la risoluzione

richiesta non autorizzata (401)

Aggiorna le credenziali devadmin corrette sul portale per gli sviluppatori e verifica di nuovo la connettività. Vedi Aggiungere e gestire gli account utente.

richiesta vietata (403)

Aggiorna il ruolo utente devadmin nell'organizzazione Edge per disporre delle autorizzazioni necessarie per la risorsa. Consulta la sezione Impostare i ruoli e le autorizzazioni utente.