開發人員入口網站通訊問題

查看 Apigee Edge 說明文件。
前往 Apigee X說明文件
資訊

問題

由於合作夥伴之間有通訊問題, 開發人員入口網站和邊緣位置:

  1. 無法執行下列工作:
  2. 建立或更新 SmartDoc。
  3. 註冊開發人員應用程式。
  4. 列出 API 產品。
  5. 存取開發人員入口網站的 SmartDoc 模型頁面時,系統傳回錯誤 (選取 內容 >SmartDoc)。


  6. 無法產生開發人員應用程式數據分析。

錯誤訊息

  1. 存取開發人員入口網站的「SmartDoc」分頁時,系統會傳回錯誤:

    The website encountered an unexpected error. Please try again later.
    
  2. 在開發人員入口網站註冊開發人員應用程式時傳回錯誤:

    There was an error trying to create the App. Please try again later.
    

可能原因

在大多數情況下,這個問題的起因是開發人員管理員不正確 已指定憑證或指派權限不足給 devadmin 使用者角色

前往以下位置,驗證開發入口網站的邊緣連線設定: 設定 >開發人員入口網站,並確認「連線狀態」欄位 就會顯示「連線成功」。否則,開發人員入口網站無法正確連線至 Edge Management 伺服器。

診斷

  1. 啟用「DEBUG」請前往 設定 >開發人員入口網站,然後選取 Edge 記錄下方的「Debug」(偵錯) 門檻。根據預設,系統不會記錄 Management API 呼叫。
  1. 重現問題。
  1. 您可以前往 [報表] -> 查看記錄。近期記錄 訊息

  1. 開啟「LogPlugin」類型的「訊息」,進一步瞭解 實際錯誤。

顯示 401 未授權錯誤的輸出結果範例

解析度

請根據遇到的錯誤,按照下表所列的適當步驟操作:

錯誤

解決步驟

401 未授權

請在開發人員入口網站更新正確的開發人員管理員憑證,並測試連線能力 可以選取「重新建立」,再次生成新的提示請參閱新增及管理使用者帳戶

403 禁止

更新 Edge 機構的 devadmin 使用者角色,取得下列項目的必要權限 資源請參閱設定使用者角色和權限