開發人員入口網站通訊問題

您正在查看 Apigee Edge 說明文件。
查看 Apigee X 說明文件
資訊

問題

您可能會遇到下列一或多項問題,原因可能是開發人員入口網站與 Edge 之間的通訊問題:

  1. 無法執行下列工作:
  2. 建立或更新 SmartDocs。
  3. 註冊開發人員應用程式。
  4. 列出 API 產品。
  5. 在開發人員入口網站上存取 SmartDocs 模型頁面 (在開發人員入口網站管理選單中依序選取「Content」>「SmartDocs」) 時傳回錯誤。


  6. 目前未產生開發人員應用程式數據分析。

錯誤訊息

  1. 在開發人員入口網站存取「SmartDocs」分頁時傳回錯誤:

    The website encountered an unexpected error. Please try again later.
    
  2. 在開發人員入口網站註冊開發人員應用程式時傳回的錯誤:

    There was an error trying to create the App. Please try again later.
    

可能原因

在多數情況下,這個問題是因為指定的 devadmin 憑證錯誤,或指派給 devadmin 使用者角色的權限不足

請依序前往「設定」>「開發人員入口網站」,並確認「連線狀態」欄位顯示「連線成功」,藉此驗證開發人員入口網站的 Edge 連線設定。否則,開發人員入口網站無法正確連線至 Edge Management 伺服器。

診斷

  1. 請前往「Configuration」(設定) >「Dev Portal」(開發人員入口網站),然後在「Edge 記錄門檻」(Edge 記錄門檻) 下方選取「Debug」(偵錯),即可在開發人員入口網站上啟用「偵錯」記錄功能。根據預設,系統不會記錄 Management API 呼叫。
  1. 重現問題。
  1. 如要存取記錄,請依序前往「Reports」->「Recent Log Messages」

  1. 開啟「LogPlugin」類型的「訊息」,進一步瞭解實際錯誤。

顯示 401 未授權錯誤的範例輸出

解析度

請根據發生的錯誤,按照下表列出的適當步驟操作:

錯誤

解決步驟

401 未授權

請在開發人員入口網站上更新正確的 devadmin 憑證,然後再次測試連線。請參閱新增及管理使用者帳戶

403 禁止

請更新 Edge 機構中的 devadmin 使用者角色,使其擁有資源所需的權限。請參閱設定使用者角色和權限