Errore interno del portale per gli sviluppatori

Stai visualizzando la documentazione di Apigee Edge.
Vai alla documentazione di Apigee X.
informazioni

Sintomo

Si è verificato un errore durante l'esecuzione di una richiesta API in tempo reale utilizzando SmartDocumenti dal portale per gli sviluppatori.

Messaggi di errore

L'errore comune che viene visualizzato nel Portale per gli sviluppatori è: "Si è verificato un errore interno. Riprova la richiesta".

Possibili cause

Questo errore può verificarsi quando il Portale per gli sviluppatori non riesce a ricevere una risposta dal backend (proxy Smartdocs o endpoint effettivo).

Diagnostica

Attiva "Strumenti per sviluppatori" nel browser e controlla la scheda Rete per identificare l'errore effettivo.

Gli errori comuni e le loro cause tipiche sono elencati nella seguente tabella:

Errore

Cause tipiche

ERR_NAME_NOT_RESOLVED

proxy SmartDocumenti configurato in modo errato o limitazioni del firewall di rete

Contenuti misti

Portale configurato tramite HTTPS, richiesta SmartDocumenti su HTTP

500 - Errore interno del server

Analizziamo ciascuna di queste cause una per una e i passaggi per risolvere il problema.

Il proxy SmartDocumenti è configurato in modo errato o limitazioni del firewall di rete

Il messaggio "ERR_NAME_NOT_RESOLVED" indica che l'URL del proxy Smartdocs non è configurato correttamente o che la rete da cui si accede al portale non è in grado di effettuare una chiamata all'URL del proxy smartdocs a causa di restrizioni del firewall. Il proxy smartdocs deve essere accessibile da internet o dalla rete interna (per le API interne).

Risoluzione

Assicurati che sia possibile accedere al proxy smartdocs da tutte le reti richieste eseguendo il deployment del proxy smartdocs su un host virtuale su Edge con un nome host accessibile da internet.

Portale configurato tramite HTTPS, richiesta SmartDocumenti su HTTP

L'errore "Contenuto misto" indica che il proxy Smartdocs viene chiamato tramite HTTP da una pagina caricata tramite HTTPS.

Risoluzione

Esponi il proxy Smartdocs su https per risolvere il problema. A tale scopo, esegui il deployment del proxy Smartdocs in modo da includere un host virtuale configurato per utilizzare TLS/SSL (in genere l'host virtuale "sicuro").

Il proxy SmartDocumenti che restituisce un'eccezione

Il messaggio 500 - Errore interno del server può essere causato da un problema con il proxy "smartdocs". In questo caso, noti che il proxy Smartdocs restituisce questo errore.

Diagnostica

Utilizza lo strumento Trace per diagnosticare gli errori con il proxy "smartdocs", come descritto di seguito. Per ulteriori informazioni, consulta la sezione Utilizzo dello strumento Trace.

  1. Attiva la traccia per il proxy "smartdocs" nell'organizzazione "VALIDATE" per individuare il criterio specifico che restituisce l'errore interno 500 del server.

  1. Seleziona il criterio specifico nella traccia per identificare la causa dell'errore.

Risoluzione

Correggi l'errore identificato. Se hai bisogno di aiuto, contatta l'assistenza Apigee Edge.

I processori di messaggi Edge non sono in grado di chiamare l'endpoint API pubblicato

500 - Si può verificare un errore interno del server anche quando i processori di messaggi appartenenti all'organizzazione che ospita il proxy Smartdocs non sono in grado di chiamare l'endpoint API.

Diagnostica

Utilizza lo strumento Trace per diagnosticare gli errori con il proxy "smartdocs", come descritto di seguito. Per ulteriori informazioni, consulta la sezione Utilizzo dello strumento Trace.

  1. Abilita trace per il proxy "smartdocs" nell'organizzazione "VALIDATE" per individuare il criterio specifico che restituisce l'errore interno 500 del server.

  1. Nella traccia UI di esempio mostrata sopra, si è notato che il criterio JavaScript "BuildTargetAPIRequest" non esegue l'URL di destinazione.
  1. Ottenere l'URL di destinazione dal criterio JavaScript "BuildTargetAPIRequest".
  1. Effettua una chiamata diretta all'URL dai nodi del processore di messaggi associati all'organizzazione "VALIDATE", come mostrato di seguito:
    curl -v <target URL>
    
  1. Correggi gli eventuali errori osservati.

Risoluzione

  1. Assicurati che le API pubblicate sul portale per gli sviluppatori possano essere richiamate dai processori di messaggi associati all'organizzazione "VALIDATE" e correggi gli eventuali errori riscontrati.
  1. Se sei in grado di eseguire la chiamata API direttamente dal processore di messaggi, è molto probabile che tu sia in grado di eseguire l'API anche tramite SmartDoc.
  1. Esegui la chiamata API tramite SmartDocs e controlla se il problema è stato risolto.