Erreur d'installation - Impossible d'ouvrir le fichier apigee-repo.rpm

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Symptôme

Vous allez observer l'erreur Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm pendant l'installation ou migration vers une version plus récente d'Apigee Edge pour Private Cloud.

Message d'erreur

Vous allez observer l'erreur suivante:

Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm. Skipping.

Cette erreur se produit généralement lors de l'installation de apigee-setup utility et dépendances:

[root@machinename ~]# sudo bash /tmp/bootstrap_4.50.00.sh apigeeuser=USERNAME
Apigee bootstrap 1.0-38 (OPDK_5000, 2020.11.30,19:31)

=== Obtaining creds for software.apigee.com:

Please enter value for password:

=== Begin work ...

=== Checking for presence of misc commands:

=== Checking distro:

=== Checking architecture:

=== Checking OS:

=== Checking SELinux status

=== Configuring package manager:
+ rpm -qa apigee*
+ rpm -e apigee-repo
error: package apigee-repo is not installed
(error can be ignored)
+ rpm -e apigeeprio-repo
error: package apigeeprio-repo is not installed
(error can be ignored)
+ yum install -y https://apigee:***@software.apigee.com/apigee-repo.rpm
Loaded plugins: enabled_repos_upload, langpacks, package_upload, priorities,
: product-id, protectbase, search-disabled-repos, subscription-
: manager
HTTP error (410 - Gone): Unit d98c371e-06bc-4afc-a216-effb1ebc9bce has been deleted
Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm. Skipping.
Error: Nothing to do
Uploading Enabled Repositories Report
Loaded plugins: langpacks, priorities, product-id, protectbase, subscription-
: manager
HTTP error (410 - Gone): Unit d98c371e-06bc-4afc-a216-effb1ebc9bce has been deleted
bootstrap_4.50.00.sh: Error: Repo configuration failed

[root@machinename ~]#
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Causes possibles

Voici les causes possibles de cette erreur:

Cause Description Instructions de dépannage applicables
Problèmes de connexion Internet ou de connectivité réseau Il n'y a pas de connexion Internet sortante ou des problèmes de connectivité réseau sont survenus. Utilisateurs de cloud privé Edge uniquement
Nom d'utilisateur ou mot de passe incorrect Nom d'utilisateur ou mot de passe incorrect pour le dépôt software.apigee.com. Utilisateurs de cloud privé Edge uniquement
Le mot de passe contient des caractères spéciaux Le mot de passe du dépôt software.apigee.com contient des caractères spéciaux. Utilisateurs de cloud privé Edge uniquement

Cause: problèmes de connexion Internet ou de connectivité réseau

Diagnostic

  1. Vérifiez que la connexion Internet sortante est installée sur la machine sur laquelle vous vous trouvez. l'erreur ci-dessus.
  2. Si vous disposez d'une connexion Internet sortante, testez la connectivité réseau pour software.apigee.com à l'aide de l'un des mécanismes suivants:

    netcat

    Avec netcat:

    1. Si vous avez installé netcat, exécutez la commande suivante:

      nc -v software.apigee.com 443
      

      Un message semblable à celui-ci doit s'afficher:

      Connection to software.apigee.com 443 port [tcp/https] succeeded!
      

      OU

      Connected to IP_ADDRESS:443
      
    2. Si aucun des messages ci-dessus ne s'affiche ou si des erreurs s'affichent, un message problème de connectivité réseau à software.apigee.com.

    Telnet

    Avec telnet:

    1. Si netcat n'est pas installé, vous pouvez utiliser les éléments suivants telnet pour vérifier la connectivité Internet:

      telnet software.apigee.com 443
      

      En cas de connexion, le résultat suivant doit s'afficher:

      Connected to software.apigee.com
      
    2. Si aucun des messages ci-dessus ne s'affiche ou si des erreurs s'affichent, un message problème de connectivité réseau à software.apigee.com.

Solution

Si vous n'avez pas accès à Internet ou à l'une des commandes (netcat ou telnet) échoue, cela signifie que votre connectivité réseau est limitée ou inexistante. Utilisez votre administrateur réseau pour résoudre le problème.

Cause: nom d'utilisateur ou mot de passe incorrect

Diagnostic

  1. Vérifiez que vous transmettez le nom d'utilisateur et le mot de passe corrects à la commande installe le apigee-service utility Apigee Edge:

    sudo bash /tmp/bootstrap_4.50.00.sh apigeeuser=USERNNAME apigeepassword=PASSWORD
    
  2. Vous pouvez également appeler directement l'URL software.apigee.com et vérifier sortie:

    curl -i -u USERNNAME>:PASSWORD https://software.apigee.com/apigee-repo.rpm
    
  3. Si vous obtenez une erreur 401 Unauthorized, cela signifie que vous utilisez nom d'utilisateur et/ou mot de passe incorrect.

Solution

Assurez-vous d'utiliser un nom d'utilisateur et un mot de passe corrects lors de l'installation. apigee-setup utility

Cause: le mot de passe contient des caractères spéciaux

Diagnostic

  1. Vérifiez que le mot de passe pour software.apigee.com ne contient pas caractères. Par exemple: >, $, @ ou *.
  2. Si le mot de passe contient des caractères spéciaux, cela est la cause de cette erreur.

Solution

  1. Utilisez la barre oblique inverse (\) avant tout caractère spécial.
  2. Par exemple, si votre mot de passe est pa$$w0rd, vous devez spécifier le mot de passe que pa\$\$w0rd.

Références

<ph type="x-smartling-placeholder"></ph> Installer l'utilitaire de configuration Edge Apigee