Errore di installazione: impossibile aprire apigee-repo.rpm

Stai visualizzando la documentazione di Apigee Edge.
Vai alla sezione Documentazione di Apigee X.
Informazioni

Sintomo

Vedrai l'errore Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm durante l'installazione o la migrazione a una versione più recente di Apigee Edge per il cloud privato.

Messaggio di errore

Vedrai il seguente errore:

Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm. Skipping.

Questo errore si verifica in genere durante l'installazione di apigee-setup utility e delle dipendenze:

[root@machinename ~]# sudo bash /tmp/bootstrap_4.50.00.sh apigeeuser=USERNAME
Apigee bootstrap 1.0-38 (OPDK_5000, 2020.11.30,19:31)

=== Obtaining creds for software.apigee.com:

Please enter value for password:

=== Begin work ...

=== Checking for presence of misc commands:

=== Checking distro:

=== Checking architecture:

=== Checking OS:

=== Checking SELinux status

=== Configuring package manager:
+ rpm -qa apigee*
+ rpm -e apigee-repo
error: package apigee-repo is not installed
(error can be ignored)
+ rpm -e apigeeprio-repo
error: package apigeeprio-repo is not installed
(error can be ignored)
+ yum install -y https://apigee:***@software.apigee.com/apigee-repo.rpm
Loaded plugins: enabled_repos_upload, langpacks, package_upload, priorities,
: product-id, protectbase, search-disabled-repos, subscription-
: manager
HTTP error (410 - Gone): Unit d98c371e-06bc-4afc-a216-effb1ebc9bce has been deleted
Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm. Skipping.
Error: Nothing to do
Uploading Enabled Repositories Report
Loaded plugins: langpacks, priorities, product-id, protectbase, subscription-
: manager
HTTP error (410 - Gone): Unit d98c371e-06bc-4afc-a216-effb1ebc9bce has been deleted
bootstrap_4.50.00.sh: Error: Repo configuration failed

[root@machinename ~]#

Possibili cause

Ecco le possibili cause di questo errore:

Causa Descrizione Le istruzioni di risoluzione dei problemi applicabili a
Problemi di connessione a internet o connettività di rete Nessuna connessione Internet in uscita o problemi di connettività di rete. Solo utenti Edge Private Cloud
Nome utente o password non corretti Utilizzo del nome utente o della password errati per il repository software.apigee.com. Solo utenti Edge Private Cloud
La password contiene caratteri speciali La password del repository software.apigee.com contiene caratteri speciali. Solo utenti Edge Private Cloud

Causa: problemi di connessione a internet o di connettività di rete

Diagnosi

  1. Verifica di avere la connessione Internet in uscita sulla macchina in cui ti trovi visualizzando l'errore riportato sopra.
  2. Se hai una connessione a internet in uscita, verifica la connettività di rete software.apigee.com usando uno dei seguenti meccanismi:

    netcat

    Con netcat:

    1. Se hai installato netcat, esegui questo comando:

      nc -v software.apigee.com 443
      

      Dovresti ricevere un messaggio simile al seguente:

      Connection to software.apigee.com 443 port [tcp/https] succeeded!
      

      OPPURE

      Connected to IP_ADDRESS:443
      
    2. Se non vedi nessuno dei messaggi riportati sopra o se visualizzi errori, significa che problema di connettività di rete a software.apigee.com.

    Telnet

    Uso di telnet:

    1. Se non hai installato netcat, puoi utilizzare quanto segue Comando telnet per controllare la connettività a internet:

      telnet software.apigee.com 443
      

      Se si connette, dovrebbe essere visualizzato il seguente output:

      Connected to software.apigee.com
      
    2. Se non vedi nessuno dei messaggi riportati sopra o se visualizzi errori, significa che problema di connettività di rete a software.apigee.com.

Risoluzione

Se non hai una connessione a internet o non hai uno dei comandi (netcat o telnet) non funziona, la connettività di rete è limitata o assente. Collabora con il tuo amministratore di rete per risolvere il problema.

Causa: nome utente o password errati

Diagnosi

  1. Verifica di aver trasmesso il nome utente e la password corretti al comando che installa Apigee Edge apigee-service utility:

    sudo bash /tmp/bootstrap_4.50.00.sh apigeeuser=USERNNAME apigeepassword=PASSWORD
    
  2. Puoi anche effettuare una chiamata diretta all'URL software.apigee.com e controllare :

    curl -i -u USERNNAME>:PASSWORD https://software.apigee.com/apigee-repo.rpm
    
  3. Se visualizzi un errore 401 Unauthorized, significa che stai utilizzando un nome utente e/o password errati.

Risoluzione

Assicurati di utilizzare il nome utente e la password corretti durante l'installazione. apigee-setup utility.

Causa: la password contiene caratteri speciali

Diagnosi

  1. Verifica che la password per software.apigee.com non contenga informazioni speciali caratteri. Ad esempio: >, $, @ o *.
  2. Se la password contiene caratteri speciali, è questo la causa dell'errore.

Risoluzione

  1. Utilizza la barra rovesciata (\) prima di qualsiasi carattere speciale.
  2. Ad esempio, se la tua password è pa$$w0rd, devi specificare la password come pa\$\$w0rd.

Riferimenti

Installa l'utilità apigee-setup Edge