Errore di installazione: impossibile aprire apigee-repo.rpm

Stai visualizzando la documentazione di Apigee Edge.
Vai alla documentazione di Apigee X.
informazioni

Sintomo

Vedrai l'errore Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm durante l'installazione o la migrazione alla versione più recente di Apigee Edge per il cloud privato.

Messaggio di errore

Vedrai il seguente errore:

Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm. Skipping.

Questo errore in genere si verifica durante l'installazione di apigee-setup utility e delle dipendenze:

[root@machinename ~]# sudo bash /tmp/bootstrap_4.50.00.sh apigeeuser=USERNAME
Apigee bootstrap 1.0-38 (OPDK_5000, 2020.11.30,19:31)

=== Obtaining creds for software.apigee.com:

Please enter value for password:

=== Begin work ...

=== Checking for presence of misc commands:

=== Checking distro:

=== Checking architecture:

=== Checking OS:

=== Checking SELinux status

=== Configuring package manager:
+ rpm -qa apigee*
+ rpm -e apigee-repo
error: package apigee-repo is not installed
(error can be ignored)
+ rpm -e apigeeprio-repo
error: package apigeeprio-repo is not installed
(error can be ignored)
+ yum install -y https://apigee:***@software.apigee.com/apigee-repo.rpm
Loaded plugins: enabled_repos_upload, langpacks, package_upload, priorities,
: product-id, protectbase, search-disabled-repos, subscription-
: manager
HTTP error (410 - Gone): Unit d98c371e-06bc-4afc-a216-effb1ebc9bce has been deleted
Cannot open: https://USERNAME:PASSWORD@software.apigee.com/apigee-repo.rpm. Skipping.
Error: Nothing to do
Uploading Enabled Repositories Report
Loaded plugins: langpacks, priorities, product-id, protectbase, subscription-
: manager
HTTP error (410 - Gone): Unit d98c371e-06bc-4afc-a216-effb1ebc9bce has been deleted
bootstrap_4.50.00.sh: Error: Repo configuration failed

[root@machinename ~]#

Possibili cause

Di seguito sono riportate le possibili cause di questo errore:

Causa Descrizione Istruzioni per la risoluzione dei problemi applicabili a
Problemi di connessione a internet o di rete Non è presente una connessione a internet in uscita o si sono verificati problemi di connettività di rete. Solo utenti Edge Private Cloud
Nome utente o password non corretti Utilizzo di un nome utente o di una password errati per il repository software.apigee.com. Solo utenti Edge Private Cloud
La password contiene caratteri speciali La password per il repository software.apigee.com contiene caratteri speciali. Solo utenti Edge Private Cloud

Causa: problemi di connessione a internet o di rete

Diagnostica

  1. Verifica se disponi della connessione a internet in uscita sulla macchina in cui viene visualizzato l'errore riportato sopra.
  2. Se hai una connessione a internet in uscita, verifica la connettività di rete a software.apigee.com utilizzando uno dei seguenti meccanismi:

    Netcat

    Utilizzo di netcat:

    1. Se hai installato netcat, esegui questo comando:

      nc -v software.apigee.com 443
      

      Dovresti ricevere un messaggio simile al seguente:

      Connection to software.apigee.com 443 port [tcp/https] succeeded!
      

      OPPURE

      Connected to IP_ADDRESS:443
      
    2. Se non vedi nessuno dei messaggi precedenti o se vedi errori, significa che hai un problema di connettività di rete a software.apigee.com.

    Telnet

    Utilizzo di Telnet:

    1. Se non hai installato netcat, puoi utilizzare il seguente comando telnet per controllare la connettività a internet:

      telnet software.apigee.com 443
      

      Dovresti vedere il seguente output se si connette:

      Connected to software.apigee.com
      
    2. Se non vedi nessuno dei messaggi precedenti o se vedi errori, significa che hai un problema di connettività di rete a software.apigee.com.

Risoluzione

Se non disponi di una connessione a internet o se uno dei comandi (netcat o telnet) non funziona, la connettività di rete è limitata o assente. Rivolgiti all'amministratore di rete per risolvere il problema.

Causa: nome utente o password errati

Diagnostica

  1. Verifica di passare il nome utente e la password corretti al comando che installa Apigee Edge apigee-service utility:

    sudo bash /tmp/bootstrap_4.50.00.sh apigeeuser=USERNNAME apigeepassword=PASSWORD
    
  2. Puoi anche effettuare una chiamata diretta all'URL software.apigee.com e controllare l'output:

    curl -i -u USERNNAME>:PASSWORD https://software.apigee.com/apigee-repo.rpm
    
  3. Se visualizzi un errore 401 Unauthorized, significa che stai utilizzando nome utente e/o password errati.

Risoluzione

Assicurati di utilizzare nome utente e password corretti durante l'installazione di apigee-setup utility.

Causa: la password contiene caratteri speciali

Diagnostica

  1. Verifica che la password di software.apigee.com non contenga caratteri speciali. Ad esempio: >, $, @ o *.
  2. Se la password contiene caratteri speciali, è questo il motivo dell'errore.

Risoluzione

  1. Utilizza il carattere di escape barra rovesciata (\) prima di qualsiasi carattere speciale.
  2. Ad esempio, se la password è pa$$w0rd, devi specificare la password come pa\$\$w0rd.

Riferimenti

Installa l'utilità Edge apigee-setup