Le domaine personnalisé ne correspond pas à l'enregistrement CNAME sur le portail des développeurs intégré

<ph type="x-smartling-placeholder"></ph> Vous consultez la documentation Apigee Edge.
Accédez à la page Documentation sur Apigee X.
En savoir plus

Symptôme

La configuration du domaine personnalisé dans le portail intégré des développeurs ne fonctionnera pas si le ne correspond pas à l'enregistrement CNAME (nom canonique) : Publier > Portails > Développeur Portail > Paramètres > domaines.

Message d'erreur

Le message d'erreur suivant s'affiche :

Domain does not match CNAME record

Le message d'erreur s'affiche dans l'interface utilisateur Edge comme indiqué ci-dessous:

Portails > Portail des développeurs > Paramètres > Domaines" title="Domaines">

Causes possibles :

Cause Description Instructions de dépannage applicables
Enregistrement CNAME manquant ou incorrect pour le domaine Le domaine personnalisé doit disposer d'un enregistrement CNAME pointant vers {orgname}-portal.apigee.net Sinon, la configuration du domaine personnalisé échouera. Utilisateurs de cloud public Edge

Cause: enregistrement CNAME manquant ou incorrect pour le domaine

Diagnostic

Pour diagnostiquer le problème, procédez comme suit:

  1. Exécutez la commande suivante pour trouver la configuration DNS du nom de domaine personnalisé:
    dig +noall +answer {custom-domain}
  2. Le résultat de la commande ci-dessus doit contenir un enregistrement CNAME pointant vers {org}-portal.apigee.net. Par exemple,
    dig +noall +answer {custom-domain}
    
    {custom-domain}	{TTL}	IN	CNAME	{orgname}-portal.apigee.net.
    .
  3. Si le résultat de la commande indique que le domaine personnalisé ne dispose pas d'un enregistrement CNAME ou contient l'enregistrement CNAME qui ne correspond pas.{org}-portal.apigee.net,alors c'est la cause de l'échec de la création de l'hôte virtuel. Par conséquent, le message d'erreur ci-dessus est affiché à l'utilisateur sur la page de configuration du domaine personnalisé de l'interface utilisateur Edge.

Solution

Si le domaine personnalisé ne contient pas d'enregistrement CNAME pointant vers {orgname}-portal.apigee.net, puis procédez comme suit pour résoudre le problème:

  1. Supprimez tous les enregistrements CNAME existants trouvés dans la configuration DNS du domaine personnalisé.
  2. Ajoutez un enregistrement CNAME à votre nom de domaine (que vous souhaitez utiliser sur la page du domaine personnalisé). pour pointer vers {orgname}-portal.apigee.net.
  3. Sélectionnez le nom de domaine personnalisé spécifique (dont l'enregistrement CNAME pointe vers {orgname}-portal.apigee.net) dans le menu déroulant associé au domaine dans page de configuration du domaine personnalisé.
  4. Si vous avez importé un certificat générique dans le keystore, procédez comme suit: <ph type="x-smartling-placeholder">
      </ph>
    1. Sélectionnez le nom de domaine dans le menu déroulant.
    2. Indiquez le nom de sous-domaine correct
  5. Configurer le keystore alias, nom de domaine sur la page de configuration du domaine personnalisé du portail des développeurs intégré.
  6. Cliquez sur Enregistrer.

Si le problème persiste, consultez la page Vous devez collecter des informations de diagnostic.

Vous devez collecter des informations de diagnostic

Si le problème persiste après avoir suivi les instructions ci-dessus, rassemblez les données de diagnostic suivantes d'assistance et de les partager avec l'assistance Apigee Edge:

  • Nom de l'organisation Apigee Edge Cloud
  • Nom du portail des développeurs intégré Apigee Edge Cloud
  • Nom du keystore créé dans l'environnement de portail
  • Nom de l'alias
  • Nom du domaine personnalisé
  • Capture d'écran de la page de configuration du domaine personnalisé qui capture le message d'erreur