Il dominio personalizzato non corrisponde al record CNAME nel portale per gli sviluppatori integrato

Stai visualizzando la documentazione di Apigee Edge.
Vai alla documentazione di Apigee X.
informazioni

Sintomo

La configurazione del dominio personalizzato nel portale per sviluppatori integrato non funziona se il dominio personalizzato non corrisponde al record CNAME (nome canonico): Pubblica > Portali > Portale per gli sviluppatori > Impostazioni > Domini.

Messaggio di errore

Viene visualizzato il seguente messaggio di errore:

Domain does not match CNAME record

Il messaggio di errore viene visualizzato nell'UI di Edge come mostrato di seguito:

Portali > Portale per gli sviluppatori > Impostazioni > Domini" title="Domini">

Possibili cause

Causa Descrizione Istruzioni per la risoluzione dei problemi applicabili a
Record CNAME mancante o non corretto per il dominio Il dominio personalizzato deve avere un record CNAME che punta a {orgname}-portal.apigee.net. In caso contrario, la configurazione del dominio personalizzato non andrà a buon fine. Utenti del cloud pubblico perimetrale

Causa: record CNAME mancante o errato per il dominio

Diagnostica

Per diagnosticare il problema:

  1. Esegui questo comando per trovare la configurazione DNS del nome di dominio personalizzato:
    dig +noall +answer {custom-domain}
  2. L'output del comando riportato sopra deve contenere un record CNAME che punta al nome di dominio {org}-portal.apigee.net. Ad esempio:
    dig +noall +answer {custom-domain}
    
    {custom-domain}	{TTL}	IN	CNAME	{orgname}-portal.apigee.net.
  3. Se l'output del comando mostra che il dominio personalizzato non ha un record CNAME o contiene il record CNAME che non corrisponde{org}-portal.apigee.net,, allora questa è la causa dell'errore di creazione dell'host virtuale. Di conseguenza, il messaggio di errore riportato sopra viene visualizzato all'utente nella pagina di configurazione del dominio personalizzato della UI perimetrale.

Risoluzione

Se il dominio personalizzato non contiene un record CNAME che punta a {orgname}-portal.apigee.net, segui questi passaggi per risolvere il problema:

  1. Rimuovi tutti i record CNAME esistenti trovati nella configurazione DNS del dominio personalizzato.
  2. Aggiungi un record CNAME al tuo nome di dominio (che vuoi utilizzare nella pagina del dominio personalizzato) per puntare a {orgname}-portal.apigee.net.
  3. Seleziona il nome di dominio personalizzato specifico (con il record CNAME che punta a {orgname}-portal.apigee.net) dal menu a discesa per Dominio nella pagina di configurazione del dominio personalizzato.
  4. Se hai caricato un certificato con caratteri jolly nell'archivio chiavi:
    1. Selezionare il nome di dominio dal menu a discesa e
    2. Inserisci il nome del sottodominio corretto
  5. Configura l'archivio chiavi, l'alias o il nome di dominio nella pagina di configurazione del dominio personalizzato del portale per gli sviluppatori integrato.
  6. Fai clic su Salva.

Se il problema persiste, vai alla pagina Devi raccogliere dati diagnostici.

Devi raccogliere dati diagnostici

Se il problema persiste dopo aver seguito le istruzioni riportate sopra, raccogli le seguenti informazioni diagnostiche e condividile con l'assistenza Apigee Edge:

  • Nome organizzazione Cloud Apigee Edge
  • Nome portale per sviluppatori integrato Apigee Edge Cloud
  • Nome dell'archivio chiavi creato nell'ambiente del portale
  • Nome alias
  • Nome dominio personalizzato
  • Uno screenshot della pagina di configurazione del dominio personalizzato che mostra il messaggio di errore