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Symptôme
La configuration du domaine personnalisé dans le portail intégré des développeurs ne fonctionnera pas si le protocole TLS la chaîne de certificats a expiré: Publier > Portails > Portail des développeurs > Paramètres > Domains (Domaines)
Message d'erreur
Le message d'erreur suivant s'affiche :
Certificate expired
Le message d'erreur s'affiche dans l'interface utilisateur Edge comme indiqué ci-dessous:
Portails > Portail des développeurs > Paramètres > Domaines" title="Domaines">
Causes possibles :
Cause | Description > | Instructions de dépannage applicables |
---|---|---|
La chaîne de certificats TLS a expiré | Si la chaîne de certificats TLS fournie a expiré, la configuration du domaine personnalisé échouera. | Utilisateurs de cloud public Edge |
Cause: la chaîne de certificats TLS a expiré
Diagnostic
Pour diagnostiquer le problème, procédez comme suit:
- <ph type="x-smartling-placeholder"></ph> Vérifiez la date et l'heure d'expiration de la chaîne de certificats TLS.
- Si la chaîne de certificats TLS spécifique a expiré, l'hôte virtuel sera créé dans le portail intégré des développeurs. Par conséquent, le message d'erreur ci-dessus est affiché à l'utilisateur sur la page de configuration du domaine personnalisé de l'interface utilisateur Edge.
Solution
Si vous avez vérifié que la chaîne de certificats TLS a expiré, procédez comme suit : procédure à suivre pour résoudre ce problème:
- Obtenez une nouvelle chaîne de certificats TLS auprès de l'autorité de certification concernée.
- Convertissez la chaîne de certificats TLS au format PEM.
- Vérifiez que la chaîne de certificats TLS est valide.
- Supprimez la chaîne de certificats TLS existante du keystore spécifique.
- Importez le fichier contenant la chaîne de certificats TLS au format PEM et le fichier contenant la clé privée au keystore à l'aide d'un alias de clé dans l'interface utilisateur Edge ou l'API de gestion.
- Configurer keystore, alias, nom de domaine dans la configuration de domaine personnalisé du portail intégré des développeurs .
- Cliquez sur Enregistrer.
Si le problème persiste, consultez la page Vous devez collecter des informations de diagnostic.
Vous devez collecter des informations de diagnostic
Si le problème persiste après avoir suivi les instructions ci-dessus, rassemblez les données de diagnostic suivantes d'assistance et de les partager avec l'assistance Apigee Edge:
- Nom de l'organisation Apigee Edge Cloud
- Nom du portail des développeurs intégré Apigee Edge Cloud
- Nom du keystore créé dans l'environnement de portail
- Nom de l'alias
- Nom du domaine personnalisé
- Capture d'écran de la page de configuration du domaine personnalisé qui capture le message d'erreur