Waktu tunggu laporan Analytics

Anda sedang melihat dokumentasi Apigee Edge.
Buka dokumentasi Apigee X.
info

Gejala

Dasbor Analytics (Performa Proxy, Target Performa, Laporan Kustom, dll.) dalam waktu tunggu UI Edge.

Pesan error

Anda melihat pesan error berikut saat waktu tunggu dasbor Analytics habis:

The report timed out: Try again with a smaller date range or a larger aggregation interval.

Kemungkinan penyebab

Tabel berikut mencantumkan kemungkinan penyebab masalah ini:

Penyebab Untuk
Konfigurasi hardware tidak memadai Pengguna Edge Private Cloud
Data Analytics dalam jumlah besar di Database Postgres Pengguna Edge Private Cloud
Tidak cukup waktu untuk mengambil data Analytics Pengguna Cloud Pribadi dan Publik Edge

Konfigurasi hardware tidak memadai

Diagnosis

Jika salah satu komponen Edge berada dalam kapasitasnya (jika memiliki kapasitas CPU, RAM, atau IOPS yang lebih sedikit dari yang diperlukan), Server Postgres/Server Qpid mungkin berjalan lambat, sehingga menyebabkan waktu tunggu habis untuk dasbor Analytics.

Resolusi

Pastikan semua komponen Edge mematuhi persyaratan hardware minimum sebagaimana dijelaskan dalam Persyaratan Hardware.

Sejumlah besar data Analytics di Database Postgres

Diagnosis

  1. Di node Postgres, login ke PostgreSQL:
    psql -h /opt/apigee/var/run/apigee-postgresql -U apigee apigee
    
  2. Periksa durasi data tersedia di Database Postgres menggunakan kueri SQL berikut:
    select min(client_received_start_timestamp), max(client_received_start_timestamp) from
      analytics."orgname.envname.fact";
    
  3. Dapatkan ukuran semua tabel di Database Postgres:
    SELECT relname as "Table",pg_size_pretty(pg_total_relation_size(relid)) As "Size",
      pg_size_pretty(pg_total_relation_size(relid) - pg_relation_size(relid)) as "External Size"
      FROM pg_catalog.pg_statio_user_tables ORDER BY pg_total_relation_size(relid) DESC;
    

Berdasarkan output yang diperoleh di langkah #2 dan #3, jika Anda melihat bahwa durasi data yang disimpan lama (lebih lama dari interval retensi Anda) dan/atau ukuran tabel sangat besar, hal ini menunjukkan bahwa Anda memiliki data analisis dalam jumlah besar di database Postgres. Hal ini dapat menyebabkan dasbor Analytics kehabisan waktu.

Resolusi

Memangkas data yang berada di luar interval retensi yang diperlukan:

  1. Tentukan interval retensi, yaitu durasi saat Anda ingin mempertahankan data Analytics di Database Postgres.

    Misalnya, Anda ingin menyimpan data Analytics selama 60 hari.

  2. Jalankan perintah berikut guna memangkas data untuk organisasi dan lingkungan tertentu:
    /opt/apigee/apigee-service/bin/apigee-service apigee-postgresql pg-data-purge
        org env num_days_to_purge_back_from_current_date
    
  3. Untuk informasi selengkapnya, lihat Memangkas data Analytics.

Jika masalah berlanjut, lanjutkan ke Tidak cukup waktu untuk mengambil data Analytics.

Waktu untuk mengambil data Analytics tidak cukup

Diagnosis

  1. Periksa apakah Anda dapat melihat data di Tab Jam/Hari pada dasbor Analytics (Performa Proxy/Target Performa).
  2. Jika Anda dapat melihat data di tab Jam saja atau tab Jam dan Hari, tetapi mendapatkan error waktu tunggu laporan hanya saat mencoba melihat tab Minggu atau Kustom, berarti volume data yang perlu diambil dari database Postgres sangat besar. Hal ini dapat menyebabkan UI Edge kehabisan waktu.

Resolusi

UI Edge memiliki waktu tunggu default 120 detik untuk mengambil dan menampilkan data Analytics. Jika volume data Analytics yang akan diambil sangat besar, 120 detik mungkin tidak cukup. Tingkatkan nilai waktu tunggu UI Edge hingga 300 detik dengan mengikuti petunjuk di Menetapkan waktu tunggu yang digunakan oleh UI Edge untuk panggilan pengelolaan Edge API (khusus pelanggan lokal).

Muat ulang salah satu dasbor Analytics dan periksa apakah Anda dapat melihat data untuk semua tab - Jam, Hari, Minggu, dan Kustom.

Jika masalah berlanjut, hubungi Dukungan Apigee Edge.