Error Internal Portal Developer

Anda sedang melihat dokumentasi Apigee Edge.
Buka dokumentasi Apigee X.
info

Gejala

Terjadi error saat membuat permintaan API live menggunakan SmartDocs dari portal developer.

Pesan Error

Error umum yang terlihat di Portal Developer adalah “Terjadi error internal. Coba lagi permintaan Anda”.

Kemungkinan Penyebab

Error ini dapat terjadi jika Portal Developer gagal mendapatkan respons dari backend (proxy smartdocs atau endpoint yang sebenarnya).

Diagnosis

Aktifkan “Developer tools” di browser Anda dan periksa tab jaringan untuk mengidentifikasi error yang sebenarnya.

Kesalahan umum dan penyebab umumnya tercantum dalam tabel berikut:

Error

Penyebab Umum

ERR_NAME_NOT_RESOLVED

Proxy SmartDocs salah dikonfigurasi atau pembatasan firewall jaringan

Konten Campuran

Portal yang dikonfigurasi melalui HTTP, permintaan SmartDocs melalui HTTP

500 - Error Server Internal

Mari kita bahas setiap penyebab ini satu per satu dan langkah-langkah untuk mengatasinya.

Proxy SmartDocs salah dikonfigurasi atau pembatasan firewall jaringan

Pesan “ERR_NAME_NOT_RESOLVED” menunjukkan bahwa URL proxy smartdocs salah dikonfigurasi atau jaringan yang mengakses portal tidak dapat melakukan panggilan ke URL proxy smartdocs karena pembatasan firewall. Proxy smartdocs harus dapat diakses dari internet atau jaringan internal (untuk API internal).

Resolusi

Pastikan proxy smartdocs dapat diakses dari semua jaringan yang diperlukan dengan men-deploy proxy smartdocs ke host virtual di Edge dengan nama host yang dapat diakses dari internet.

Portal yang dikonfigurasi melalui HTTPS, permintaan SmartDocs melalui HTTP

Error “Konten Campuran” menunjukkan bahwa proxy smartdocs dipanggil melalui HTTP dari halaman yang dimuat melalui HTTPS.

Resolusi

Mengekspos proxy smartdocs melalui https untuk mengatasi masalah ini. Anda dapat melakukannya dengan men-deploy proxy smartdocs untuk menyertakan host virtual yang dikonfigurasi untuk menggunakan TLS/SSL (biasanya host virtual "aman").

Proxy SmartDocs menampilkan pengecualian

Pesan 500 - Internal Server Error dapat disebabkan oleh masalah pada proxy “smartdocs”. Dalam hal ini, Anda melihat bahwa proxy smartdocs menampilkan error ini.

Diagnosis

Gunakan alat Trace untuk mendiagnosis error dengan proxy "smartdocs", seperti yang dijelaskan di bawah. Untuk mengetahui informasi selengkapnya, lihat Menggunakan alat Trace.

  1. Aktifkan pelacakan untuk Proxy “smartdocs” di organisasi “VALIDATE” untuk menemukan kebijakan tertentu yang menampilkan Error Server Internal 500.

  1. Pilih kebijakan spesifik dalam rekaman aktivitas untuk mengidentifikasi penyebab error.

Resolusi

Perbaiki error yang teridentifikasi. Jika Anda memerlukan bantuan, hubungi Dukungan Apigee Edge.

Prosesor Pesan Edge tidak dapat memanggil endpoint API yang dipublikasikan

500 - Error Server Internal juga dapat terjadi jika Prosesor Pesan milik organisasi yang menghosting proxy Smartdocs tidak dapat memanggil endpoint API.

Diagnosis

Gunakan alat Trace untuk mendiagnosis error dengan proxy "smartdocs", seperti yang dijelaskan di bawah. Untuk mengetahui informasi selengkapnya, lihat Menggunakan alat Trace.

  1. Aktifkan trace untuk proxy “smartdocs” dalam organisasi “VALIDATE” untuk menemukan kebijakan khusus yang menampilkan Error Server Internal 500.

  1. Pada contoh rekaman aktivitas UI yang ditampilkan di atas, terlihat bahwa kebijakan JavaScript “BuildTargetAPIRequest” gagal mengeksekusi URL target.
  1. Dapatkan URL target dari kebijakan JavaScript “BuildTargetAPIRequest”.
  1. Lakukan panggilan langsung ke URL dari node Pemroses Pesan yang terkait dengan organisasi “VALIDATE” seperti yang ditunjukkan di bawah ini:
    curl -v <target URL>
    
  1. Perbaiki setiap error yang diamati.

Resolusi

  1. Pastikan API yang dipublikasikan di Portal Developer dapat dipanggil dari Pemroses Pesan yang terkait dengan organisasi “VALIDATE” dan memperbaiki error yang ditemukan.
  1. Jika Anda dapat menjalankan panggilan API langsung dari Pemroses Pesan, kemungkinan besar Anda juga dapat menjalankan API melalui SmartDocs.
  1. Jalankan panggilan API melalui SmartDocs dan periksa apakah masalah telah diperbaiki.