Masalah reset sandi

Anda sedang melihat dokumentasi Apigee Edge.
Buka dokumentasi Apigee X.
info

Gejala

Pengguna global Apigee tidak menerima email reset sandi untuk akun Apigee Edge mereka, bahkan setelah mereset sandi dengan mengikuti petunjuk di bagian Mereset sandi.

Pesan error

Tidak ada pesan error yang diamati.

Konteks

Umumnya, pengguna global tidak dapat login ke UI Edge karena kredensial yang tidak valid, karena pengguna lupa sandi atau memiliki sandi yang salah. Dalam kasus tersebut, pengguna dapat mereset sandi menggunakan langkah-langkah berikut:

  1. Klik Reset sandi di jendela Login.

    setel ulang sandi

  2. Masukkan alamat email yang akan digunakan untuk membuat akun di Apigee Edge, seperti yang ditunjukkan di bawah ini:

    kirim link reset sandi

  3. Klik Kirim Link Reset Sandi. Anda akan melihat jendela seperti yang ditunjukkan di bawah:

    petunjuk dikirim

  4. Pengguna harus memeriksa kotak suratnya dan mengikuti petunjuk yang diberikan dalam email untuk mereset sandi.

Terkadang ditemukan bahwa pengguna tidak mendapatkan email reset sandi meskipun telah mengikuti semua petunjuk dengan benar. Dokumen ini menjelaskan kemungkinan penyebab masalah ini serta cara memecahkan dan mengatasi masalah ini.

Kemungkinan penyebab

Pengguna mungkin tidak mendapatkan email reset sandi karena sejumlah alasan. Alasan ini diklasifikasikan secara luas ke dalam jenis berikut:

Penyebab Deskripsi Petunjuk pemecahan masalah yang berlaku untuk
Pengguna tidak ada atau belum diaktifkan Ini hanya berlaku untuk pengguna pemula yang tidak memiliki pengguna di Apigee atau belum diaktifkan. Pengguna Cloud Publik Edge
Pengguna tidak mendapatkan email reset sandi Pengguna tidak mendapatkan email dengan link reset sandi. Pengguna Cloud Publik Edge
Link reset sandi tidak valid Pengguna mendapatkan link reset sandi yang tidak valid. Pengguna Cloud Publik Edge

Penyebab: Pengguna tidak ada atau belum diaktifkan

Pengguna mungkin tidak menerima email dengan link reset sandi jika pengguna tidak ada atau tidak diaktifkan. Namun, perhatikan bahwa Apigee tetap akan menampilkan pesan Petunjuk terkirim karena alasan keamanan, meskipun pengguna mencoba dan meminta reset sandi untuk alamat email yang tidak terdaftar.

Diagnosis

  1. Jika pengguna ditambahkan sebagai pengguna organisasi seperti yang dijelaskan di Menambahkan pengguna, hubungi administrator organisasi untuk mengetahui apakah pengguna tertentu tercantum di halaman Pengguna Organisasi di UI seperti yang dijelaskan dalam Menjelajahi halaman Pengguna.
  2. Lakukan lagi alur pendaftaran Apigee. Jika pengguna telah melalui proses pendaftaran, mereka akan mendapatkan pesan error bahwa pengguna sudah ada seperti yang ditunjukkan di bawah ini:

    akun sudah ada

  3. Selain itu, jika pengguna belum mengaktifkan akunnya saat mencoba login, mereka akan melihat pesan verifikasi akun Anda seperti yang ditunjukkan di bawah ini:

    verifikasi akun

Resolusi

  1. Jika pengguna belum dibuat, buat pengguna menggunakan langkah-langkah yang tersedia dalam Membuat pengguna global.
  2. Jika pengguna ada, tetapi belum diaktifkan, pengguna harus menyelesaikan proses pendaftaran untuk mengaktifkannya. Saat pengguna baru ditambahkan ke Edge, email pendaftaran akan dikirim. Setelah menyelesaikan proses pendaftaran dengan mengklik Aktifkan akun, pengguna akan ditambahkan ke sistem dan dapat mereset sandi atau melakukan login.

    aktifkan email akun

  3. Jika administrator organisasi menggunakan UI Edge untuk menambahkan pengguna global ke organisasi yang sudah ada dengan peran tertentu dan pengguna tidak ada, Edge akan membuatkan pengguna dan mengirimkan pesan email kepada pengguna untuk mengaktifkan akun dan menyetel sandi. Jika pengguna mendaftar sendiri, email akan dikirim ke alamat email yang ditentukan agar pengguna dapat mengaktifkan akun.

Penyebab: Pengguna tidak mendapatkan email reset sandi

Pengguna ada dan aktif, tetapi tidak mendapatkan email reset sandi.

Email reset sandi dikirim dari noreply@apigee.com seperti yang ditunjukkan di bawah.

alt_text

Masalah ini biasanya terjadi dalam dua skenario:

Skenario#1 : Email dipindahkan ke folder spam/sampah kotak surat

Diagnosis

  1. Periksa folder spam/sampah untuk mencari email reset sandi dari noreply@apigee.com.
  2. Jika Anda menemukan email reset sandi di folder spam/sampah, artinya alamat email noreply@apigee.com tidak dipercaya.

Resolusi

Tambahkan noreply@apigee.com sebagai alamat email tepercaya untuk kotak surat Anda dan tandai sebagai bukan spam/sampah.

Skenario#2 : Email diblokir oleh kebijakan perusahaan

Diagnosis

Periksa untuk melihat apakah alamat email noreply@apigee.com diblokir/difilter oleh kebijakan/firewall perusahaan.

Resolusi

Pastikan bahwa noreply@apigee.com tidak diblokir/difilter oleh kebijakan/firewall perusahaan Anda.

Terkadang pengguna menerima email link reset sandi; namun, saat pengguna mengklik link dalam email, error link sandi tidak valid akan ditampilkan seperti yang ditunjukkan di bawah ini:

alt_text

Diagnosis

  1. Jika menggunakan akun email perusahaan, Anda mungkin memiliki pemindai virus email yang memeriksa link di email untuk mendeteksi malware.
  2. Jika pemindai virus ini memindai link reset sandi sebelum Anda mengkliknya, pemindai virus tersebut akan menggunakan token sehingga masa berlaku token berakhir.
  3. Akibatnya, link menjadi tidak valid jika Anda mencoba mengaksesnya di lain waktu.

    Anda akan mendapatkan error berikut (seperti yang ditampilkan pada screenshot di atas): Maaf, link reset sandi Anda tidak lagi valid. Anda dapat mengajukan permintaan lagi di bawah ini.

Resolusi

Pertimbangkan untuk menambahkan domain apigee.com ke allowlist yang dikirimi email reset sandi (noreply@apigee.com). Hal ini memastikan bahwa email dapat diteruskan tanpa pemindaian virus dan mencegah masa berlaku token berakhir.

Jika masalah masih berlanjut, hubungi Dukungan Apigee Edge Google Cloud.