Masalah reset sandi

Anda sedang melihat dokumentasi Apigee Edge.
Buka dokumentasi Apigee X.
info

Gejala

Pengguna global Apigee tidak menerima email reset sandi untuk akun Apigee Edge mereka meskipun setelah mereset sandi dengan mengikuti petunjuk di Mereset sandi Anda.

Pesan error

Tidak ada pesan error yang diamati.

Konteks

Umumnya, pengguna global tidak dapat login ke UI Edge karena kredensial tidak valid, baik karena pengguna lupa sandi atau memiliki sandi yang salah. Dalam kasus tersebut, pengguna dapat mereset sandi menggunakan langkah-langkah berikut:

  1. Klik Reset sandi di jendela Login.

    setel ulang sandi

  2. Masukkan alamat email yang akunnya dibuat di Apigee Edge seperti yang ditunjukkan di bawah:

    mengirim link reset sandi

  3. Klik Kirim Link Reset Sandi. Anda akan melihat jendela seperti yang ditunjukkan di bawah ini:

    petunjuk dikirim

  4. Pengguna harus memeriksa kotak suratnya dan mengikuti petunjuk yang diberikan dalam email untuk mereset sandi.

Terkadang ditemukan bahwa pengguna tidak mendapatkan email reset sandi meskipun telah mengikuti semua petunjuk dengan benar. Dokumen ini menjelaskan kemungkinan penyebab masalah ini dan cara memecahkan masalah ini.

Kemungkinan penyebab

Pengguna mungkin tidak mendapatkan email reset sandi karena sejumlah alasan. Alasan ini secara luas diklasifikasikan menjadi jenis berikut:

Penyebab Deskripsi Petunjuk pemecahan masalah yang berlaku untuk
Pengguna tidak ada atau belum diaktifkan Hal ini hanya berlaku untuk pengguna pertama kali yang tidak ada di Apigee atau belum diaktifkan. Pengguna Edge Public Cloud
Pengguna tidak mendapatkan email reset sandi Pengguna tidak mendapatkan email dengan link reset sandi. Pengguna Edge Public Cloud
Link reset sandi tidak valid Pengguna mendapatkan link reset sandi yang tidak valid. Pengguna Edge Public Cloud

Penyebab: Pengguna tidak ada atau belum diaktifkan

Pengguna mungkin tidak menerima email dengan link reset sandi jika pengguna tidak ada atau tidak diaktifkan. Namun, perlu diketahui bahwa Apigee akan tetap menampilkan pesan Petunjuk dikirim karena alasan keamanan, meskipun pengguna mencoba dan meminta reset sandi untuk alamat email yang tidak terdaftar.

Diagnosis

  1. Jika pengguna ditambahkan sebagai pengguna organisasi seperti yang dijelaskan dalam Menambahkan pengguna, hubungi administrator organisasi untuk melihat apakah pengguna tertentu tercantum di halaman Pengguna Organisasi di UI seperti yang dijelaskan dalam Menjelajahi halaman Pengguna.
  2. Ikuti kembali alur pendaftaran Apigee. Jika pengguna telah melalui proses pendaftaran, mereka akan mendapatkan error bahwa pengguna sudah ada seperti yang ditunjukkan di bawah:

    akun ada

  3. Selain itu, jika pengguna belum mengaktifkan akunnya saat mencoba login, mereka akan melihat pesan verifikasi akun seperti yang ditunjukkan di bawah:

    verifikasi akun

Resolusi

  1. Jika pengguna belum dibuat, buat pengguna menggunakan langkah-langkah yang diberikan di Membuat pengguna global.
  2. Jika pengguna ada, tetapi tidak diaktifkan, pengguna harus menyelesaikan proses pendaftaran untuk mengaktifkannya. Saat pengguna baru ditambahkan ke Edge, email pendaftaran akan dikirim. Setelah pengguna menyelesaikan proses pendaftaran dengan mengklik Aktifkan akun Anda, pengguna akan ditambahkan ke sistem dan pengguna kemudian dapat mereset sandi atau melakukan login.

    aktifkan email akun

  3. Jika administrator organisasi menggunakan UI Edge untuk menambahkan pengguna global ke organisasi yang ada dengan peran tertentu dan pengguna tersebut tidak ada, Edge akan membuat pengguna dan mengirim pesan email kepada pengguna untuk mengaktifkan akun dan menetapkan sandi. Jika pengguna mendaftar sendiri, email akan dikirim ke alamat email yang ditentukan agar pengguna dapat mengaktifkan akun.

Penyebab: Pengguna tidak mendapatkan email reset sandi

Pengguna ada dan aktif, tetapi tidak mendapatkan email reset sandi.

Email reset sandi dikirim dari noreply@apigee.com seperti yang ditunjukkan di bawah.

alt_text

Biasanya, masalah ini terlihat dalam dua skenario:

Skenario#1 : Email dipindahkan ke folder spam/sampah di kotak surat

Diagnosis

  1. Periksa folder spam/sampah untuk menemukan email reset sandi dari noreply@apigee.com.
  2. Jika Anda menemukan email reset sandi di folder spam/sampah, hal ini menunjukkan bahwa alamat email noreply@apigee.com tidak tepercaya.

Resolusi

Tambahkan noreply@apigee.com sebagai alamat email tepercaya untuk kotak surat Anda dan tandai sebagai bukan spam/sampah.

Skenario#2 : Email diblokir oleh kebijakan perusahaan

Diagnosis

Periksa apakah alamat email noreply@apigee.com diblokir/difilter oleh kebijakan/firewall perusahaan Anda.

Resolusi

Pastikan noreply@apigee.com tidak diblokir/difilter oleh kebijakan/firewall perusahaan Anda.

Terkadang pengguna menerima email link reset sandi; namun, saat pengguna mengklik link dalam email, error link sandi tidak valid akan ditampilkan seperti yang ditunjukkan di bawah:

alt_text

Diagnosis

  1. Jika Anda menggunakan akun email perusahaan, Anda mungkin memiliki pemindai virus email yang memeriksa link dalam email untuk mendeteksi malware.
  2. Jika pemindai virus ini memindai link reset sandi sebelum Anda mengkliknya, pemindai virus akan menggunakan token sehingga masa berlaku token berakhir.
  3. Akibatnya, link menjadi tidak valid saat Anda mencoba mengaksesnya di lain waktu.

    Anda akan mendapatkan error berikut (seperti yang ditunjukkan pada screenshot di atas): Maaf, link reset sandi Anda sudah tidak valid. Anda dapat meminta link lain di bawah.

Resolusi

Pertimbangkan untuk menambahkan domain apigee.com ke allowlist tempat email reset sandi dikirim (noreply@apigee.com). Tindakan ini memastikan bahwa email dapat lolos tanpa pemindaian virus dan mencegah masa berlaku token berakhir.

Jika masalah masih berlanjut, hubungi Dukungan Apigee Edge Google Cloud.