Anda sedang melihat dokumentasi Apigee Edge.
Buka
dokumentasi Apigee X. info
Gejala
Masalah terkait data, biasanya disebut sebagai masalah jaringan kabel, dapat muncul sebagai salah satu gejala berikut:
- Kegagalan selama memulai server Pengelolaan
- Kegagalan deployment
- Error Datastore di UI
- Masalah konektivitas lintas pusat data antara Pemroses Pesan dan server Pengelolaan
- Analytics tidak menampilkan data
Masalah ini tidak terkait dengan infrastruktur ZooKeeper, tetapi terkait dengan data tidak valid yang tersedia di hierarki ZooKeeper.
Kemungkinan penyebab
Penyebab umum untuk masalah ini adalah:
- Node yang terhubung ke region atau nama pod yang salah selama penginstalan karena terjadi kesalahan dalam file penginstalan senyap.
- Penginstalan komponen yang gagal akan membuat pendaftaran duplikat jika Anda menginstal ulang komponen beberapa kali. Dalam hal ini, pembersihan diperlukan untuk menghapus pendaftaran dengan UUID yang salah.
Diagnosis
Untuk mendiagnosis, kumpulkan data berikut:
- Diagram topologi, dengan nama host dan alamat ip setiap node dan komponen Apigee apa saja yang ada di node tersebut. Pemetaan seperti berikut yang menggunakan profil penginstalan Apigee akan sangat membantu:
DC-1 DS: ip1 hostname DS: ip2 hostname DS: ip3 hostname MS: ip4 hostname RMP: ip5 hostname RMP: ip6 hostname SAX: ip7 hostname DC-2 DS: ip8 hostname DS: ip9 hostname DS: ip10 hostname MS: ip11 hostname RMP: ip12 hostname RMP: ip13 hostname SAX: ip14 hostname
- Buat output hierarki ZooKeeper untuk memeriksa jaringan kabel:
/opt/apigee/apigee-zookeeper/contrib/zk-tree.sh > zk-tree-output.txt
- Untuk memudahkan verifikasi data di hierarki ZooKeeper, jalankan panggilan API pengelolaan berikut
untuk mendapatkan daftar UUID server di setiap pusat data:
Server Gateway
curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=gateway®ion=region-name"
Server Pusat
curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=central®ion=region-name"
Server Analytics
curl -u sysadmin@email.com "http://management-server-host:8080/v1/servers?pod=analytics®ion=region-name"
- Periksa UUID pada setiap komponen dan pastikan keduanya cocok dengan yang Anda lihat di hierarki ZooKeeper:
Router
curl 0:8081/v1/servers/self/uuid
Pemroses Pesan
curl 0:8082/v1/servers/self/uuid
Agen Qpid
curl 0:8083/v1/servers/self/uuid
Agen Postgres
curl 0:8084/v1/servers/self/uuid
- Gunakan data UUID untuk menelusuri output hierarki ZooKeeper yang dihasilkan pada langkah #2 guna memvalidasi jaringan kabel komponen dan untuk menghapus pendaftaran duplikat untuk komponen yang memiliki UUID yang salah.
- Gunakan panggilan API pengelolaan yang tercantum di sini untuk memperbaiki pendaftaran datastore. Komponen seperti Router, Message Processors, Postgres, dan Qpid mendaftar sendiri ke ZooKeeper selama waktu startup.
Resolusi
Masalah terkait data ZooKeeper perlu ditangani secara kasus per kasus. Data di ZooKeeper didasarkan pada topologi Apigee Edge dan bervariasi menurut setiap kasus penggunaan. Jika salah satu dari gejala masalah tersebut terjadi, kumpulkan data seperti yang dijelaskan di bagian sebelumnya, lalu hubungi Dukungan Apigee Edge.