Masa berlaku sertifikat TLS di konfigurasi domain kustom portal developer terintegrasi sudah tidak berlaku

Anda sedang melihat dokumentasi Apigee Edge.
Buka Dokumentasi Apigee X.
info

Gejala

Konfigurasi domain kustom di portal developer terintegrasi tidak akan berfungsi jika TLS rantai sertifikat kedaluwarsa: Publikasikan > Portal > Portal Developer > Pengaturan > Domain.

Pesan Error

Pesan error berikut akan ditampilkan:

Certificate expired

Pesan error ditampilkan di UI Edge seperti yang ditunjukkan di bawah ini:

Portal > Portal Developer > Pengaturan > Domain" title="Domain">

Kemungkinan Penyebab

Penyebab Deskripsi Petunjuk pemecahan masalah berlaku untuk
Rantai sertifikat TLS telah berakhir Jika rantai sertifikat TLS yang diberikan telah habis masa berlakunya, konfigurasi domain kustom akan gagal. Pengguna Edge Public Cloud

Penyebab: Masa berlaku rantai sertifikat TLS telah berakhir

Diagnosis

Lakukan langkah-langkah berikut untuk mendiagnosis masalah:

  1. Verifikasi tanggal dan waktu habis masa berlaku rantai sertifikat TLS.
  2. Jika masa berlaku rantai sertifikat TLS tertentu telah berakhir, hal tersebut akan menyebabkan pembuatan host virtual gagal di portal developer terintegrasi. Hasilnya, pesan {i>error<i} di atas adalah yang ditampilkan kepada pengguna di halaman konfigurasi domain khusus dari UI Edge.

Resolusi

Jika Anda telah memastikan bahwa rantai Sertifikat TLS telah kedaluwarsa, lakukan hal berikut langkah-langkah untuk mengatasi masalah ini:

  1. Dapatkan rantai sertifikat TLS baru dari certificate authority yang relevan.
  2. Konversi rantai sertifikat TLS ke format PEM.
  3. Validasi bahwa rantai sertifikat TLS valid.
  4. Hapus rantai Sertifikat TLS yang ada dari keystore tertentu.
  5. Upload file yang berisi rantai sertifikat TLS dalam format PEM dan file yang berisi kunci pribadi ke keystore menggunakan alias kunci di UI Edge atau API pengelolaan.
  6. Konfigurasi keystore, alias, nama domain di konfigurasi domain kustom portal developer terintegrasi halaman kami.
  7. Klik Simpan.

Jika masalah masih berlanjut, buka Harus mengumpulkan informasi diagnostik.

Harus mengumpulkan informasi diagnostik

Jika masalah berlanjut setelah mengikuti petunjuk di atas, kumpulkan diagnostik berikut dan membagikannya kepada Dukungan Apigee Edge:

  • Nama organisasi Apigee Edge Cloud
  • Nama portal developer terintegrasi Apigee Edge Cloud
  • Nama keystore yang dibuat di lingkungan portal
  • Nama alias
  • Nama domain kustom
  • Screenshot halaman konfigurasi domain kustom yang menangkap pesan error