كتالوج أخطاء وقت التشغيل

أنت الآن بصدد الاطّلاع على مستندات Apigee Edge.
انتقِل إلى مستندات Apigee X.
info

أخطاء في Apigee Edge

عند إرسال طلبات البيانات من واجهة برمجة التطبيقات من خلال Apigee Edge، يمكن أن تعرض مكوّنات Apigee Edge، مثل أجهزة التوجيه ومعالجات الرسائل، أو خوادم الخلفية، أخطاء لتطبيقات العميل.

أخطاء من "معالج الرسائل"

"معالج الرسائل" هو المكوّن الأساسي في Apigee Edge الذي يعالج السياسات ويتفاعل مع خوادم الخلفية. يمكن أن يعرض أخطاءً إذا رصد أي مشاكل، مثل:

  • مشاكل في اتصال الشبكة، وتعذُّر تأكيد الاتصال من خلال بروتوكول أمان طبقة النقل، وعدم توفّر خادم الخلفية، وعدم تلقّي استجابة أثناء التواصل مع خادم الخلفية
  • حالات تعذُّر تنفيذ السياسة
  • عناوين HTTP غير صالحة أو ترميز أو مسار أو عدم الالتزام بمواصفات HTTP أو تجاوز حدود المنتجات وما إلى ذلك:
    • مع طلب HTTP الذي ترسله تطبيقات العميل
    • أو

    • مع استجابة HTTP التي يرسلها خادم الخلفية
  • وغير ذلك الكثير

نموذج خطأ من "معالج الرسائل"

يعرض "معالج الرسائل" دائمًا رمز حالة HTTP متبوعًا برسالة خطأ مع رمز خطأ بتنسيق JSON كما هو موضّح أدناه:

يتلقّى تطبيق العميل رمز استجابة مثل المثال التالي:

HTTP/1.1 414 Request-URI Too Long

تظهر استجابة الخطأ من "معالج الرسائل" بالتنسيق التالي:

{
   "fault":{
      "faultstring":"request line size exceeding 7,168",
      "detail":{
         "errorcode":"protocol.http.TooBigLine"
      }
   }
}

وصف الحقول في ردّ الخطأ:

الحقل الوصف
faultstring يحتوي على رسالة الخطأ التي تصف السبب المحتمل للخطأ
errorcode رمز الخطأ (يُشار إليه أيضًا باسم رمز العطل) المرتبط بالخطأ

قائمة الأخطاء أثناء التشغيل

يوفّر دليل الأخطاء هذا جميع المعلومات التي تحتاج إلى معرفتها حول رموز أخطاء وقت التشغيل (للأخطاء غير المتعلقة بالسياسات) التي يعرضها مكوّن "معالج الرسائل" في Apigee Edge. يتضمّن المعلومات التالية لكل رمز من رموز الخطأ:

  • رمز حالة HTTP
  • رسالة الخطأ
  • الأسباب المحتملة للخطأ
  • أي مواصفات HTTP و/أو حدود قصوى للمنتجات ذات صلة
  • كتيبات إرشادية وفيديوهات تتضمّن تعليمات لتشخيص سبب الخطأ وحلولاً فعّالة يمكنك تطبيقها لحلّ الخطأ بنفسك (في حال توفّرها)
  • إصلاح يمكنك تطبيقه لحلّ الخطأ بنفسك

يتم تناول فئات رموز الأخطاء التالية:

استخدِم مربّع البحث أدناه لفلترة الجدول وعرض المعلومات المذكورة أعلاه لرمز خطأ معيّن. يمكنك البحث عن رمز الحالة أو أي محتوى في أي حقل في الجدول.

رمز الخطأ الوصف تعديل الإجابات

flow.*

flow.APITimedOut

  • رمز حالة HTTP:
504 Gateway Timeout
  • رسالة الخطأ:
API timed out
  • السبب المحتمل:

يحدث هذا الخطأ في الحالات التالية:

  • لا يستجيب خادم الخلفية خلال فترة المهلة التي تم ضبطها من خلال السمة api.timeout لخادم وكيل واجهة برمجة التطبيقات المحدّد.
  • تستغرق السياسة وقتًا طويلاً بسبب العمليات التي تتطلّب قدرًا كبيرًا من الحسابات أو الحمل الزائد أو الأداء الضعيف.

ملاحظة: يقدّم دليل التشغيل هذا تعليمات لتحديد وحلّ المشاكل المتعلّقة برمز الخطأ messaging.adaptors.http.flow.GatewayTimeout، ولكن يمكنك استخدام دليل التشغيل نفسه لتحديد وحلّ المشاكل المتعلّقة برمز الخطأ flow.APITimedOut.

دليل إرشادي

flow.SharedFlowNotFound

  • رمز حالة HTTP:
500 Internal Server Error
  • رسالة الخطأ:
Shared Flow {shared_flow_name} Not Found
  • السبب المحتمل:

يحدث هذا الخطأ إذا كان مسار العمل المشترَك المحدّد:

  • غير موجود
  • أو

  • موجودة ولكن لم يتم نشرها
دليل إرشادي

messaging.adaptors.http.flow

messaging.adaptors.http.flow.ApplicationNotFound

  • رمز حالة HTTP:
404 Not Found
  • رسالة الخطأ:
Unable to identify proxy for host: {virtual_host} and url: {pathsuffix}
  • السبب المحتمل:

يحدث هذا الخطأ في إحدى الحالات التالية:

  1. وكيل واجهة برمجة التطبيقات المحدّد هو:
    1. لم يتم ضبطها لقبول الطلبات على المضيف الافتراضي المحدّد
    2. لم يتم ضبطه لقبول الطلبات على المسار المحدّد المستخدَم في الطلب
    3. لم يتم نشرها في البيئة المحدّدة التي تحاول فيها إرسال طلبات إلى واجهة برمجة التطبيقات
    4. لم يتم نشره على معالج رسائل واحد أو أكثر
  2. لم يتم تحميل البيئة المحدّدة التي تحاول فيها إرسال طلبات البيانات من واجهة برمجة التطبيقات على معالج رسائل واحد أو أكثر
الدليل الإرشادي
يمكن أن يحدث هذا الخطأ أيضًا إذا كان لدى مضيفات افتراضية متعددة الاسم المستعار للمضيف ورقم المنفذ نفسهما. دليل إرشادي

messaging.adaptors.http.flow.DecompressionFailureAtRequest

  • رمز حالة HTTP:
400 Bad Request
  • رسالة الخطأ:
Decompression failure at request
  • السبب المحتمل:

يحدث هذا الخطأ فقط في الحالات التالية:

  • التشفير المحدّد في عنوان طلب HTTP Content-Encoding صالح و متوافق مع Apigee Edge،
  • BUT

  • لا يتطابق تنسيق الحمولة الذي يرسله العميل كجزء من طلب HTTP مع تنسيق الترميز المحدّد في العنوان Content-Encoding.
الدليل الإرشادي

messaging.adaptors.http.flow.DecompressionFailureAtResponse

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
Decompression failure at response
  • السبب المحتمل:

يحدث هذا الخطأ فقط في الحالات التالية:

  • الترميز المحدّد في عنوان استجابة HTTP Content-Encoding للخادم الخلفي/الهدف صالح و متوافق مع Apigee Edge.
  • BUT

  • لا يتطابق تنسيق الحمولة الذي يرسله الخادم الخلفي/الخادم المستهدف كجزء من استجابة HTTP مع تنسيق الترميز المحدّد في العنوان Content-Encoding
الدليل الإرشادي

messaging.adaptors.http.flow.ErrorResponseCode

  • رمز حالة HTTP:
500

الدليل الإرشادي

فيديو

  • رسالة الخطأ:
قد تختلف رسالة الخطأ وتنسيقه حسب طريقة تنفيذ خادم الخلفية.
  • السبب المحتمل:
يحدث هذا الخطأ إذا استجاب خادم الخلفية برمز الحالة 500 إلى Apigee Edge.
  • رمز حالة HTTP:
503

دليل إرشادي

الفيديو

  • رسالة الخطأ:
قد تختلف رسالة الخطأ وتنسيقه حسب طريقة تنفيذ خادم الخلفية.
  • السبب المحتمل:
يحدث هذا الخطأ إذا استجاب خادم الخلفية برمز الحالة 503 إلى Apigee Edge.
  • رمز حالة HTTP:
504 الدليل الإرشادي
  • رسالة الخطأ:
قد تختلف رسالة الخطأ وتنسيقه حسب طريقة تنفيذ خادم الخلفية.
  • السبب المحتمل:
يحدث هذا الخطأ إذا استجاب خادم الخلفية برمز الحالة 504 إلى Apigee Edge.

ملاحظة: لا يتم عرض رمز الخطأ messaging.adaptors.http.flow.ErrorResponseCode كجزء من رسالة الخطأ المرسَلة إلى تطبيقات العميل. ويرجع ذلك إلى أنّ رمز الخطأ هذا يتم ضبطه بواسطة Apigee Edge عندما يستجيب خادم الخلفية بخطأ وأي من رموز الحالة 4XX أو 5XX. يمكنك الاطّلاع على رمز الخطأ هذا في "مراقبة واجهة برمجة التطبيقات" أو سجلات الوصول إلى NGINX أو قاعدة بيانات الإحصاءات.

messaging.adaptors.http.flow.GatewayTimeout

  • رمز حالة HTTP:
504 Gateway Timeout
  • رسالة الخطأ:
Gateway Timeout
  • السبب المحتمل:
يحدث هذا الخطأ إذا لم يستجب خادم الخلفية إلى "معالج الرسائل" في Apigee Edge خلال فترة مهلة الإدخال/الإخراج التي تم ضبطها في "معالج الرسائل".
الدليل الإرشادي

messaging.adaptors.http.flow.LengthRequired

  • رمز حالة HTTP:
411 Length Required
  • رسالة الخطأ:
'Content-Length' is missing
  • السبب المحتمل:

يحدث هذا الخطأ إذا لم يتم تمرير العنوان Content-Length من خلال تطبيق العميل كجزء من طلبات HTTP POST وPUT المرسَلة إلى Apigee Edge.

ملاحظة: لا يمكن تسجيل الطلبات التي تعذّر تنفيذها بسبب هذا الخطأ في أداة "التتبُّع"، لأنّ "معالج الرسائل" يجري عملية التحقّق هذه في مرحلة مبكرة جدًا، أي قبل معالجة الطلب وتنفيذ أي سياسة في خادم وكيل واجهة برمجة التطبيقات.

  • مواصفات HTTP:
القسم 3.3.2 من RFC: Content-Length

تعديل الإجابات

لحلّ هذا الخطأ، اتّبِع الخطوات التالية:

  1. تأكَّد من أنّ تطبيق العميل يمرِّر العنوان Content-Length دائمًا كجزء من طلبات HTTP POST وPUT المُرسَلة إلى Apigee Edge. على سبيل المثال:

    curl -X POST https://HOSTALIAS/PATH -d '{"name": "abc"}' -H "Content-Length: 15"
    
  2. حتى إذا كنت تمرّر حمولة فارغة مع طلبات POST وPUT، تأكَّد من تمرير العنوان Content-Length: 0. على سبيل المثال:

    curl -X POST https://HOSTALIAS/PATH -H "Content-Length: 0"
    

messaging.adaptors.http.flow.NoActiveTargets

  • رمز حالة HTTP:
503 Service Unavailable
  • رسالة الخطأ:
The Service is temporarily unavailable
  • السبب المحتمل:

يحدث هذا الخطأ في إحدى الحالات التالية، إذا كنت تستخدم TargetServer في Apigee Edge:

  1. أدّى عدم التحويل باستخدام نظام أسماء النطاقات (DNS) بشكل صحيح لمضيف خادم الخلفية من خلال خادم المصادقة المخصّص إلى عناوين IP غير صالحة، ما أدّى إلى حدوث أخطاء في الاتصال.
  2. أخطاء انتهاء مهلة الاتصال بسبب:
    1. يمنع جدار الحماية على خادم الخلفية Apigee Edge من الاتصال بخادم الخلفية.
    2. مشاكل في الاتصال بالشبكة بين Apigee Edge وخادم الخلفية
  3. المضيف المحدّد في TargetServer غير صحيح أو يحتوي على أحرف غير مرغوب فيها (مثل مسافة).

الدليل الإرشادي

الفيديو

يمكن أن يحدث هذا الخطأ أيضًا إذا تعذّر إجراء عمليات التحقّق من الصحة التي تم ضبطها لمراقبة عملية التحقّق من الصحة للخوادم المستهدَفة.

دليل إرشادي

الفيديو

messaging.adaptors.http.flow.RequestTimeOut

  • رمز حالة HTTP:
408 Request Timeout
  • رسالة الخطأ:
Request timed out
  • السبب المحتمل:
يحدث هذا الخطأ إذا لم يتلقَّ "معالج الرسائل" في Apigee Edge حمولة الطلب من تطبيق العميل خلال فترة المهلة المحدّدة للإدخال/الإخراج التي تم ضبطها في مكوّن "معالج الرسائل".

تعديل الإجابات

تأكَّد من أنّ تطبيق العميل يرسل حمولة الطلب خلال فترة المهلة المحدّدة للإدخال/الإخراج التي تم ضبطها على مكوّن "معالج الرسائل" في Apigee Edge.

messaging.adaptors.http.flow.ServiceUnavailable

  • رمز حالة HTTP:
503 Service Unavailable
  • رسالة الخطأ:
The Service is temporarily unavailable
  • السبب المحتمل:

يحدث هذا الخطأ في إحدى الحالات التالية:

  1. أدّى عدم التحويل باستخدام نظام أسماء النطاقات (DNS) بشكل صحيح لمضيف خادم الخلفية من خلال خادم المصادقة المخصّص إلى عناوين IP غير صالحة، ما أدّى إلى حدوث أخطاء في الاتصال.
  2. أخطاء انتهاء مهلة الاتصال بسبب:
    1. يمنع قيود جدار الحماية على خادم الخلفية Apigee Edge من الاتصال بخادم الخلفية.
    2. مشاكل في الاتصال بالشبكة بين Apigee Edge وخادم الخلفية
  3. مضيف الخادم المستهدَف المحدّد في نقطة النهاية المستهدَفة غير صحيح أو يحتوي على أحرف غير مرغوب فيها (مثل المسافة).

الدليل الإرشادي

تعطُّل نظام أسماء النطاقات:

فيديو

الاتصال بالشبكة:

فيديو

يمكن أن يحدث هذا الخطأ أيضًا إذا أغلق خادم الخلفية الاتصال قبل الأوان بينما كان "معالج الرسائل" لا يزال يرسل حمولة الطلب إلى خادم الخلفية. دليل إرشادي

messaging.adaptors.http.flow.SslHandshakeFailed

  • رمز حالة HTTP:
503 Service Unavailable
  • رسالة الخطأ:
SSL Handshake failed {error_message}
  • السبب المحتمل:

يحدث هذا الخطأ أثناء عملية المصافحة عبر بروتوكول SSL بين معالج الرسائل في Apigee Edge وخادم الخلفية في الحالات التالية:

  1. ملف truststore الخاص بـ "معالج الرسائل" في Apigee Edge:
    • يحتوي على سلسلة شهادات لا تتطابق مع سلسلة الشهادات الكاملة لخادم الخلفية
    • أو

    • لا يحتوي على سلسلة الشهادات الكاملة لخادم الخلفية
  2. سلسلة الشهادات التي قدّمها خادم الخلفية:
    • يحتوي على اسم نطاق مؤهَّل بالكامل (FQDN) لا يتطابق مع اسم المضيف المحدّد في نقطة النهاية المستهدَفة
    • أو

    • تحتوي على سلسلة شهادات غير صحيحة أو غير مكتملة

دليل إرشادي

فيديو

messaging.adaptors.http.flow.UnexpectedEOFAtTarget

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
Unexpected EOF at target
  • السبب المحتمل:

يحدث هذا الخطأ في إحدى الحالات التالية:

  1. لم يتم ضبط TargetServer بشكل صحيح لإتاحة اتصالات TLS/SSL في Apigee Edge.
  2. قد ينهي خادم الخلفية الاتصال فجأة، بينما ينتظر Apigee Edge ردًا من خادم الخلفية.
  3. تم ضبط مهلات البقاء على قيد الحياة بشكلٍ غير صحيح على Apigee وخادم الخلفية.
الدليل الإرشادي

messaging.runtime.*

messaging.runtime.RouteFailed

  • رمز حالة HTTP:
500 Internal Server Error
  • رسالة الخطأ:
Unable to route the message to a TargetEndpoint
  • السبب المحتمل:

يحدث هذا الخطأ إذا تعذّر على Apigee Edge توجيه الطلب إلى أي من TargetEndpoints للأسباب التالية:

  • ما مِن شرط لقاعدة توجيه (<RouteRule>) يتطابق مع الطلب في خادم وكيل
  • و

  • لم يتم تحديد قاعدة مسار تلقائية في ProxyEndpoint (أي، ‫<RouteRule> بدون أي شرط)

تعديل الإجابات

لحلّ هذا الخطأ، اتّبِع التعليمات التالية:

  1. راجِع قواعد المسارات المحدّدة في ProxyEndpoint وعدِّلها للتأكّد من أنّ هناك شرطًا واحدًا على الأقل من شروط قاعدة المسار يتطابق مع طلبك.
  2. من أفضل الممارسات تحديد قاعدة مسار تلقائية بدون أي شرط عندما يكون لديك عدة RouteRules.
  3. تأكَّد من تحديد قاعدة المسار التلقائي دائمًا في آخر قائمة المسارات الشرطية، لأنّه يتم تقييم القواعد من الأعلى إلى الأسفل في ProxyEndpoint.

لمزيد من المعلومات حول تحديد شروط <RouteRule> في ProxyEndpoint، راجِع الاستهدافات الشرطية.

messaging.runtime.SenseRaiseFault

  • رمز حالة HTTP:
403 Forbidden
  • رسالة الخطأ:
Sense Fault
  • السبب المحتمل:
يحدث هذا الخطأ إذا تم إرسال طلب بيانات من واجهة برمجة التطبيقات من عنوان IP خاص بعميل معيّن تم حظره كجزء من قواعد Apigee Sense.

تعديل الإجابات

لحلّ هذا الخطأ، اتّبِع التعليمات التالية:

  1. تأكَّد من حظر عنوان IP الخاص بالعميل المحدّد من خلال التحقّق من القواعد التي تم ضبطها في Apigee Sense. إذا تم حظره، يعني ذلك أنّه يعمل على النحو المطلوب.
  2. إذا لم يتم حظر عنوان IP الخاص بالعميل، ولكن استمر ظهور هذا الخطأ، يُرجى التواصل مع فريق دعم Apigee Edge.

protocol.http.* - Caused due to bad request

protocol.http.BadFormData

  • رمز حالة HTTP:
500 Internal Server Error
  • رسالة الخطأ:
Bad Form Data
  • السبب المحتمل:

يحدث هذا الخطأ فقط في حال استيفاء جميع الشروط التالية:

  1. يتضمّن طلب HTTP الذي يرسله العميل إلى Apigee Edge ما يلي:
    • ‫ Content-Type: application/x-www-form-urlencoded، و
    • بيانات النموذج التي تتضمّن علامة النسبة المئوية (%) أو علامة النسبة المئوية (%) متبوعة بأحرف سداسية عشرية غير صالحة وغير مسموح بها وفقًا لنماذج الإدخال - الفقرة 17.13.4.1
  2. يقرأ خادم وكيل واجهة برمجة التطبيقات في Apigee Edge مَعلمات النموذج المحدّدة التي تحتوي على أي أحرف غير مسموح بها باستخدام سياسة ExtractVariables أو AssignMessage في مسار الطلب.
الدليل الإرشادي

protocol.http.DuplicateHeader

  • رمز حالة HTTP:
400 Bad Request
  • رسالة الخطأ:
Duplicate Header "{header_name}"
  • السبب المحتمل:
يحدث هذا الخطأ إذا ظهر عنوان HTTP معيّن غير مسموح بتكراره في Apigee Edge أكثر من مرة بقيم متطابقة أو مختلفة كجزء من طلب HTTP الذي أرسله تطبيق العميل إلى Apigee Edge.
  • مواصفات HTTP:
RFC 7230، القسم 3.2.2: ترتيب الحقول
الدليل الإرشادي

protocol.http.EmptyHeaderName

  • رمز حالة HTTP:
400 Bad Request
  • رسالة الخطأ:
Header name cannot be empty
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان اسم العنوان الذي يتم إرساله كجزء من طلب HTTP من تطبيق العميل إلى Apigee Edge فارغًا.
  • مواصفات HTTP:
RFC 7230، الفقرة 3.2: حقول العناوين

تعديل الإجابات

تأكَّد من أنّ طلب HTTP الذي يرسله تطبيق العميل إلى Apigee Edge يتضمّن دائمًا اسم عنوان صالحًا وفقًا للفقرة 3.2 من معايير RFC 7230: حقول العناوين.

protocol.http.HeaderNameWithNonAsciiChar

  • رمز حالة HTTP:
400 Bad Request
  • رسالة الخطأ:
Header {header_name} contains non ascii character {character}
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان اسم العنوان المُرسَل كجزء من طلب HTTP من خلال تطبيق العميل إلى Apigee Edge يحتوي على أحرف غير ASCII.
  • مواصفات HTTP:

RFC 7230، القسم 3.2: حقول العناوين و RFC 7230، القسم 3.2.6: مكوّنات قيمة الحقل

تعديل الإجابات

تأكَّد من أنّ طلب HTTP الذي يرسله العميل إلى Apigee Edge لا يحتوي على أحرف غير ASCII في أسماء العناوين وفقًا للمعيار RFC 7230، القسم 3.2.6: مكونات قيمة الحقل.

protocol.http.HeaderWithInvalidChar

  • رمز حالة HTTP:
400 Bad Request
  • رسالة الخطأ:
Header {header_name} contains invalid character {character}
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان اسم العنوان المُرسَل كجزء من طلب HTTP من تطبيق العميل إلى Apigee Edge يحتوي على أحرف غير صالحة، مثل علامة يساوي (=) والفاصلة (،) والفاصلة المنقوطة (؛) وعلامة التبويب وCRLF وحرف السطر الجديد.
  • مواصفات HTTP:

RFC 7230، القسم 3.2: حقول العناوين و RFC 7230، القسم 3.2.6: مكوّنات قيمة الحقل

تعديل الإجابات

تأكَّد من أنّ طلب HTTP الذي يرسله تطبيق العميل إلى Apigee Edge لا يحتوي على أي أحرف غير صالحة في أسماء العناوين وفقًا للمعيار RFC 7230، القسم 3.2.6: مكوّنات قيمة الحقل.

protocol.http.InvalidPath

  • رمز حالة HTTP:
400 Bad Request
  • رسالة الخطأ:
Invalid path {path}
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان المسار في عنوان URL لطلب HTTP الذي أرسله تطبيق العميل إلى Apigee Edge يحتوي على أحرف غير مسموح بها وفقًا للمواصفات RFC 3986، القسم 3.3: المسار.
  • مواصفات HTTP:

الفقرة 3 من معيار RFC 3986: عناصر البنية و الفقرة 3.3 من معيار RFC 3986: المسار

تعديل الإجابات

تأكَّد من أنّ المسار في عنوان URL لطلب HTTP الذي يرسله تطبيق العميل إلى Apigee Edge لا يتضمّن أي أحرف غير مسموح بها وفقًا للمعيار RFC 3986، القسم 3.3: المسار.

protocol.http.MessageReadError

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
Unexpected I/O after message headers have been read.
  • السبب المحتمل:
يحدث هذا الخطأ النادر عندما يتلقّى MP عمليات إدخال/إخراج على قناة عندما لا يتوقّع ذلك. يقرأ MP طلبًا، وقد قرأ جميع العناوين، وتم ضبطه لقراءة حمولة الطلب. ثم يصادف حدث إدخال/إخراج يبدو أنّه مخصّص للعناوين نفسها.

تعديل الإجابات

ابحث عن رسالة السجلّ للحصول على مزيد من المعلومات عن المشكلة.

logger.atSevere().log(
    "Unexpected I/O after message headers have been read. Channel diagnostics=%s."
        + " HeartBeat=%s",
    input.client().getDiagnostic(), message.getHeaders().isHeartBeat());
                

protocol.http.TooBigBody

  • رمز حالة HTTP:
413 Request Entity Too Large
  • رسالة الخطأ:
Body buffer overflow
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان حجم الحمولة التي يرسلها تطبيق العميل كجزء من طلب HTTP إلى Apigee Edge أكبر من الحدّ المسموح به في Apigee Edge.
  • الحدود:
حدود Apigee Edge
الدليل الإرشادي

protocol.http.TooBigHeaders

  • رمز حالة HTTP:
431 Request Header Fields Too Large
  • رسالة الخطأ:
request headers size exceeding {limit}
  • السبب المحتمل:
يتجاوز إجمالي حجم جميع عناوين الطلبات التي يرسلها تطبيق العميل كجزء من طلب HTTP إلى Apigee Edge الحدّ المسموح به في Apigee Edge.
  • مواصفات HTTP:
RFC 6585، القسم 5: 431 Request Header Fields Too Large
  • الحدود:
حدود Apigee Edge
الدليل الإرشادي

protocol.http.TooBigLine

  • رمز حالة HTTP:
414 Request-URI Too Long
  • رسالة الخطأ:
request line size exceeding {limit}
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان حجم سطر الطلب الذي أرسله تطبيق العميل كجزء من طلب HTTP إلى Apigee Edge أكبر من الحدّ المسموح به في Apigee Edge.
  • الحدود:
حدود Apigee Edge
الدليل الإرشادي

protocol.http.UnsupportedEncoding

  • رمز حالة HTTP:
415 Unsupported Media
  • رسالة الخطأ:
Unsupported Encoding "{encoding}"
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان العنوان Content-Encoding الذي أرسله العميل كجزء من استجابة HTTP يحتوي على تنسيق ترميز/حمولة غير متوافق مع Apigee Edge.
  • مواصفات HTTP:
RFC 7231, section 6.5.13: 415 Unsupported Media Type
الدليل الإرشادي

protocol.http.* - Caused by target

protocol.http.BadPath

  • رمز حالة HTTP:
500 Internal Server Error
  • رسالة الخطأ:
Invalid request path
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان عنوان URL للطلب الخاص بخادم الخلفية، والذي يمثّله متغيّر التدفق target.url، يحتوي على مسار يبدأ بعلامة استفهام (?) بدلاً من شرطة مائلة للأمام (/)، وهو ما يُعدّ غير صالح.
  • مواصفات HTTP:

الفقرة 3 من معيار RFC 3986: عناصر البنية و الفقرة 3.3 من معيار RFC 3986: المسار

الدليل الإرشادي

protocol.http.DuplicateHeader

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
Duplicate Header "{header_name}"
  • السبب المحتمل:
يحدث هذا الخطأ إذا ظهر عنوان HTTP المحدّد الذي لا يُسمح بتكراره في Apigee Edge أكثر من مرة بقيم متطابقة أو مختلفة كجزء من استجابة HTTP التي يرسلها خادم الخلفية إلى Apigee Edge.
  • مواصفات HTTP:
RFC 7230، القسم 3.2.2: ترتيب الحقول
دليل إرشادي

protocol.http.EmptyHeaderName

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
Header name cannot be empty
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان اسم العنوان الذي يرسله خادم الخلفية كجزء من استجابة HTTP إلى Apigee Edge فارغًا.
  • مواصفات HTTP:
RFC 7230، الفقرة 3.2: حقول العناوين

تعديل الإجابات

تأكَّد من أنّ استجابة HTTP التي يرسلها خادم الخلفية إلى Apigee Edge تتضمّن دائمًا اسم عنوان صالحًا وفقًا للفقرة 3.2 من معايير RFC 7230: حقول العناوين.

protocol.http.EmptyPath

  • رمز حالة HTTP:
500 Internal Server Error
  • رسالة الخطأ:
Request path cannot be empty
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان عنوان URL لطلب HTTP الخاص بخادم الخلفية، والذي يمثّله متغيّر التدفق target.url، يحتوي على مسار فارغ.
  • مواصفات HTTP:

RFC 3986، الفقرة 3: عناصر البنية و RFC 3986، الفقرة 3.3: المسار

الدليل الإرشادي

protocol.http.HeaderNameWithNonAsciiChar

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
Header {header_name} contains non ascii character {character}
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان اسم العنوان الذي أرسله خادم الخلفية كجزء من استجابة HTTP إلى Apigee Edge يحتوي على أحرف غير ASCII.
  • مواصفات HTTP:

RFC 7230، القسم 3.2: حقول العناوين و RFC 7230، القسم 3.2.6: مكوّنات قيمة الحقل

تعديل الإجابات

تأكَّد من أنّ استجابة HTTP التي يرسلها خادم الخلفية إلى Apigee Edge لا تحتوي على أحرف غير ASCII في أسماء العناوين وفقًا للمعيار RFC 7230، القسم 3.2.6: مكونات قيمة الحقل.

protocol.http.HeaderWithInvalidChar

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
Header {header_name} contains invalid character {character}
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان اسم العنوان الذي أرسله خادم الخلفية كجزء من استجابة HTTP يحتوي على أحرف غير صالحة، مثل علامة يساوي (=) والفاصلة (,) والفاصلة المنقوطة (;) وعلامة التبويب وCRLF وحرف السطر الجديد.
  • مواصفات HTTP:

RFC 7230، القسم 3.2: حقول العناوين و RFC 7230، القسم 3.2.6: مكوّنات قيمة الحقل

تعديل الإجابات

تأكَّد من أنّ استجابة HTTP التي يرسلها خادم الخلفية إلى Apigee Edge لا تحتوي على أي أحرف غير صالحة في أسماء العناوين وفقًا للمعيار RFC 7230، القسم 3.2.6: مكونات قيم الحقول.

protocol.http.ProxyTunnelCreationFailed

  • رمز حالة HTTP:
503 Service Unavailable
  • رسالة الخطأ:
Proxy refused to create tunnel with response status {status code}
  • السبب المحتمل:

يحدث هذا الخطأ أثناء إنشاء النفق بين Apigee Edge وخادم الخلفية من خلال خادم وكيل بسبب جدار الحماية أو قائمة التحكّم بالوصول (ACL) أو مشاكل نظام أسماء النطاقات (DNS) أو مدى توفّر خادم الخلفية أو غير ذلك.

ملاحظة: يقدّم رمز الحالة في رسالة الخطأ (faultstring) السبب العام للمشكلة.

دليل إرشادي

protocol.http.Response306Reserved

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
Response Status code 306 is reserved, so can't be used.
  • السبب المحتمل:

يحدث هذا الخطأ إذا ردّ خادم الخلفية برمز الحالة 306 إلى Apigee Edge.

تم تحديد رمز الحالة 306 في إصدار سابق من مواصفات HTTP. وفقًا لمواصفات HTTP الحالية، هذا الرمز محجوز ويجب عدم استخدامه.

  • مواصفات HTTP:
RFC 7231، الفقرة 6.3.5: 306 Reserved

تعديل الإجابات

بما أنّ رمز الحالة 306 محجوز، تأكَّد من أنّ خادم الخلفية لا يستخدم رمز الحالة هذا عند إرسال ردّ إلى Apigee Edge.

protocol.http.Response405WithoutAllowHeader

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
Received 405 Response without Allow Header
  • السبب المحتمل:
يستجيب خادم الخلفية برمز الحالة 405 Method Not Allowed بدون العنوان Allow.
  • مواصفات HTTP:

RFC 7231، القسم 6.5.5: 405 Method Not Allowed و RFC 7231، القسم 7.4.1: Allow

الدليل الإرشادي

protocol.http.ResponseWithBody

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
Received {status_code} Response with message body
  • السبب المحتمل:

يحدث هذا الخطأ إذا كانت استجابة HTTP من خادم الخلفية إلى Apigee Edge هي 204 No Content أو 205 Reset Content، ولكنها تحتوي على نص الاستجابة و/أو عنوان واحد أو أكثر من العناوين التالية:

  • Content-Length
  • Content-Encoding
  • Transfer-Encoding
  • مواصفات HTTP:

RFC 7231، القسم 6.3.5: 204 No Content و RFC 7231، القسم 6.3.6: 205 Reset Content

الدليل الإرشادي

protocol.http.TooBigBody

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
Body buffer overflow
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان حجم الحمولة التي يرسلها تطبيق العميل كجزء من طلب HTTP إلى Apigee Edge أكبر من الحدّ المسموح به في Apigee Edge.
  • الحدود:
حدود Apigee Edge
الدليل الإرشادي

protocol.http.TooBigHeaders

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
response headers size exceeding {limit}
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان الحجم الإجمالي لجميع عناوين الاستجابة التي أرسلها خادم الخلفية كجزء من استجابة HTTP إلى Apigee Edge أكبر من الحد المسموح به في Apigee Edge.
  • الحدود:
حدود Apigee Edge
الدليل الإرشادي

protocol.http.TooBigLine

  • رمز حالة HTTP:
502 Bad Gateway
  • رسالة الخطأ:
response line size exceeding {limit}
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان حجم سطر الردّ الذي يرسله خادم الخلفية كجزء من استجابة HTTP إلى Apigee Edge أكبر من الحدّ المسموح به في Apigee Edge.
  • الحدود:
حدود Apigee Edge
الدليل الإرشادي

protocol.http.UnsupportedEncoding

  • رمز حالة HTTP:
415 Unsupported Media
  • رسالة الخطأ:
Unsupported Encoding "{encoding}"
  • السبب المحتمل:
يحدث هذا الخطأ إذا كان العنوان Content-Encoding الذي أرسله خادم الخلفية كجزء من استجابة HTTP يحتوي على تنسيق الترميز/الحِمل الذي لا يتوافق مع Apigee Edge.
  • مواصفات HTTP:
RFC 7231, section 6.5.13: 415 Unsupported Media Type
الدليل الإرشادي

security.util.*

security.util.KeyAliasNotFound

  • رمز حالة HTTP:
500 Internal Server Error
  • رسالة الخطأ:
KeyAlias {KeyAlias_name} is not found in Keystore {Keystore_Name}
  • السبب المحتمل:

يحدث هذا الخطأ إذا لم يتم العثور على KeyAlias المحدّد المشار إليه في TargetEndpoint أو TargetServer في Keystore المحدّد.

تعديل الإجابات

تأكَّد من أنّ KeyAlias المحدّد في TargetEndpoint أو TargetServer متوفّر وهو جزء من ملف تخزين المفاتيح المحدّد.

security.util.TrustStoreWithNoCertificates

  • رمز حالة HTTP:
500 Internal Server Error
  • رسالة الخطأ:
TrustStore {truststore_name} has no certificates
  • السبب المحتمل:

يحدث هذا الخطأ إذا كان Truststore المحدّد المشار إليه في TargetEndpoint أو TargetServer لا يحتوي على أي شهادات.

تعديل الإجابات

إذا أردت التحقّق من صحة شهادة خادم الخلفية وأردت استخدام Truststore في TargetEndpoint أو TargetServer، تأكَّد من أنّ Truststore يحتوي على شهادات صالحة لخادم الخلفية.