flow.*
flow.APITimedOut
504 Gateway Timeout
API timed out
ข้อผิดพลาดนี้จะเกิดขึ้นในกรณีต่อไปนี้
เซิร์ฟเวอร์แบ็กเอนด์ไม่ตอบกลับภายในระยะหมดเวลาที่กำหนดค่า
โดยพร็อพเพอร์ตี้
api.timeout สำหรับพร็อกซี API ที่เฉพาะเจาะจง
นโยบายใช้เวลานานเนื่องจากการดำเนินการที่ต้องใช้การคำนวณสูง มีภาระงานสูง หรือประสิทธิภาพต่ำ
หมายเหตุ: Playbook นี้มีวิธีการแก้ปัญหารหัสข้อผิดพลาด
messaging.adaptors.http.flow.GatewayTimeout แต่คุณสามารถใช้
Playbook เดียวกันเพื่อแก้ปัญหารหัสข้อผิดพลาด flow.APITimedOut ได้
PLAYBOOK
flow.SharedFlowNotFound
500 Internal Server Error
Shared Flow {shared_flow_name} Not Found
ข้อผิดพลาดนี้จะเกิดขึ้นหากโฟลว์ที่แชร์เฉพาะมีลักษณะดังนี้
ไม่มี
หรือ
มีอยู่แต่ไม่ได้ใช้งาน
PLAYBOOK
messaging.adaptors.http.flow
messaging.adaptors.http.flow.ApplicationNotFound
404 Not Found
Unable to identify proxy for host: {virtual_host} and url: {pathsuffix}
ข้อผิดพลาดนี้เกิดขึ้นในสถานการณ์ใดสถานการณ์หนึ่งต่อไปนี้
พร็อกซี API ที่เฉพาะเจาะจงคือ
ไม่ได้กำหนดค่าให้ยอมรับคำขอใน
โฮสต์เสมือนที่เฉพาะเจาะจง
ไม่ได้กำหนดค่าให้ยอมรับคำขอในเส้นทางที่เฉพาะเจาะจง
ที่ใช้ในคำขอ
ไม่ได้ติดตั้งใช้งานในสภาพแวดล้อมที่เฉพาะเจาะจงซึ่งคุณ
พยายามส่งคำขอ API
ไม่ได้ติดตั้งใช้งานใน Message Processor อย่างน้อย 1 รายการ
ระบบไม่ได้โหลดสภาพแวดล้อมที่เฉพาะเจาะจงซึ่งคุณพยายามส่งคำขอ API ในตัวประมวลผลข้อความอย่างน้อย 1 รายการ
PLAYBOOK
ข้อผิดพลาดนี้ยังอาจเกิดขึ้นหากโฮสต์เสมือนหลายรายการมีนามแฝงโฮสต์และหมายเลขพอร์ตเดียวกัน
PLAYBOOK
messaging.adaptors.http.flow.DecompressionFailureAtRequest
400 Bad Request
Decompression failure at request
ข้อผิดพลาดนี้จะเกิดขึ้นในกรณีต่อไปนี้เท่านั้น
การเข้ารหัสที่ระบุในส่วนหัวของคำขอ HTTP
Content-Encoding ใช้ได้และ
รองรับโดย Apigee Edge
BUT
รูปแบบเพย์โหลดที่ไคลเอ็นต์ส่งเป็นส่วนหนึ่งของคำขอ HTTP
ไม่ตรงกับรูปแบบการเข้ารหัสที่ระบุในส่วนหัว Content-Encoding
PLAYBOOK
messaging.adaptors.http.flow.DecompressionFailureAtResponse
502 Bad Gateway
Decompression failure at response
ข้อผิดพลาดนี้จะเกิดขึ้นในกรณีต่อไปนี้เท่านั้น
การเข้ารหัสที่ระบุในส่วนหัวการตอบกลับ HTTP Content-Encoding ของเซิร์ฟเวอร์แบ็กเอนด์/เป้าหมาย
ถูกต้องและ
รองรับโดย Apigee Edge
BUT
รูปแบบเพย์โหลดที่แบ็กเอนด์/เซิร์ฟเวอร์เป้าหมายส่งเป็นส่วนหนึ่งของการตอบกลับ HTTP ไม่ตรงกับรูปแบบการเข้ารหัสที่ระบุในส่วนหัว Content-Encoding
PLAYBOOK
messaging.adaptors.http.flow.ErrorResponseCode
500
PLAYBOOK
วิดีโอ
ข้อความแสดงข้อผิดพลาดและรูปแบบอาจแตกต่างกันไปตามการติดตั้งใช้งานเซิร์ฟเวอร์แบ็กเอนด์
ข้อผิดพลาดนี้เกิดขึ้นหากเซิร์ฟเวอร์แบ็กเอนด์ตอบกลับด้วยรหัสสถานะ 500 ไปยัง Apigee Edge
503
PLAYBOOK
วิดีโอ
ข้อความแสดงข้อผิดพลาดและรูปแบบอาจแตกต่างกันไปตามการติดตั้งใช้งานเซิร์ฟเวอร์แบ็กเอนด์
ข้อผิดพลาดนี้เกิดขึ้นหากเซิร์ฟเวอร์แบ็กเอนด์ตอบกลับด้วยรหัสสถานะ 503 ไปยัง Apigee Edge
504
PLAYBOOK
ข้อความแสดงข้อผิดพลาดและรูปแบบอาจแตกต่างกันไปตามการติดตั้งใช้งานเซิร์ฟเวอร์แบ็กเอนด์
ข้อผิดพลาดนี้เกิดขึ้นหากเซิร์ฟเวอร์แบ็กเอนด์ตอบกลับด้วยรหัสสถานะ 504 ไปยัง Apigee Edge
หมายเหตุ: ระบบจะไม่แสดงรหัสข้อผิดพลาด
messaging.adaptors.http.flow.ErrorResponseCode
เป็นส่วนหนึ่งของข้อความแสดงข้อผิดพลาดที่ส่งไปยังแอปพลิเคชันไคลเอ็นต์ เนื่องจาก Apigee Edge จะตั้งรหัสข้อผิดพลาดนี้เมื่อใดก็ตามที่เซิร์ฟเวอร์แบ็กเอนด์
ตอบสนองด้วยข้อผิดพลาดและรหัสสถานะ 4XX หรือ 5XX
คุณดูรหัสข้อผิดพลาดนี้ได้ในการตรวจสอบ API, บันทึกการเข้าถึง NGINX
หรือฐานข้อมูลการวิเคราะห์
messaging.adaptors.http.flow.GatewayTimeout
504 Gateway Timeout
Gateway Timeout
ข้อผิดพลาดนี้จะเกิดขึ้นหากเซิร์ฟเวอร์แบ็กเอนด์ไม่ตอบกลับ
ไปยัง Message Processor ของ Apigee Edge ภายใน
ระยะหมดเวลา I/O ที่กำหนดค่าไว้ใน Message Processor
PLAYBOOK
messaging.adaptors.http.flow.LengthRequired
411 Length Required
'Content-Length' is missing
ข้อผิดพลาดนี้เกิดขึ้นหากแอปพลิเคชันไคลเอ็นต์ไม่ได้ส่งส่วนหัว Content-Length เป็นส่วนหนึ่งของคำขอ HTTP POST และ PUT
ที่ส่งไปยัง Apigee Edge
หมายเหตุ: คำขอที่ไม่สำเร็จเนื่องจากข้อผิดพลาดนี้จะบันทึกในเครื่องมือติดตามไม่ได้ เนื่องจาก Message Processor จะทำการตรวจสอบนี้ในระยะแรกๆ ก่อนที่จะประมวลผลคำขอและเรียกใช้นโยบายใดๆ ใน API Proxy
ส่วนที่ 3.3.2 ของ RFC: Content-Length
แก้ไข
แก้ไข
หากต้องการแก้ไขข้อผิดพลาดนี้ ให้ทำตามขั้นตอนต่อไปนี้
ตรวจสอบว่าแอปพลิเคชันไคลเอ็นต์ส่งส่วนหัว
Content-Length เป็นส่วนหนึ่งของคำขอ HTTP POST และ
PUT ที่ส่งไปยัง Apigee Edge เสมอ เช่น
curl -X POST https://HOSTALIAS /PATH -d '{"name": "abc"}' -H "Content-Length: 15"
แม้ว่าคุณจะส่งเพย์โหลดที่ว่างเปล่าพร้อมคำขอ POST และ
PUT แต่โปรดตรวจสอบว่าได้ส่งส่วนหัว
Content-Length: 0 แล้ว เช่น
curl -X POST https://HOSTALIAS /PATH -H "Content-Length: 0"
Close
messaging.adaptors.http.flow.NoActiveTargets
503 Service Unavailable
The Service is temporarily unavailable
ข้อผิดพลาดนี้จะเกิดขึ้นในสถานการณ์ใดสถานการณ์หนึ่งต่อไปนี้
หากคุณใช้
TargetServer ใน Apigee Edge
การแปลง DNS ที่ไม่ถูกต้องของโฮสต์เซิร์ฟเวอร์แบ็กเอนด์
โดยเซิร์ฟเวอร์การให้สิทธิ์ที่กำหนดเองส่งผลให้มีที่อยู่ IP ที่ไม่ถูกต้องซึ่งนำไปสู่
ข้อผิดพลาดในการเชื่อมต่อ
ข้อผิดพลาดการหมดเวลาการเชื่อมต่อเนื่องจาก
การจำกัดไฟร์วอลล์ในเซิร์ฟเวอร์แบ็กเอนด์ป้องกันไม่ให้
Apigee Edge เชื่อมต่อกับเซิร์ฟเวอร์แบ็กเอนด์
ปัญหาการเชื่อมต่อเครือข่ายระหว่าง Apigee Edge
กับเซิร์ฟเวอร์แบ็กเอนด์
โฮสต์ที่ระบุใน TargetServer ไม่ถูกต้องหรือ
มีอักขระที่ไม่ต้องการ (เช่น ช่องว่าง)
PLAYBOOK
วิดีโอ
ข้อผิดพลาดนี้อาจเกิดขึ้นได้เช่นกันหากการตรวจสอบประสิทธิภาพการทำงานที่กำหนดค่าไว้เพื่อตรวจสอบการตรวจสอบประสิทธิภาพการทำงานของเซิร์ฟเวอร์เป้าหมายล้มเหลว
PLAYBOOK
วิดีโอ
messaging.adaptors.http.flow.RequestTimeOut
408 Request Timeout
Request timed out
ข้อผิดพลาดนี้เกิดขึ้นหาก Message Processor ของ Apigee Edge ไม่ได้รับ
เพย์โหลดคำขอจากแอปพลิเคชันไคลเอ็นต์สำหรับ
ระยะหมดเวลา I/O ที่กำหนดค่าไว้ในคอมโพเนนต์ Message Processor
แก้ไข
แก้ไข
ตรวจสอบว่าแอปพลิเคชันไคลเอ็นต์ส่งเพย์โหลดคำขอภายใน
ระยะหมดเวลา I/O ที่กำหนดค่าไว้ในคอมโพเนนต์ Message Processor ของ Apigee Edge
Close
messaging.adaptors.http.flow.ServiceUnavailable
503 Service Unavailable
The Service is temporarily unavailable
ข้อผิดพลาดนี้เกิดขึ้นในสถานการณ์ใดสถานการณ์หนึ่งต่อไปนี้
การแปลง DNS ของโฮสต์เซิร์ฟเวอร์แบ็กเอนด์ไม่ถูกต้องโดยเซิร์ฟเวอร์การให้สิทธิ์ที่กำหนดเองส่งผลให้มีที่อยู่ IP ที่ไม่ถูกต้อง ซึ่งนำไปสู่ข้อผิดพลาดในการเชื่อมต่อ
ข้อผิดพลาดการหมดเวลาการเชื่อมต่อเนื่องจาก
การจำกัดไฟร์วอลล์ในเซิร์ฟเวอร์แบ็กเอนด์ป้องกันไม่ให้
Apigee Edge เชื่อมต่อกับเซิร์ฟเวอร์แบ็กเอนด์
ปัญหาการเชื่อมต่อเครือข่ายระหว่าง Apigee Edge กับ
เซิร์ฟเวอร์แบ็กเอนด์
โฮสต์เซิร์ฟเวอร์เป้าหมายที่ระบุในปลายทางเป้าหมายไม่ถูกต้อง
หรือมีอักขระที่ไม่ต้องการ (เช่น ช่องว่าง)
PLAYBOOK
DNS Lookup ไม่สำเร็จ
วิดีโอ
การเชื่อมต่อเครือข่าย
วิดีโอ
ข้อผิดพลาดนี้อาจเกิดขึ้นได้เช่นกันหากเซิร์ฟเวอร์แบ็กเอนด์ปิดการเชื่อมต่อก่อนเวลาอันควรในขณะที่ Message Processor ยังคงส่งเพย์โหลดคำขอไปยังเซิร์ฟเวอร์แบ็กเอนด์
PLAYBOOK
messaging.adaptors.http.flow.SslHandshakeFailed
503 Service Unavailable
SSL Handshake failed {error_message}
ข้อผิดพลาดนี้เกิดขึ้นระหว่างกระบวนการแฮนด์เชค SSL ระหว่าง Message Processor ของ Apigee Edge กับเซิร์ฟเวอร์แบ็กเอนด์ในกรณีต่อไปนี้
ที่เก็บที่เชื่อถือได้ของ Message Processor ของ Apigee Edge
มีชุดใบรับรองที่ไม่ตรงกับชุดใบรับรองที่สมบูรณ์ของเซิร์ฟเวอร์แบ็กเอนด์
หรือ
ไม่มีเชนใบรับรองที่สมบูรณ์ของเซิร์ฟเวอร์แบ็กเอนด์
กลุ่มใบรับรองที่เซิร์ฟเวอร์แบ็กเอนด์แสดง
มีชื่อโดเมนที่สมบูรณ์ในตัวเอง (FQDN) ซึ่งไม่ตรงกับ
ชื่อโฮสต์ที่ระบุในปลายทางเป้าหมาย
หรือ
มีชุดใบรับรองที่ไม่ถูกต้อง/ไม่สมบูรณ์
PLAYBOOK
วิดีโอ
messaging.adaptors.http.flow.UnexpectedEOFAtTarget
502 Bad Gateway
Unexpected EOF at target
ข้อผิดพลาดนี้เกิดขึ้นในสถานการณ์ใดสถานการณ์หนึ่งต่อไปนี้
TargetServer ไม่ได้กำหนดค่าอย่างถูกต้องเพื่อรองรับการเชื่อมต่อ TLS/SSL
ใน Apigee Edge
เซิร์ฟเวอร์แบ็กเอนด์อาจปิดการเชื่อมต่ออย่างกะทันหัน
ขณะที่ Apigee Edge กำลังรอการตอบกลับจากเซิร์ฟเวอร์แบ็กเอนด์
กำหนดค่าการหมดเวลา Keep-Alive ไม่ถูกต้องใน Apigee และ
เซิร์ฟเวอร์แบ็กเอนด์
PLAYBOOK
messaging.runtime.*
messaging.runtime.RouteFailed
500 Internal Server Error
Unable to route the message to a TargetEndpoint
ข้อผิดพลาดนี้จะเกิดขึ้นหาก Apigee Edge ไม่สามารถกำหนดเส้นทางคำขอไปยัง
TargetEndpoints ใดๆ เนื่องจากสาเหตุต่อไปนี้
ไม่มีเงื่อนไขกฎเส้นทาง (<RouteRule>) ที่
ตรงกับคำขอในพร็อกซี
และ
ไม่มีกฎเส้นทางเริ่มต้นที่กำหนดไว้ใน ProxyEndpoint
(เช่น <RouteRule> โดยไม่มีเงื่อนไข)
แก้ไข
แก้ไข
หากต้องการแก้ไขข้อผิดพลาดนี้ ให้ทำตามวิธีการต่อไปนี้
ตรวจสอบกฎเส้นทางที่กำหนดไว้ใน ProxyEndpoint และแก้ไขเพื่อให้แน่ใจว่า
มีเงื่อนไขกฎเส้นทางอย่างน้อย 1 รายการที่ตรงกับคำขอของคุณ
แนวทางปฏิบัติแนะนำคือการกำหนดกฎการกำหนดเส้นทางเริ่มต้น ที่ไม่มีเงื่อนไข
เมื่อมี RouteRule หลายรายการ
ตรวจสอบว่ากฎเส้นทางเริ่มต้นจะกำหนดเป็นกฎสุดท้ายในรายการเส้นทางแบบมีเงื่อนไขเสมอ เนื่องจากระบบจะประเมินกฎจากบนลงล่างใน ProxyEndpoint
ดูข้อมูลเพิ่มเติมเกี่ยวกับการกำหนด<RouteRule>เงื่อนไขใน
ProxyEndpoint ได้ที่
เป้าหมายแบบมีเงื่อนไข
Close
messaging.runtime.SenseRaiseFault
403 Forbidden
Sense Fault
ข้อผิดพลาดนี้จะเกิดขึ้นหากมีการส่งคำขอ API จากที่อยู่ IP ของไคลเอ็นต์ที่เฉพาะเจาะจง
ซึ่งถูกบล็อกเป็นส่วนหนึ่งของกฎ Apigee Sense
แก้ไข
แก้ไข
หากต้องการแก้ไขข้อผิดพลาดนี้ ให้ทำตามวิธีการต่อไปนี้
ตรวจสอบว่าคุณได้บล็อกที่อยู่ IP ของไคลเอ็นต์ที่เฉพาะเจาะจงโดย
ตรวจสอบกฎที่กำหนดค่าใน Apigee Sense หากถูกบล็อก
แสดงว่าระบบทำงานตามที่ออกแบบไว้
หากไม่ได้บล็อกที่อยู่ IP ของไคลเอ็นต์ที่เฉพาะเจาะจง แต่คุณยังคง
ได้รับข้อผิดพลาดนี้ โปรดติดต่อทีมสนับสนุนของ Apigee Edge
Close
protocol.http.* - Caused due to bad request
500 Internal Server Error
Bad Form Data
ข้อผิดพลาดนี้จะเกิดขึ้นก็ต่อเมื่อเป็นไปตามเงื่อนไขต่อไปนี้ทั้งหมด
คำขอ HTTP ที่ไคลเอ็นต์ส่งไปยัง Apigee Edge
มีข้อมูลต่อไปนี้
Content-Type: application/x-www-form-urlencoded
และ
ข้อมูลแบบฟอร์มที่มีเครื่องหมายเปอร์เซ็นต์ (%) หรือเครื่องหมายเปอร์เซ็นต์ (%) ตามด้วยอักขระฐานสิบหกที่ไม่ถูกต้องซึ่งไม่อนุญาต
ตามที่ระบุไว้ใน
แบบฟอร์ม - ส่วนที่ 17.13.4.1
พร็อกซี API ใน Apigee Edge จะอ่านพารามิเตอร์แบบฟอร์มที่เฉพาะเจาะจง
ซึ่งมีอักขระใดๆ ที่ไม่อนุญาตโดยใช้
นโยบาย ExtractVariables หรือ AssignMessage ในโฟลว์คำขอ
PLAYBOOK
400 Bad Request
Duplicate Header "{header_name}"
ข้อผิดพลาดนี้เกิดขึ้นหากส่วนหัว HTTP ที่เฉพาะเจาะจงซึ่งไม่อนุญาตให้มีรายการที่ซ้ำกัน
ใน Apigee Edge ปรากฏมากกว่า 1 ครั้งโดยมีค่าเดียวกันหรือค่าที่แตกต่างกันเป็นส่วนหนึ่งของ
คำขอ HTTP ที่แอปพลิเคชันไคลเอ็นต์ส่งไปยัง Apigee Edge
RFC 7230, ส่วนที่ 3.2.2: ลำดับฟิลด์
PLAYBOOK
400 Bad Request
Header name cannot be empty
ข้อผิดพลาดนี้จะเกิดขึ้นหากชื่อส่วนหัวที่ส่งเป็นส่วนหนึ่งของคำขอ HTTP
โดยแอปพลิเคชันไคลเอ็นต์ไปยัง Apigee Edge ว่างเปล่า
RFC 7230, section 3.2: Header Fields
แก้ไข
แก้ไข
แก้ไข
protocol.http.InvalidPath
แก้ไข
แก้ไข
ตรวจสอบว่าเส้นทางใน URL ของคำขอ HTTP ที่แอปพลิเคชันไคลเอ็นต์ส่งไปยัง Apigee Edge ไม่มีอักขระใดๆ ที่ไม่ได้รับอนุญาตตาม
RFC 3986 ส่วนที่ 3.3: เส้นทาง
Close
protocol.http.MessageReadError
502 Bad Gateway
Unexpected I/O after message headers have been read.
ข้อผิดพลาดที่พบได้ยากนี้เกิดขึ้นเมื่อ MP
ได้รับ I/O ในแชแนลเมื่อไม่คาดคิด MP กำลังอ่านคำขอ อ่านส่วนหัวทั้งหมดแล้ว และตั้งค่า
เพื่ออ่านเพย์โหลดของคำขอ จากนั้นก็พบเหตุการณ์ I/O
ซึ่งดูเหมือนว่าจะเป็นส่วนหัวเดียวกัน
แก้ไข
แก้ไข
ค้นหาข้อความในบันทึกเพื่อดูข้อมูลเพิ่มเติมเกี่ยวกับสิ่งที่เกิดขึ้น
logger.atSevere().log(
"Unexpected I/O after message headers have been read. Channel diagnostics=%s."
+ " HeartBeat=%s",
input.client().getDiagnostic(), message.getHeaders().isHeartBeat());
Close
protocol.http.TooBigBody
413 Request Entity Too Large
Body buffer overflow
ข้อผิดพลาดนี้เกิดขึ้นหากขนาดเพย์โหลดที่แอปพลิเคชันไคลเอ็นต์ส่งเป็นส่วนหนึ่งของ
คำขอ HTTP ไปยัง Apigee Edge มีขนาดใหญ่กว่าขีดจำกัดที่อนุญาตใน Apigee Edge
ขีดจำกัดของ Apigee Edge
PLAYBOOK
PLAYBOOK
protocol.http.TooBigLine
414 Request-URI Too Long
request line size exceeding {limit}
ข้อผิดพลาดนี้เกิดขึ้นหากขนาดของบรรทัดคำขอที่แอปพลิเคชันไคลเอ็นต์ส่ง
เป็นส่วนหนึ่งของคำขอ HTTP ไปยัง Apigee Edge มีค่ามากกว่าขีดจำกัดที่อนุญาตใน
Apigee Edge
ขีดจำกัดของ Apigee Edge
PLAYBOOK
protocol.http.UnsupportedEncoding
PLAYBOOK
protocol.http.* - Caused by target
protocol.http.BadPath
PLAYBOOK
502 Bad Gateway
Duplicate Header "{header_name}"
ข้อผิดพลาดนี้เกิดขึ้นหากส่วนหัว HTTP ที่เฉพาะเจาะจงซึ่งไม่อนุญาตให้มีรายการที่ซ้ำกัน
ใน Apigee Edge ปรากฏมากกว่า 1 ครั้งโดยมีค่าเดียวกันหรือค่าที่แตกต่างกันเป็นส่วนหนึ่งของ
การตอบกลับ HTTP ที่เซิร์ฟเวอร์แบ็กเอนด์ส่งไปยัง Apigee Edge
RFC 7230, ส่วนที่ 3.2.2: ลำดับฟิลด์
PLAYBOOK
502 Bad Gateway
Header name cannot be empty
ข้อผิดพลาดนี้จะเกิดขึ้นหากชื่อส่วนหัวที่เซิร์ฟเวอร์แบ็กเอนด์ส่งเป็นส่วนหนึ่งของคำตอบ HTTP
ไปยัง Apigee Edge ว่างเปล่า
RFC 7230, section 3.2: Header Fields
แก้ไข
protocol.http.EmptyPath
PLAYBOOK
แก้ไข
แก้ไข
protocol.http.ProxyTunnelCreationFailed
503 Service Unavailable
Proxy refused to create tunnel with response status {status code}
ข้อผิดพลาดนี้เกิดขึ้นระหว่างการสร้างอุโมงค์ระหว่าง Apigee Edge กับ
เซิร์ฟเวอร์แบ็กเอนด์โดยเซิร์ฟเวอร์พร็อกซีเนื่องจากไฟร์วอลล์, ACL (รายการควบคุมการเข้าถึง), DNS
ปัญหา, ความพร้อมใช้งานของเซิร์ฟเวอร์แบ็กเอนด์ ฯลฯ
หมายเหตุ: รหัสสถานะ ในข้อความแสดงข้อผิดพลาด
(faultstring) จะระบุสาเหตุระดับสูงของปัญหา
PLAYBOOK
protocol.http.Response306Reserved
502 Bad Gateway
Response Status code 306 is reserved, so can't be used.
ข้อผิดพลาดนี้เกิดขึ้นหากเซิร์ฟเวอร์แบ็กเอนด์ตอบกลับด้วยรหัสสถานะ 306 ไปยัง Apigee Edge
รหัสสถานะ 306 ได้รับการกำหนดไว้ในข้อกำหนด HTTP เวอร์ชันก่อนหน้า
ตามข้อกำหนด HTTP ปัจจุบัน รหัสนี้เป็นรหัสที่สงวนไว้และไม่ควรใช้
RFC 7231, section 6.3.5: 306 Reserved
แก้ไข
แก้ไข
เนื่องจากมีการสงวนรหัสสถานะ 306 ไว้ โปรดตรวจสอบว่าเซิร์ฟเวอร์แบ็กเอนด์ของคุณไม่ได้ใช้รหัสสถานะนี้ขณะส่งการตอบกลับไปยัง Apigee Edge
Close
PLAYBOOK
protocol.http.ResponseWithBody
PLAYBOOK
protocol.http.TooBigBody
502 Bad Gateway
Body buffer overflow
ข้อผิดพลาดนี้เกิดขึ้นหากขนาดเพย์โหลดที่แอปพลิเคชันไคลเอ็นต์ส่งเป็นส่วนหนึ่งของ
คำขอ HTTP ไปยัง Apigee Edge มีขนาดใหญ่กว่าขีดจำกัดที่อนุญาตใน Apigee Edge
ขีดจำกัดของ Apigee Edge
PLAYBOOK
502 Bad Gateway
response headers size exceeding {limit}
ข้อผิดพลาดนี้จะเกิดขึ้นหากขนาดรวมของส่วนหัวการตอบกลับทั้งหมดที่เซิร์ฟเวอร์แบ็กเอนด์ส่งเป็นส่วนหนึ่งของการตอบกลับ HTTP ไปยัง Apigee Edge มากกว่าขีดจำกัดที่อนุญาตใน Apigee Edge
ขีดจำกัดของ Apigee Edge
PLAYBOOK
protocol.http.TooBigLine
502 Bad Gateway
response line size exceeding {limit}
ข้อผิดพลาดนี้เกิดขึ้นหากขนาดของบรรทัดการตอบกลับที่เซิร์ฟเวอร์แบ็กเอนด์ส่งเป็น
ส่วนหนึ่งของการตอบกลับ HTTP ไปยัง Apigee Edge มีขนาดใหญ่กว่าขีดจำกัดที่อนุญาตใน Apigee
Edge
ขีดจำกัดของ Apigee Edge
PLAYBOOK
protocol.http.UnsupportedEncoding
PLAYBOOK
security.util.*
security.util.KeyAliasNotFound
500 Internal Server Error
KeyAlias {KeyAlias_name} is not found in
Keystore {Keystore_Name}
ข้อผิดพลาดนี้เกิดขึ้นหากไม่พบ KeyAlias ที่เฉพาะเจาะจงซึ่งอ้างอิงใน TargetEndpoint
หรือ TargetServer ใน Keystore ที่เฉพาะเจาะจง
แก้ไข
แก้ไข
ตรวจสอบว่า KeyAlias ที่ระบุใน TargetEndpoint หรือ TargetServer
มีอยู่และเป็นส่วนหนึ่งของ Keystore ที่เฉพาะเจาะจง
Close
security.util.TrustStoreWithNoCertificates
500 Internal Server Error
TrustStore {truststore_name} has no certificates
ข้อผิดพลาดนี้เกิดขึ้นหาก Truststore ที่เฉพาะเจาะจงซึ่งอ้างอิงใน TargetEndpoint หรือ
TargetServer ไม่มีใบรับรอง
แก้ไข
แก้ไข
หากต้องการตรวจสอบใบรับรองของเซิร์ฟเวอร์แบ็กเอนด์และ
ต้องการใช้ Truststore ใน TargetEndpoint หรือ TargetServer ให้
ตรวจสอบว่า Truststore มีใบรับรองที่ถูกต้องของเซิร์ฟเวอร์แบ็กเอนด์
Close