400 Yêu cầu Không hợp lệ - Giải nén

Bạn đang xem tài liệu về Apigee Edge.
Truy cập vào tài liệu Apigee X.
thông tin

Dấu hiệu

Ứng dụng khách nhận được mã trạng thái HTTP 400 Bad Request với mã lỗi messaging.adaptors.http.flow.DecompressionFailureAtRequest để phản hồi các lệnh gọi API.

Thông báo lỗi

Ứng dụng khách nhận được mã phản hồi sau:

HTTP/1.1 400 Bad Request

Ngoài ra, bạn có thể thấy một thông báo lỗi tương tự như thông báo dưới đây:

{
   "fault":{
      "faultstring":"Decompression failure at request",
      "detail":{
         "errorcode":"messaging.adaptors.http.flow.DecompressionFailureAtRequest"
      }
   }
}

Các nguyên nhân có thể

Lỗi này chỉ xảy ra nếu:

  • Mã hoá được chỉ định trong tiêu đề yêu cầu HTTP Content-Encoding là hợp lệ và được Apigee Edge hỗ trợ,
  • NHƯNG

  • Định dạng tải trọng do ứng dụng gửi trong yêu cầu HTTP không khớp với định dạng mã hoá được chỉ định trong tiêu đề Content-Encoding

Điều này là do Apigee Edge không giải mã được tải trọng bằng cách sử dụng phương thức mã hoá đã chỉ định vì định dạng của tải trọng không giống với định dạng của phương thức mã hoá được chỉ định trong tiêu đề Content-Encoding.

Sau đây là một số ví dụ về các giá trị Content-Encoding được hỗ trợ và cách Apigee Edge mong đợi định dạng tải trọng trong những trường hợp đó:

Trường hợp Mã hoá nội dung Định dạng tải trọng dự kiến
Mã hoá đơn gzip

Định dạng gzip của Unix.

Xem Định dạng GZIP RFC1952.

Mã hoá đơn deflate

Định dạng này sử dụng cấu trúc zlib với thuật toán nén deflate.

Xem RFC1950 và RFC1951.

Nhiều phương thức mã hoá

Nhiều phương thức mã hoá

Ví dụ: trong trường hợp mã hoá được thực hiện hai lần, mã này có thể là:

  • gzip, deflate
  • gzip, gzip
  • deflate, gzip
  • deflate, deflate
Nhiều phương thức mã hoá được áp dụng cho tải trọng theo thứ tự đã cho khi tải trọng xuất hiện trong tiêu đề.

Sau đây là những nguyên nhân có thể gây ra lỗi này:

Nguyên nhân Mô tả Hướng dẫn khắc phục sự cố áp dụng cho
Định dạng tải trọng yêu cầu không khớp với phương thức mã hoá được chỉ định trong tiêu đề Content-Encoding Định dạng của tải trọng yêu cầu do ứng dụng gửi không được mã hoá hoặc không khớp với phương thức mã hoá được chỉ định trong tiêu đề Content-Encoding. Người dùng Edge Public Cloud và Private Cloud

Các bước chẩn đoán thường gặp

Hãy sử dụng một trong các công cụ/kỹ thuật sau để chẩn đoán lỗi này:

Giám sát API

Cách chẩn đoán lỗi bằng tính năng Giám sát API:

  1. Đăng nhập vào giao diện người dùng Apigee Edge với tư cách là người dùng có vai trò phù hợp.
  2. Chuyển sang tổ chức mà bạn muốn điều tra vấn đề.

  3. Chuyển đến trang Phân tích > Giám sát API > Điều tra.
  4. Chọn khung thời gian cụ thể mà bạn nhận thấy lỗi.
  5. Đảm bảo rằng bộ lọc Proxy được đặt thành Tất cả.
  6. Vẽ Mã lỗi theo Thời gian.
  7. Chọn một ô có mã lỗi messaging.adaptors.http.flow.DecompressionFailureAtRequest như minh hoạ bên dưới:

    ( xem hình ảnh lớn hơn)

  8. Thông tin về mã lỗi messaging.adaptors.http.flow.DecompressionFailureAtRequest sẽ xuất hiện như minh hoạ dưới đây:

    ( xem hình ảnh lớn hơn)

  9. Nhấp vào Xem nhật ký rồi mở rộng hàng không thành công có lỗi 400.

    ( xem hình ảnh lớn hơn)

  10. Trong cửa sổ Nhật ký, hãy lưu ý những thông tin sau:
    • Mã trạng thái: 400
    • Nguồn lỗi: proxy
    • Mã lỗi: messaging.adaptors.http.flow.DecompressionFailureAtRequest.
  11. Nếu Nguồn lỗi có giá trị proxy, thì điều đó cho biết rằng định dạng tải trọng của yêu cầu không khớp với mã hoá được hỗ trợ được chỉ định trong tiêu đề Content-Encoding.

Công cụ theo dõi

Cách chẩn đoán lỗi bằng công cụ Trace (Theo dõi):

  1. Bật phiên theo dõi và một trong hai lựa chọn sau:
    1. Chờ lỗi 400 Bad Request xảy ra, hoặc
    2. Nếu bạn có thể tái hiện vấn đề, hãy thực hiện lệnh gọi API và tái hiện 400 Bad Request.
  2. Đảm bảo bạn đã bật chế độ Show all FlowInfos (Hiện tất cả FlowInfo):

  3. Chọn một trong các yêu cầu không thực hiện được và kiểm tra dấu vết.
  4. Điều hướng qua các giai đoạn khác nhau của dấu vết và xác định vị trí xảy ra lỗi.
  5. Thông thường, bạn sẽ thấy lỗi trong một luồng ngay sau giai đoạn Đã nhận được yêu cầu từ khách hàng như minh hoạ dưới đây:

    ( xem hình ảnh lớn hơn)

  6. Lưu ý các giá trị của thuộc tính trong dấu vết:

    • error: Decompression failure at request
    • error.class: com.apigee.rest.framework.BadRequestException
    • error.cause: Not in GZIP format

    error.cause cho biết tải trọng yêu cầu KHÔNG ở định dạng GZIP. Điều này có nghĩa là Apigee Edge đang chờ tải trọng yêu cầu ở định dạng GZIP vì tải trọng này sẽ được chỉ định trong tiêu đề Content-Encoding.

  7. Xác định giá trị của tiêu đề của yêu cầu Content-Encoding. Để thực hiện việc này, hãy chuyển đến giai đoạn Request Received from Client (Đã nhận được yêu cầu từ ứng dụng khách) như minh hoạ dưới đây:

    ( xem hình ảnh lớn hơn)

    Lưu ý rằng giá trị của tiêu đề yêu cầu Content-Encoding thực sự là gzip.

    Dấu vết mẫu ở trên cho thấy rằng quá trình mã hoá được chỉ định trong tiêu đề của yêu cầu Content-Encoding là gzip; tuy nhiên, tải trọng yêu cầu không ở định dạng GZIP. Do đó, Apigee không thể giải nén tải trọng bằng gzip và trả về lỗi Decompression failure at request.

  8. Ghi lại mã trạng thái và thông báo lỗi do Apigee Edge trả về bằng cách chuyển đến

    đến giai đoạn Response Sent to Client (Phản hồi được gửi đến ứng dụng) trong dấu vết như minh hoạ dưới đây:

    ( xem hình ảnh lớn hơn)

    Lưu ý những thông tin sau trong dấu vết:

    • Mã trạng thái: 400 Bad Request.
    • Nội dung lỗi: {"fault":{"faultstring":"Decompression failure at request","detail":{"errorcode":"messaging.adaptors.http.flow.DecompressionFailureAtRequest"}}}
  9. Chuyển đến giai đoạn AX (Dữ liệu Analytics được ghi lại) trong dấu vết và nhấp vào giai đoạn đó.

  10. Di chuyển xuống phần Phase Details (Thông tin chi tiết về giai đoạn), Error Headers (Tiêu đề lỗi) và xác định các giá trị của X-Apigee-fault-code và X-Apigee-fault-source như minh hoạ bên dưới:

    ( xem hình ảnh lớn hơn)

  11. Bạn sẽ thấy các giá trị của X-Apigee-fault-code và X-Apigee-fault-source là messaging.adaptors.http.flow.DecompressionFailureAtRequest và policy, cho biết rằng định dạng tải trọng yêu cầu không khớp với phương thức mã hoá được chỉ định trong tiêu đề Content-Encoding.
    Tiêu đề phản hồi Giá trị
    X-Apigee-fault-code messaging.adaptors.http.flow.DecompressionFailureAtRequest
    X-Apigee-fault-source policy

NGINX

Cách chẩn đoán lỗi bằng nhật ký truy cập NGINX:

  1. Nếu là người dùng Đám mây riêng, bạn có thể sử dụng nhật ký truy cập NGINX để xác định thông tin chính về lỗi HTTP 400.
  2. Kiểm tra nhật ký truy cập NGINX:

    /opt/apigee/var/log/edge-router/nginx/ORG~ENV.PORT#_access_log

    Vị trí: ORG, ENV và PORT# được thay thế bằng các giá trị thực tế.

  3. Tìm kiếm để xem có lỗi 400 nào xảy ra trong một khoảng thời gian cụ thể hay không (nếu vấn đề xảy ra trong quá khứ) hoặc xem có yêu cầu nào vẫn không thành công với 400 hay không.
  4. Nếu bạn tìm thấy bất kỳ lỗi 400 nào có X-Apigee-fault-code khớp với giá trị của messaging.adaptors.http.flow.DecompressionFailureAtRequest, thì hãy xác định giá trị của X-Apigee-fault-source.

    Ví dụ về lỗi 400 trong nhật ký truy cập NGINX:

    Mục nhập mẫu ở trên trong nhật ký truy cập NGINX có các giá trị sau cho X-Apigee-fault-code và X-Apigee-fault-source:

    Tiêu đề phản hồi Giá trị
    X-Apigee-fault-code messaging.adaptors.http.flow.DecompressionFailureAtRequest
    X-Apigee-fault-source policy

Nguyên nhân: Định dạng tải trọng yêu cầu không khớp với phương thức mã hoá được chỉ định trong tiêu đề Content-Encoding

Theo mặc định, Apigee Edge luôn giải nén tải trọng nếu tiêu đề của yêu cầu Content-Encoding chứa một mã hoá hợp lệ và được hỗ trợ. Do đó, định dạng của tải trọng yêu cầu phải khớp với phương thức mã hoá được chỉ định trong tiêu đề của yêu cầu Content-Encoding. Nếu có sự không khớp, bạn sẽ gặp lỗi này.

Chẩn đoán

  1. Xác định Mã lỗi và Nguồn lỗi cho lỗi quan sát được bằng cách sử dụng API Monitoring, Trace tool hoặc nhật ký truy cập NGINX như được giải thích trong Các bước chẩn đoán thường gặp.
  2. Nếu Mã lỗi là messaging.adaptors.http.flow.DecompressionFailureAtRequest và Nguồn lỗi có giá trị policy hoặc proxy, thì điều này cho biết rằng yêu cầu do ứng dụng gửi có tải trọng không khớp với mã hoá được hỗ trợ được chỉ định trong tiêu đề của yêu cầu Content-Encoding.
  3. Bạn có thể xác định sự không khớp trong yêu cầu HTTP bằng một trong các phương thức sau:

    Thông báo lỗi

    Cách xác thực bằng thông báo lỗi:

    1. Nếu bạn có quyền truy cập vào thông báo lỗi hoàn chỉnh nhận được từ Apigee Edge, hãy tham khảo faultstring.

      Thông báo lỗi mẫu:

      "faultstring":"Decompression failure at request"
    2. Trong thông báo lỗi ở trên, thông báo này hiển thị "Decompression failure at request", tức là request không thể giải nén bằng phương thức mã hoá được chỉ định trong tiêu đề Content-Encoding.

    Trace

    Cách xác thực bằng Trace:

    1. Xác định giá trị của tiêu đề của yêu cầu Content-Encoding và thuộc tính error.cause bằng cách sử dụng Trace như được giải thích trong phần Các bước chẩn đoán thường gặp.
    2. Các giá trị trong dấu vết mẫu như sau:

      • Content-Encoding: gzip
      • error.cause: Not in GZIP format

      Giá trị trong tiêu đề của yêu cầu Content-Encoding là gzip; tuy nhiên, tải trọng yêu cầu không ở định dạng GZIP (như được chỉ ra bởi error.cause). Do đó, Apigee Edge sẽ phản hồi bằng 400 Bad Request và mã lỗi messaging.adaptors.http.flow.DecompressionFailureAtRequest.

    Yêu cầu thực tế

    Cách xác thực bằng yêu cầu thực tế:

    Nếu bạn có quyền truy cập vào yêu cầu thực tế do ứng dụng khách đưa ra, hãy thực hiện các bước sau:

    1. Xác định giá trị được truyền đến tiêu đề của yêu cầu Content-Encoding.
    2. Xác định định dạng của tải trọng được gửi trong yêu cầu.
    3. Nếu giá trị của tiêu đề Content-Encoding nằm trong danh sách mã hoá được hỗ trợ nhưng định dạng của tải trọng yêu cầu không khớp với mã hoá được chỉ định trong tiêu đề Content-Encoding, thì đó là nguyên nhân gây ra vấn đề.

      Yêu cầu mẫu:

      curl -v "http://HOSTALIAS/v1/testgzip" -H "Content-Encoding: gzip" -X POST -d @request_payload.zip
      

      Yêu cầu mẫu ở trên sẽ gửi giá trị gzip đến tiêu đề Content-Encoding. Đây là mã hoá được hỗ trợ trong Apigee Edge. Tuy nhiên, tải trọng yêu cầu request_payload.zip ở định dạng ZIP. Do đó, yêu cầu này không thành công với mã trạng thái 400 Bad Request và mã lỗi: messaging.adaptors.http.flow.DecompressionFailureAtRequest.

    Nhật ký Trình xử lý tin nhắn

    Cách xác thực bằng nhật ký Message Processor:

    Nếu là người dùng Đám mây riêng, bạn có thể sử dụng nhật ký Trình xử lý thông báo để xác định thông tin chính về lỗi HTTP 400.

    1. Xác định mã nhận dạng thông báo của yêu cầu không thành công bằng cách sử dụng tính năng Giám sát API, công cụ Theo dõi hoặc nhật ký truy cập NGINX như được giải thích trong phần Các bước chẩn đoán thường gặp.
    2. Tìm mã nhận dạng thư trong nhật ký của Trình xử lý thư:

      /opt/apigee/var/log/edge-message-processor/logs/system.log

    3. Bạn sẽ thấy một trong các trường hợp ngoại lệ sau:

      Tình huống 1

      Tình huống 1: Khi yêu cầu API có tiêu đề Content-Encoding: gzip

      2021-07-28 10:21:16,861  NIOThread@0 ERROR HTTP.SERVER -
      HTTPServer$Context.onInputException() : Message id:rt-57-1
      SSLClientChannel[Accepted: Remote:192.168.199.8:8443
      Local:192.168.80.234:44284]@28469 useCount=1 bytesRead=0
      bytesWritten=28764 age=2739893ms  lastIO=0ms
      isOpen=true.onExceptionRead exception: {}
      java.util.zip.ZipException: Not in GZIP format
      
      2021-07-28 10:21:16,862  NIOThread@0 ERROR ADAPTORS.HTTP.FLOW -
      AbstractRequestListener.onException() : Request:POST, uri:/test,
      message Id:rt-57-1, exception:java.util.zip.ZipException: Not in GZIP format,
      context:Context@71ea5ac input=ClientInputChannel(SSLClientChannel[Accepted:
      Remote:192.168.199.8:8443 Local:192.168.80.234:44284]@28469 useCount=1
      bytesRead=0 bytesWritten=28764 age=2739894ms  lastIO=0ms  isOpen=true)
      2021-07-28 10:21:16,862  NIOThread@0 INFO  HTTP.SERVICE -
      ExceptionHandler.handleException() :
      Exception java.util.zip.ZipException: Not in GZIP format occurred while writing
      to channel null
      2021-07-28 10:21:16,863  NIOThread@0 INFO  HTTP.SERVICE -
      ExceptionHandler.handleException() : Exception trace:
      java.util.zip.ZipException: Not in GZIP format
      

      Dòng java.util.zip.ZipException: Not in GZIP format trong thông báo lỗi ở trên cho biết tải trọng yêu cầu không được gửi ở định dạng GZIP mặc dù Content-Encoding được chỉ định là gzip. Do đó, Apigee Edge sẽ gửi ngoại lệ và trả về mã trạng thái 400 kèm theo mã lỗi messaging.adaptors.http.flow.DecompressionFailureAtRequest cho các ứng dụng khách.

      Tình huống 2

      Trường hợp 2: Khi yêu cầu API có tiêu đề Content-Encoding: deflate

      2021-07-28 15:26:31,893  NIOThread@1 ERROR HTTP.SERVER -
      HTTPServer$Context.onInputException() : Message id:rt-47875-1
      SSLClientChannel[Accepted: Remote:192.168.199.8:8443
      Local:192.168.81.72:45954]@29276 useCount=1 bytesRead=0
      bytesWritten=37230 age=3498856ms  lastIO=1ms
      isOpen=true.onExceptionRead exception: {}
      java.util.zip.ZipException: incorrect header check
                        ….
      Caused by: java.util.zip.DataFormatException: incorrect header check
             ..
      2021-07-28 15:26:31,894  NIOThread@1 ERROR ADAPTORS.HTTP.FLOW -
      AbstractRequestListener.onException() : Request:POST, uri:/test,
      message Id:rrt-47875-1, exception:java.util.zip.ZipException:
      incorrect header check, context:Context@69b3ac45
      input=ClientInputChannel(SSLClientChannel[Accepted:
      Remote:192.168.199.8:8443 Local:192.168.81.72:45954]@29276
      useCount=1 byt	esRead=0 bytesWritten=37230 age=3498856ms
      lastIO=1ms  isOpen=true)
      

      Các dòng java.util.zip.ZipException: incorrect header check và Caused by: java.util.zip.DataFormatException: incorrect header check trong thông báo lỗi ở trên cho biết tải trọng yêu cầu không được gửi ở định dạng deflate và không khớp với phương thức mã hoá được chỉ định trong tiêu đề Content-Encoding của deflate. Do đó, Apigee Edge sẽ gửi ngoại lệ và trả về mã trạng thái 400 với mã lỗi messaging.adaptors.http.flow.DecompressionFailureAtRequest cho các ứng dụng khách.

Độ phân giải

  1. Nếu không cần tải trọng yêu cầu được nén trong quy trình proxy API trong Apigee Edge và trong máy chủ phụ trợ, thì đừng truyền tiêu đề Content-Encoding. Nếu cần nén tải trọng yêu cầu, hãy chuyển sang bước 2.
  2. Đảm bảo rằng ứng dụng luôn gửi những thông tin sau:
    • Bất kỳ phương thức mã hoá nào được hỗ trợ làm giá trị cho tiêu đề Content-Encoding trong yêu cầu
    • Tải trọng yêu cầu ở định dạng được hỗ trợ cho Apigee Edge khớp với định dạng mã hoá được chỉ định trong tiêu đề Content-Encoding
  3. Trong ví dụ được thảo luận ở trên, tải trọng yêu cầu ở định dạng ZIP nhưng tiêu đề của yêu cầu chỉ định Content-Encoding: gzip. Bạn có thể khắc phục vấn đề này bằng cách gửi tiêu đề yêu cầu dưới dạng Content-Encoding: gzip và tải trọng yêu cầu cũng ở định dạng gzip:
    curl -v "https://HOSTALIAS/v1/testgzip" -H "Content-Encoding: gzip" -X POST -d @request_payload.gz
    

Thông số kỹ thuật

Apigee Edge phản hồi bằng mã trạng thái 400 Bad Request với mã lỗi messaging.adaptors.http.flow.DecompressionFailureAtRequest theo các quy cách RFC sau:

Thông số kỹ thuật
RFC 7231, phần 6.5.1
RFC 7231, phần 3.1.2.2

Nếu bạn vẫn cần được Nhóm hỗ trợ Apigee trợ giúp, hãy xem phần Bạn phải thu thập thông tin chẩn đoán.

Phải thu thập thông tin chẩn đoán

Thu thập thông tin chẩn đoán sau đây, rồi liên hệ với Nhóm hỗ trợ Apigee Edge:

Nếu bạn là người dùng Đám mây công cộng, hãy cung cấp những thông tin sau:

  • Tên tổ chức
  • Tên môi trường
  • Tên API Proxy
  • Lệnh curl hoàn tất được dùng để tái tạo lỗi 400
  • Tệp theo dõi cho các yêu cầu API

Nếu bạn là người dùng Đám mây riêng, hãy cung cấp những thông tin sau:

  • Thông báo lỗi hoàn chỉnh được ghi nhận cho các yêu cầu không thành công
  • Tên môi trường
  • Gói API Proxy
  • Tệp theo dõi cho các yêu cầu API
  • Nhật ký truy cập NGINX /opt/apigee/var/log/edge-router/nginx/ORG~ENV.PORT#_access_log

    Trong đó: ORG, ENV và PORT# được thay thế bằng các giá trị thực tế.

  • Nhật ký hệ thống của Trình xử lý tin nhắn /opt/apigee/var/log/edge-message-processor/logs/system.log