15.01.30.00 - Apigee Developer Services Portal Release Notes

On Friday, January 30, 2015, we released version 15.01.30.00 of the cloud version of the Apigee Developer Services portal.

If you have questions, go to Apigee Customer Support.

Deprecation

As of April 15, 2015 Google will no longer support the OpenID 2.0 API, as described at the following link:

https://developers.google.com/+/api/auth-migration#timetable

All portals released before 14.07 used Google OpenID 2.0, which enabled users to log in to the portal or register as a portal user by using their Google credentials. For more, see Using federated credentials on the developer portal. Because of this deprecation, that functionality has been removed from the portal.

As a replacement, you can instead use the Drupal Google Auth module or use the information described in the article: Using OAuth 2.0 for Login.

Bug fixes

This on-premises release includes the following bug fixes:

Topic Issue ID Description
Editing existing app yields fatal exception DEVSOL-992 Editing an existing app when caches have not recently been cleared yields fatal exception.