Google is committed to advancing racial equity for Black communities. See how.

Supported software and supported versions

Following are supported software versions for Apigee Edge for Public Cloud, Apigee Edge for Private Cloud (on-premises), and Apigee hybrid.

Apigee Edge Cloud

The following are supported in Apigee Edge cloud.

Java (JDK)

  • Oracle JDK 7/8
  • OpenJDK 7/8

Java Callouts in API proxy flows are available only in Apigee Edge Enterprise accounts. See also the Edge pricing features page.

TLS

TLS version 1.2

Node.js (Trireme)

Trireme 0.8.9 (which supports Node.js 0.10.32 and Rhino JavaScript engine 1.7.7.1). See also Understanding Edge support for Node.js modules.

JavaScript

Rhino JavaScript engine 1.7.7.1

Edge for Private Cloud supported versions

Operating system support is only on Intel 64-bit processors.

Version Operating systems JDK TLS Other software
4.50.00
  • Red Hat Enterprise Linux (Intel 64-bit):
    7.5, 7.6, 7.7, 7.8
  • CentOS (Intel 64-bit):
    7.5, 7.6, 7.7, 7.8
  • Oracle Linux (Intel 64-bit):
    7.5, 7.6, 7.7, 7.8
  • Amazon Linux AMI
    (Amazon Linux AMI 2 is not supported)
  • Oracle JDK 8
  • OpenJDK 8 (excluding 1.8.0.242 and 1.8.0.251)
1.0, 1.1, 1.2
  • Cassandra 2.1.16
  • Zookeeper 3.4.14
  • QPID 1.35
  • Postgres 9.6.1
  • Play (UI) 2.4
  • OpenLDAP 2.4.44-20.el7
  • Node.js 0.10.32
  • Nginx 1.16.1
  • Trireme 0.8.9 (Node.js 0.10.32, Rhino JavaScript engine 1.7.7.1)
  • Tomcat 7.0.103
4.19.06
  • Red Hat Enterprise Linux (Intel 64-bit):
    6.10, 7.5, 7.6, 7.7, 7.8
  • CentOS (Intel 64-bit):
    6.10, 7.5, 7.6, 7.7, 7.8
  • Oracle Linux (Intel 64-bit):
    6.9, 7.5, 7.6, 7.7, 7.8
  • Amazon Linux AMI
    (Amazon Linux AMI 2 is not supported)
  • Oracle JDK 8
  • OpenJDK 8 (excluding 1.8.0.242 and 1.8.0.251)
1.0, 1.1, 1.2
  • Cassandra 2.1.16
  • Zookeeper 3.4.5
  • QPID 1.35
  • Postgres 9.6.1
  • Play (UI) 2.4
  • OpenLDAP 2.4.44-20.el7
  • Node.js 0.10.32
  • Nginx 1.16.1
  • Trireme 0.8.9 (Node.js 0.10.32, Rhino JavaScript engine 1.7.7.1)
  • Tomcat 7.0.103
4.19.01.xx
  • Red Hat Enterprise Linux (Intel 64-bit):
    6.9, 7.4, 7.5, 7.6, 7.7
  • CentOS (Intel 64-bit):
    6.9, 7.4, 7.5, 7.6, 7.7
  • Oracle Linux (Intel 64-bit):
    6.8, 7.4, 7.5, 7.6, 7.7
  • Amazon Linux AMI
    (Amazon Linux AMI 2 is not supported)
  • Oracle JDK 8
  • OpenJDK 8 (excluding 1.8.0.242 and 1.8.0.251)
1.0, 1.1, 1.2
  • Cassandra 2.1.16
  • Zookeeper 3.4.5
  • QPID 1.35
  • Postgres 9.6.1
  • Play (UI) 2.4
  • OpenLDAP 2.4.44-20.el7
  • Node.js 0.10.32
  • Nginx 1.16.1
  • Trireme 0.8.9 (Node.js 0.10.32, Rhino JavaScript engine 1.7.7.1)
  • Tomcat 7.0.103
4.18.05.xx and earlier  

No longer supported. You must upgrade to 4.19.01.xx or later for continued support. For more information, see Apigee Edge release process.

Apigee hybrid

You can install Apigee hybrid runtime on the following platforms:

Platform Version
Google Kubernetes Engine (GKE) Version 1.14.x and 1.15.x
Anthos (GKE on-prem) Version 1.2.x and 1.3.x
Azure Kubernetes Service (AKS) 1.14.x

Apigee mtLS

Apigee mTLS supports the following platforms for your Private Cloud cluster (the supported OS for mTLS depends on the version of Private Cloud):

Operating System Supported Private Cloud Version
v4.19.01 v4.19.06 v4.50.00
CentOS
RedHat Enterprise Linux (RHEL)
Oracle Linux
7.4, 7.5, 7.6, 7.7 7.5, 7.6, 7.7 7.5, 7.6, 7.7, 7.8

For more information, see Introduction to Apigee mTLS.

apigee-monit

apigee-monit supports the following platforms for your Private Cloud cluster. (The supported OS for apigee-monit depends on the version of Private Cloud.)

Operating System Private Cloud Version
v4.19.01 v4.19.06 v4.50.00
CentOS 6.9*, 7.4, 7.5, 7.6, 7.7 7.5, 7.6, 7.7 7.5, 7.6, 7.7, 7.8
RedHat Enterprise Linux (RHEL) 6.9*, 7.4, 7.5, 7.6, 7.7 7.5, 7.6, 7.7 7.5, 7.6, 7.7, 7.8
Oracle Linux 6.9*, 7.4, 7.5, 7.6, 7.7 7.5, 7.6, 7.7 7.5, 7.6, 7.7, 7.8
* While not technically supported, you can install and use apigee-monit on CentOS/RHEL/Oracle version 6.9 for Apigee Edge for Private Cloud version 4.19.01.

For more information, see Self-healing with apigee-monit.

Apigee Edge Microgateway

Apigee Edge Microgateway is supported on all standard platforms that are supported by Node.js including Docker containers.

Apigee supports Active LTS or Maintenance LTS releases on Windows, macOS, and Linux. See Node.js Releases for more information.

Apigee Developer Portal (Drupal)

Operating system support is that same as the OS supported by the underlying version of Apigee Edge.

Version Apigee Edge TLS Other software
4.50.00.xx 4.19.06 or later 1.0, 1.1, 1.2
  • Drupal 7 - latest stable minor version
  • PHP 7.0.32
  • Postgres 9.6
  • Nginx 1.12.1
4.19.06.xx 4.18.05 or later 1.0, 1.1, 1.2
  • Drupal 7 - latest stable minor version
  • PHP 7.0.32
  • Postgres 9.6
  • Nginx 1.12.1
4.19.01.xx 4.15.07 or later 1.0, 1.1, 1.2
  • Drupal 7 - latest stable minor version
  • PHP 7.0.32
  • Postgres 9.6
  • Nginx 1.12.1
4.18.05.xx and earlier  

No longer supported. You must upgrade to 4.19.01.xx or later for continued support. See Apigee Edge release process for more.

* Licensed copy of Red Hat Enterprise Linux (RHEL). Red Hat requires a license to download and install all required RPMs.

Browser support

The following sections summarize the browser support for Apigee Edge and integrated and Drupal-based portals.

Apigee Edge

On Windows and Mac, current major version and one-previous major version of:

  • Microsoft Edge (Windows only)
  • Google Chrome
  • Safari
  • Firefox

Integrated portals

Apigee integrated portals support the same browser versions as Apigee Edge.

Drupal-based developer portals

Drupal-based developer portals built using just Drupal core support the browsers listed in Browser requirements in the Drupal documentation. Brower support for Drupal-based developer portals using additional contributed modules may be more limited.