Software e versões compatíveis

Você está vendo a documentação do Apigee Edge.
Acesse a documentação da Apigee X.
informações

Veja a seguir as versões de software compatíveis com o Apigee Edge para nuvem pública e o Apigee Edge para nuvem privada (no local).

Apigee Edge para versões com suporte à nuvem pública

Os itens a seguir são suportados na nuvem do Apigee Edge.

Java (JDK)

  • Oracle JDK 7/8
  • OpenJDK 7/8.

As frases de destaque do Java nos fluxos de proxy de API estão disponíveis apenas nas contas do Apigee Edge Enterprise. Consulte também a página de recursos de preços da Apigee.

TLS

TLS versão 1.2

JavaScript

Mecanismo JavaScript do Rhino 1.7.12

Edge para software com suporte de nuvem privada

A tabela a seguir descreve o software compatível com o Edge para nuvem privada. O suporte ao sistema operacional está disponível apenas para processadores Intel de 64 bits.

Versão Sistemas operacionais JDK TLS Outros softwares
4.52.00
  • Red Hat Enterprise Linux (Intel de 64 bits):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, 8.7, 8.8
  • CentOS (Intel de 64 bits):
    7.5, 7.6, 7.7, 7.8
  • Oracle Linux (Intel 64 bits):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, 8.7, 8.8
  • Amazon Linux 2
  • Rocky Linux 8
  • Oracle JDK 8
  • OpenJDK 8
  • 1.0, 1.1, 1.2
  • TLS 1.3
  • Cassandra 2.1.22
  • Zookeeper 3.8.0
  • QPID 1,35
  • Postgres 14
  • OpenLDAP:
    • Para ChromeVox-8.X ou Oracle-8.X: OpenLDAP 2.4.44-20.el7
    • Para CentOS-7.X, php-7.X ou Oracle-7.X: a versão mais recente fornecida pelo SO
  • NGINX 1.20.1
  • Tomcat 9.0.82
4.51.00
  • Red Hat Enterprise Linux (Intel de 64 bits):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6
  • CentOS (Intel de 64 bits):
    7.5, 7.6, 7.7, 7.8
  • Oracle Linux (Intel de 64 bits):
    7.5, 7.6, 7.7, 7.8, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5 e 8.6
  • Amazon Linux 2
  • Oracle JDK 8
  • OpenJDK 8
  • 1.0, 1.1, 1.2
  • TLS 1.3
  • Cassandra 2.1.22
  • Zookeeper 3.4.14
  • QPID 1,35
  • Postgres 10.17
  • OpenLDAP:
    • Para ChromeVox-8.X ou Oracle-8.X: OpenLDAP 2.4.44-20.el7
    • Para CentOS-7.X, php-7.X ou Oracle-7.X: a versão mais recente fornecida pelo SO
  • NGINX 1.20.1
  • Tomcat 8.5.64
4.50.00 e anteriores

Não é mais compatível. Faça upgrade para a versão 4.51.00.xx ou posterior para receber suporte contínuo. Para mais informações, consulte o processo de lançamento do Apigee Edge.

Apigee Edge Microgateway

As versões do Node.js compatíveis incluem: 16, 18 e 20. A partir da versão 3.3.2, os comandos da CLI do Edge Microgateway só vão funcionar nas versões compatíveis. A execução de comandos da CLI em versões não compatíveis resultará em erro.

O Apigee Edge Microgateway é compatível com todas as plataformas padrão compatíveis com Node.js, incluindo contêineres do Docker.

A Apigee oferece suporte às versões Active LTS ou Manutenção LTS no Windows, macOS e Linux. Consulte Versões do Node.js para mais informações.

Portal do desenvolvedor da Apigee (Drupal)

O suporte ao sistema operacional é o mesmo que o SO compatível com a versão subjacente do Apigee Edge.

Versão Apigee Edge TLS Outros softwares
4.52.00 4.52.00 ou mais recente 1,0, 1,1, 1,2
  • Drupal 9: versão secundária estável mais recente
  • PHP 7.4 (Firebase 7/CentOS 7) ou PHP mais recente na distribuição (Amazon Linux)
  • Postgres 10.17
  • NGINX 1.12.1
4.51.00 4.51.00 ou mais recente 1,0, 1,1, 1,2
  • Drupal 7: versão secundária estável mais recente
  • PHP 7.4 (Firebase 7/CentOS 7) ou PHP mais recente na distribuição (Amazon Linux)
  • Postgres 10.17
  • NGINX 1.12.1
4.50.00 4.19.06 ou mais recente 1,0, 1,1, 1,2
  • Drupal 7: versão secundária estável mais recente
  • PHP 7.3 (Firebase 7/CentOS 7) ou PHP mais recente na distribuição (Amazon Linux)
  • Postgres 9.6
  • NGINX 1.12.1
4.19.06.xx e anteriores

Não é mais compatível. Faça upgrade para a versão 4.50.00.xx ou posterior para ter suporte contínuo. Consulte o processo de lançamento do Apigee Edge para mais informações.

* Cópia licenciada do Red Hat Enterprise Linux (Firebase). O Red Hat requer uma licença para fazer o download e a instalação de todas as RPMs necessárias.

Suporte ao navegador

As seções a seguir resumem o suporte a navegadores para o Apigee Edge e os portais integrados e baseados no Drupal.

Apigee Edge

No Windows e Mac, a versão principal atual e a versão principal anterior:

  • Microsoft Edge (somente para Windows)
  • Google Chrome
  • Safari
  • Firefox

Portais integrados

Os portais integrados da Apigee são compatíveis com as mesmas versões de navegador do Apigee Edge.

Portais de desenvolvedores baseados em Drupal

Os portais de desenvolvedores baseados no Drupal criados usando apenas o Drupal Core oferecem suporte aos navegadores listados em Requisitos do navegador na documentação do Drupal. O suporte a portais de desenvolvedores baseados em Drupal que usa outros módulos de contribuição pode ser mais limitado.