البرامج المتوافقة والإصدارات المتوافقة

يتم الآن عرض مستندات Apigee Edge.
انتقِل إلى مستندات Apigee X.
المعلومات

في ما يلي إصدارات البرامج المتوافقة مع Apigee Edge for Public Cloud وApigee Edge for Private Cloud (داخل الشركة).

Apigee Edge للإصدارات المتوافقة مع Public Cloud

ما يلي متاح في السحابة الإلكترونية Apigee Edge.

جافا (JDK)

  • Oracle JDK 7/8
  • OpenJDK 7/8

لا تتوفّر وسائل شرح Java في تدفقات الخادم الوكيل لواجهة برمجة التطبيقات إلا في حسابات Apigee Edge Enterprise. يُرجى الاطّلاع أيضًا على صفحة ميزات أسعار Apigee.

خاضعة لبروتوكول TLS

الإصدار 1.2 من بروتوكول أمان طبقة النقل (TLS)

JavaScript

الإصدار 1.7.12 من Rhino JavaScript Engine

برنامج Edge for Private Cloud

يصف الجدول التالي البرامج المتوافقة مع Edge for Private Cloud. لا تتوافق أنظمة التشغيل إلا مع معالِجات Intel 64 بت.

الإصدار أنظمة التشغيل JDK خاضعة لبروتوكول TLS برامج أخرى
4.52.00
  • Red Hat Enterprise Linux (Intel 64 بت):
    7.5، 7.6، 7.7، 7.8، 7.9، 8.0، 8.1، 8.2، 8.3، 8.4، 8.5، 8.6، 8.7، 8.8
  • CentOS (Intel 64-bit):
    7.5، 7.6، 7.7، 7.8
  • Oracle Linux (Intel 64 بت):
    7.5، 7.6، 7.7، 7.8، 7.9، 8.0، 8.1، 8.2، 8.3، 8.4، 8.5، 8.6، 8.7، 8.8
  • نظام التشغيل Amazon Linux 2
  • نظام التشغيل Rocky Linux 8
  • Oracle JDK 8
  • OpenJDK 8
  • 1.0، 1.1، 1.2
  • الإصدار 1.3 من بروتوكول أمان طبقة النقل (TLS)
  • الإصدار 2.1.22 من مكتبة كاساندرا
  • Zookeeper 3.8.0
  • 1.35 QPID
  • بوستجريس 14
  • بروتوكول OpenLDAP:
    • بالنسبة إلى RHEL-8.X أو Oracle-8.X: OpenLDAP 2.4.44-20.el7
    • بالنسبة إلى CentOS-7.X أو RHEL-7.X أو Oracle-7.X: أحدث إصدار يوفّره نظام التشغيل
  • الإصدار 1.20.1 من NGINX
  • Tomcat 9.0.82
4.51.00
  • Red Hat Enterprise Linux (Intel 64 بت):
    7.5، 7.6، 7.7، 7.8، 7.9، 8.0، 8.1، 8.2، 8.3، 8.4، 8.5، 8.6
  • CentOS (Intel 64-bit):
    7.5، 7.6، 7.7، 7.8
  • Oracle Linux (Intel 64 بت):
    7.5 و7.6 و7.7 و7.8 و8.0 و8.1 و8.2 و8.3 و8.4 و8.5 و8.6
  • نظام التشغيل Amazon Linux 2
  • Oracle JDK 8
  • OpenJDK 8
  • 1.0، 1.1، 1.2
  • الإصدار 1.3 من بروتوكول أمان طبقة النقل (TLS)
  • الإصدار 2.1.22 من مكتبة كاساندرا
  • Zookeeper 3.4.14
  • 1.35 QPID
  • Postgres 10.17
  • بروتوكول OpenLDAP:
    • بالنسبة إلى RHEL-8.X أو Oracle-8.X: OpenLDAP 2.4.44-20.el7
    • بالنسبة إلى CentOS-7.X أو RHEL-7.X أو Oracle-7.X: أحدث إصدار يوفّره نظام التشغيل
  • الإصدار 1.20.1 من NGINX
  • Tomcat 8.5.64
4.50.00 والإصدارات الأقدم

لم تعد متاحة. يجب الترقية إلى الإصدار 4.51.00.xx أو إصدار أحدث لمواصلة الدعم. لمزيد من المعلومات، يُرجى الاطّلاع على مقالة عملية إصدار Apigee Edge.

قناة Apigee Edge Microgateway

تتضمن إصدارات Node.js المعتمدة ما يلي: 16 و18 و20. بدءًا من الإصدار 3.3.2، ستعمل أوامر واجهة سطر الأوامر "Edge Microgateway" على الإصدارات المتوافقة فقط. وسيؤدي تنفيذ أوامر واجهة سطر الأوامر على الإصدارات غير المتوافقة إلى حدوث خطأ.

يتوافق Apigee Edge Microgateway على جميع المنصات العادية المتوافقة مع Node.js بما في ذلك حاويات Docker.

تتوافق Apigee مع إصدارات Active LTS أو Maintenance LTS على أنظمة التشغيل Windows وmacOS وLinux. يمكنك الاطّلاع على إصدارات Node.js للحصول على مزيد من المعلومات.

بوابة مطوّري Apigee (Drupal)

يتوافق نظام التشغيل مع نظام التشغيل نفسه المتوافق مع الإصدار الأساسي من Apigee Edge.

الإصدار Apigee Edge خاضعة لبروتوكول TLS برامج أخرى
4.52.00 4.52.00 أو إصدار أحدث 1.0، 1.1، 1.2
  • Drupal 9: أحدث إصدار ثانوي ثابت
  • PHP 7.4 (RHEL 7/CentOS 7) أو أحدث PHP في التوزيع (Amazon Linux)
  • Postgres 10.17
  • الإصدار 1.12.1 من نظام NGINX
4.51.00 4.51.00 أو إصدار أحدث 1.0، 1.1، 1.2
  • Drupal 7: أحدث إصدار ثانوي ثابت
  • PHP 7.4 (RHEL 7/CentOS 7) أو أحدث PHP في التوزيع (Amazon Linux)
  • Postgres 10.17
  • الإصدار 1.12.1 من نظام NGINX
4.50.00 4.19.06 أو إصدار أحدث 1.0، 1.1، 1.2
  • Drupal 7: أحدث إصدار ثانوي ثابت
  • PHP 7.3 (RHEL 7/CentOS 7) أو أحدث PHP في التوزيع (Amazon Linux)
  • Postgres 9.6
  • الإصدار 1.12.1 من نظام NGINX
4.19.06.xx أو الإصدارات الأقدم

لم تعد متاحة. يجب الترقية إلى الإصدار 4.50.00.xx أو إصدار أحدث لمواصلة الدعم. يُرجى الاطّلاع على عملية إصدار Apigee Edge لمعرفة المزيد.

* نسخة مرخّصة من Red Hat Enterprise Linux (RHEL). تتطلب شركة Red Hat ترخيصًا لتنزيل جميع العائدات لكل ألف ظهور المطلوبة وتثبيتها.

المتصفحات المتوافقة

تلخّص الأقسام التالية دعم المتصفِّح Apigee Edge والبوابات المدمجة والمستنِدة إلى Drupal.

Apigee Edge

على نظامَي التشغيل Windows وMac، الإصدار الرئيسي الحالي والإصدار الرئيسي السابق من:

  • Microsoft Edge (نظام التشغيل Windows فقط)
  • متصفح Google Chrome
  • برنامج المتصفح Safari
  • Firefox

البوابات المدمجة

تتوافق بوابات Apigee المتكاملة مع إصدارات المتصفّح نفسها مثل Apigee Edge.

بوابات المطوّرين المستندة إلى Drupal

تتوافق بوابات مطوّري البرامج المستندة إلى Drupal، التي تم إنشاؤها باستخدام نظام Drupal الأساسي فقط، مع المتصفّحات الواردة في متطلبات المتصفّح في مستندات Drupal. قد يكون دعم أداة Brotor لبوابات مطوّري البرامج المستندة إلى Drupal التي تستخدم الوحدات الإضافية التي تمت المساهمة بها محدودًا بشكل أكبر.