Unterstützte Software und unterstützte Versionen

Sie sehen die Dokumentation zu Apigee Edge.
Zur Apigee X-Dokumentation
weitere Informationen

Im Folgenden werden die unterstützten Softwareversionen für Apigee Edge for Public Cloud und Apigee Edge für Private Cloud (lokal) aufgeführt.

Von Apigee Edge für Public Cloud unterstützte Versionen

Folgendes wird in der Apigee Edge-Cloud unterstützt.

Java (JDK)

  • Oracle JDK 7/8
  • OpenJDK 7/8

Java-Callouts in API-Proxy-Abläufen sind nur in Apigee Edge Enterprise-Konten verfügbar. Weitere Informationen finden Sie auf der Seite mit den Apigee-Preisfunktionen.

TLS

TLS-Version 1.2

JavaScript

Rhino JavaScript-Engine 1.7.12

Von Edge für Private Cloud unterstützte Software

In der folgenden Tabelle wird die unterstützte Software für Edge für Private Cloud beschrieben. Die Betriebssystemunterstützung ist nur auf Intel 64-Bit-Prozessoren verfügbar.

Version Betriebssysteme JDK TLS Andere Software
4.52.00
  • Red Hat Enterprise Linux (Intel 64-Bit):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, 8.7, 8.8
  • CentOS (Intel 64-Bit):
    7.5, 7.6, 7.7, 7.8
  • Oracle Linux (Intel 64-Bit):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, 8.7, 8.8
  • Amazon Linux 2
  • Rocky Linux 8
  • Oracle JDK 8
  • OpenJDK 8
  • 1,0, 1,1, 1,2
  • TLS 1.3
  • Cassandra 2.1.22
  • Zookeeper 3.8.0
  • QPID 1.35
  • Postgres 14
  • OpenLDAP:
    • Für RHEL-8.X oder Oracle-8.X: OpenLDAP 2.4.44-20.el7
    • Für CentOS-7.X, RHEL-7.X oder Oracle-7.X: die neueste vom Betriebssystem bereitgestellte Version
  • NGINX 1.20.1
  • Tomcat 9.0.82
4.51.00
  • Red Hat Enterprise Linux (Intel 64-Bit):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6
  • CentOS (Intel 64-Bit):
    7.5, 7.6, 7.7, 7.8
  • Oracle Linux (Intel 64-Bit):
    7.5, 7.6, 7.7, 7.8, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5 und 8.6
  • Amazon Linux 2
  • Oracle JDK 8
  • OpenJDK 8
  • 1,0, 1,1, 1,2
  • TLS 1.3
  • Cassandra 2.1.22
  • Zookeeper 3.4.14
  • QPID 1.35
  • Postgres 10.17
  • OpenLDAP:
    • Für RHEL-8.X oder Oracle-8.X: OpenLDAP 2.4.44-20.el7
    • Für CentOS-7.X, RHEL-7.X oder Oracle-7.X: die neueste vom Betriebssystem bereitgestellte Version
  • NGINX 1.20.1
  • Tomcat 8.5.64
bis 4.50.00

Wird nicht mehr unterstützt. Sie müssen ein Upgrade auf 4.51.00.xx oder höher ausführen, um weiteren Support zu erhalten. Weitere Informationen finden Sie unter Apigee Edge-Release-Prozess.

Apigee Edge Microgateway

Zu den unterstützten Node.js-Versionen gehören 16, 18 und 20. Ab Version 3.3.2 funktionieren Edge Microgateway CLI-Befehle nur in den unterstützten Versionen. Das Ausführen von Befehlszeilenbefehlen für nicht unterstützte Versionen führt zu einem Fehler.

Apigee Edge Microgateway wird auf allen Standardplattformen unterstützt, die von Node.js unterstützt werden, einschließlich Docker-Containern.

Apigee unterstützt aktive LTS- oder Wartungs-LangTS-Releases unter Windows, macOS und Linux. Weitere Informationen finden Sie unter Node.js-Releases.

Apigee-Entwicklerportal (Drupal)

Die Betriebssystemunterstützung entspricht dem Betriebssystem, das von der zugrunde liegenden Version von Apigee Edge unterstützt wird.

Version Apigee Edge TLS Andere Software
4.52.00 4.52.00 oder höher 1,0, 1,1, 1,2
  • Drupal 9 – neueste stabile Nebenversion
  • PHP 7.4 (RHEL 7/CentOS 7) oder neueste PHP-Distribution (Amazon Linux)
  • Postgres 10.17
  • NGINX 1.12.1
4.51.00 4.51.00 oder höher 1,0, 1,1, 1,2
  • Drupal 7 – neueste stabile Nebenversion
  • PHP 7.4 (RHEL 7/CentOS 7) oder neueste PHP-Distribution (Amazon Linux)
  • Postgres 10.17
  • NGINX 1.12.1
4.50.00 4.19.06 oder höher 1,0, 1,1, 1,2
  • Drupal 7 – neueste stabile Nebenversion
  • PHP 7.3 (RHEL 7/CentOS 7) oder neueste PHP-Distribution (Amazon Linux)
  • Postgres 9.6
  • NGINX 1.12.1
4.19.06.xx und früher

Wird nicht mehr unterstützt. Sie müssen ein Upgrade auf 4.50.00.xx oder höher ausführen, um weiteren Support zu erhalten. Weitere Informationen finden Sie unter Apigee Edge-Release-Prozess.

* Lizenzierte Kopie von Red Hat Enterprise Linux (RHEL) Für Red Hat ist eine Lizenz zum Herunterladen und Installieren aller erforderlichen RPMs erforderlich.

Unterstützte Browser

In den folgenden Abschnitten wird die Browserunterstützung für Apigee Edge sowie integrierte und Drupal-basierte Portale zusammengefasst.

Apigee Edge

Unter Windows und Mac die aktuelle und die vorherige Hauptversion von:

  • Microsoft Edge (nur Windows)
  • Google Chrome
  • Safari
  • Firefox

Integrierte Portale

Integrierte Apigee-Portale unterstützen dieselben Browserversionen wie Apigee Edge.

Drupal-basierte Entwicklerportale

Drupal-basierte Entwicklerportale, die nur mit Drupal Core erstellt wurden, unterstützen die Browser, die in der Drupal-Dokumentation unter Browseranforderungen aufgeführt sind. Der Brower-Support für Drupal-basierte Entwicklerportale mit zusätzlichen bereitgestellten Modulen ist möglicherweise eingeschränkt.