Logiciels et versions compatibles

Vous consultez la documentation d'Apigee Edge.
Consultez la documentation Apigee X.
en savoir plus

Vous trouverez ci-dessous les versions logicielles compatibles d'Apigee Edge pour le cloud public et d'Apigee Edge pour le cloud privé (sur site).

Versions compatibles d'Apigee Edge pour le cloud public

Les éléments suivants sont pris en charge dans le cloud Apigee Edge.

Java (JDK)

  • JDK Oracle 7/8
  • OpenJDK 7/8

Les appels Java dans les flux de proxy d'API ne sont disponibles que dans les comptes Apigee Edge Enterprise. Consultez également la page Fonctionnalités tarifaires Apigee.

TLS

TLS version 1.2

JavaScript

Moteur JavaScript Rhino 1.7.12

Logiciels compatibles avec Edge for Private Cloud

Le tableau suivant décrit les logiciels compatibles avec Edge for Private Cloud. Le système d'exploitation n'est compatible qu'avec les processeurs Intel 64 bits.

Version Systèmes d'exploitation JDK TLS Autres logiciels
4.52.00
  • Red Hat Enterprise Linux (Intel 64 bits):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, 8.7, 8.8
  • CentOS (Intel 64 bits):
    7.5, 7.6, 7.7, 7.8
  • Oracle Linux (Intel 64 bits):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, 8.7, 8.8
  • Amazon Linux 2
  • Rocky Linux 8
  • Oracle JDK 8
  • OpenJDK 8
  • 1.0, 1.1, 1.2
  • TLS 1.3
  • Cassandra 2.1.22
  • Zookeeper 3.8.0
  • QPID 1.35
  • Postgres 14
  • OpenLDAP:
    • Pour RHEL-8.X ou Oracle-8.X: OpenLDAP 2.4.44-20.el7
    • Pour CentOS-7.X, RHEL-7.X ou Oracle-7.X: dernière version fournie par le système d'exploitation
  • NGINX 1.20.1
  • Tomcat 9.0.82
4.51.00
  • Red Hat Enterprise Linux (Intel 64 bits):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6
  • CentOS (Intel 64 bits):
    7.5, 7.6, 7.7, 7.8
  • Oracle Linux (Intel 64 bits):
    7.5, 7.6, 7.7, 7.8, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5 et 8.6
  • Amazon Linux 2
  • Oracle JDK 8
  • OpenJDK 8
  • 1.0, 1.1, 1.2
  • TLS 1.3
  • Cassandra 2.1.22
  • Zookeeper 3.4.14
  • QPID 1.35
  • Postgres 10.17
  • OpenLDAP:
    • Pour RHEL-8.X ou Oracle-8.X: OpenLDAP 2.4.44-20.el7
    • Pour CentOS-7.X, RHEL-7.X ou Oracle-7.X: dernière version fournie par le système d'exploitation
  • NGINX 1.20.1
  • Tomcat 8.5.64
4.50.00 et versions antérieures

N'est plus pris en charge. Vous devez passer à la version 4.51.00.xx ou ultérieure pour continuer à utiliser l'assistance. Pour plus d'informations, consultez le processus de publication d'Apigee Edge.

Apigee Edge Microgateway

Les versions Node.js compatibles incluent: 16, 18 et 20. À partir de la version 3.3.2, les commandes CLI Edge Microgateway ne fonctionneront que sur les versions compatibles. L'exécution de commandes de CLI sur des versions non compatibles entraînera une erreur.

Apigee Edge Microgateway est compatible avec toutes les plates-formes standards compatibles avec Node.js, y compris les conteneurs Docker.

Apigee est compatible avec les versions Active LTS et Maintenance LTS sur Windows, macOS et Linux. Pour plus d'informations, consultez les versions de Node.js.

Portail des développeurs Apigee (Drupal)

La compatibilité du système d'exploitation est identique à celle du système d'exploitation compatible avec la version sous-jacente d'Apigee Edge.

Version Apigee Edge TLS Autres logiciels
4.52.00 4.52.00 ou version ultérieure 1,0, 1,1, 1,2
  • Drupal 9 : dernière version mineure stable
  • PHP 7.4 (RHEL 7/CentOS 7) ou dernière version de PHP dans la distribution (Amazon Linux)
  • Postgres 10.17
  • NGINX 1.12.1
4.51.00 4.51.00 ou version ultérieure 1,0, 1,1, 1,2
  • Drupal 7 : dernière version mineure stable
  • PHP 7.4 (RHEL 7/CentOS 7) ou dernière version de PHP dans la distribution (Amazon Linux)
  • Postgres 10.17
  • NGINX 1.12.1
4.50.00 4.19.06 ou version ultérieure 1,0, 1,1, 1,2
  • Drupal 7 : dernière version mineure stable
  • PHP 7.3 (RHEL 7/CentOS 7) ou dernière version de PHP en distribution (Amazon Linux)
  • Postgres 9.6
  • NGINX 1.12.1
4.19.06.xx et versions antérieures

N'est plus pris en charge. Vous devez passer à la version 4.50.00.xx ou ultérieure pour continuer à bénéficier de l'assistance. Pour en savoir plus, consultez Processus de publication d'Apigee Edge.

* Copie sous licence de Red Hat Enterprise Linux (RHEL). Red Hat nécessite une licence pour télécharger et installer tous les RPM requis.

Prise en charge des navigateurs

Les sections suivantes récapitulent la compatibilité des navigateurs avec Apigee Edge et les portails intégrés et basés sur Drupal.

Apigee Edge

Sur Windows et Mac, version majeure actuelle et version majeure précédente des versions suivantes:

  • Microsoft Edge (Windows uniquement)
  • Google Chrome ;
  • Safari
  • Firefox

Portails intégrés

Les portails intégrés Apigee sont compatibles avec les mêmes versions de navigateur qu'Apigee Edge.

Portails de développeurs basés sur Drupal

Les portails pour développeurs basés sur Drupal et créés uniquement avec Drupal Core sont compatibles avec les navigateurs listés dans la section Configuration requise pour les navigateurs de la documentation Drupal. La compatibilité des navigateurs pour les portails de développeurs basés sur Drupal utilisant des modules contribués supplémentaires peut être plus limitée.