Desteklenen yazılımlar ve desteklenen sürümler

Apigee Edge belgelerini görüntülüyorsunuz.
Apigee X belgelerine gidin.
bilgi

Aşağıda, Genel Bulut için Apigee Edge ve Private Cloud için Apigee Edge'de (şirket içi) desteklenen yazılım sürümleri yer almaktadır.

Genel Bulut için Apigee Edge tarafından desteklenen sürümler

Apigee Edge bulutta aşağıdakiler desteklenir.

Java (JDK)

  • Oracle JDK 7/8
  • OpenJDK 7/8

API proxy akışlarındaki Java Çağrıları yalnızca Apigee Edge Enterprise hesaplarında kullanılabilir. Apigee fiyatlandırma özellikleri sayfasına da göz atın.

TLS

TLS 1.2 sürümü

JavaScript

Rhino JavaScript motoru 1.7.12

Edge for Private Cloud tarafından desteklenen yazılım

Aşağıdaki tabloda, Private Cloud için Edge'de desteklenen yazılımlar açıklanmaktadır. Yalnızca Intel 64 bit işlemcilerde işletim sistemi desteği sunulur.

Sürüm İşletim sistemleri JDK TLS Diğer yazılımlar
4.52.00
  • Red Hat Enterprise Linux (Intel 64 bit):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, 8.7, 8.8
  • CentOS (Intel 64 bit):
    7.5, 7.6, 7.7, 7.8
  • Oracle Linux (Intel 64 bit):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, 8.7, 8.8
  • Amazon Linux 2
  • Rocky Linux 8
  • Oracle JDK 8
  • OpenJDK 8
  • 1,0, 1,1, 1,2
  • TLS 1.3
  • Cassandra 1.2.22
  • Hayvanat Bahçesi 3.8.0
  • QPID 1,35
  • Postgres 14
  • OpenLDAP:
    • RHEL-8.X veya Oracle-8.X için: OpenLDAP 2.4.44-20.el7
    • CentOS-7.X, RHEL-7.X veya Oracle-7.X için: OS tarafından sağlanan en son sürüm
  • NGINX 1.20.1
  • Tomcat 9.0.82
4.51.00
  • Red Hat Enterprise Linux (Intel 64 bit):
    7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6
  • CentOS (Intel 64 bit):
    7.5, 7.6, 7.7, 7.8
  • Oracle Linux (Intel 64 bit):
    7.5, 7.6, 7.7, 7.8, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5 ve 8.6
  • Amazon Linux 2
  • Oracle JDK 8
  • OpenJDK 8
  • 1,0, 1,1, 1,2
  • TLS 1.3
  • Cassandra 1.2.22
  • Hayvanat Bahçesi 3.4.14
  • QPID 1,35
  • Postgres 10.17
  • OpenLDAP:
    • RHEL-8.X veya Oracle-8.X için: OpenLDAP 2.4.44-20.el7
    • CentOS-7.X, RHEL-7.X veya Oracle-7.X için: OS tarafından sağlanan en son sürüm
  • NGINX 1.20.1
  • Tomcat 8.5.64
4.50.00 ve öncesi

Artık desteklenmiyor. Desteğin devam etmesi için 4.51.00.xx veya daha yeni bir sürüme geçmeniz gerekir. Daha fazla bilgi için Apigee Edge sürüm sürecine göz atın.

Apigee Edge Mikro Ağ Geçidi

Desteklenen Node.js sürümleri şunları içerir: 16, 18 ve 20. Edge 3.3.2 sürümünden itibaren Edge Microgateway CLI komutları yalnızca desteklenen sürümlerde çalışır. Desteklenmeyen sürümlerde CLI komutları yürütmek hatayla sonuçlanır.

Apigee Edge Microgateway, Docker kapsayıcıları dahil, Node.js tarafından desteklenen tüm standart platformlarda desteklenir.

Apigee; Windows, macOS ve Linux'ta Etkin LTS veya Bakım LTS sürümlerini destekler. Daha fazla bilgi için Node.js Sürümleri bölümüne bakın.

Apigee Geliştirici Portalı (Drupal)

İşletim sistemi desteği, Apigee Edge'in temel sürümünün desteklediği işletim sistemiyle aynıdır.

Sürüm Apigee Edge TLS Diğer yazılımlar
4.52.00 4.52.00 veya sonraki sürümler 1,0, 1,1, 1,2
  • Drupal 9 - en son kararlı alt sürüm
  • PHP 7.4 (RHEL 7/CentOS 7) veya dağıtımdaki en yeni PHP (Amazon Linux)
  • Postgres 10.17
  • NGINX 1.12.1
4.51.00 4.51.00 veya sonraki sürümler 1,0, 1,1, 1,2
  • Drupal 7 - en son kararlı alt sürüm
  • PHP 7.4 (RHEL 7/CentOS 7) veya dağıtımdaki en yeni PHP (Amazon Linux)
  • Postgres 10.17
  • NGINX 1.12.1
4.50.00 4.19.06 veya sonraki sürümler 1,0, 1,1, 1,2
  • Drupal 7 - en son kararlı alt sürüm
  • PHP 7.3 (RHEL 7/CentOS 7) veya dağıtımdaki en son PHP (Amazon Linux)
  • Postgres 9.6
  • NGINX 1.12.1
4.19.06.xx ve öncesi

Artık desteklenmiyor. Desteğin devam etmesi için 4.50.00.xx veya daha yeni bir sürüme geçmeniz gerekir. Daha fazla bilgi için Apigee Edge sürüm sürecine göz atın.

* Red Hat Enterprise Linux'un (RHEL) lisanslı kopyası. Red Hat'in gerekli tüm BGBG'leri indirmek ve yüklemek için lisansa ihtiyacı vardır.

Tarayıcı desteği

Aşağıdaki bölümlerde Apigee Edge'in yanı sıra entegre ve Drupal tabanlı portallar için tarayıcı desteği özetlenmektedir.

Apigee Edge

Windows ve Mac'te aşağıdakilerin geçerli ana sürümü ve bir önceki ana sürümü:

  • Microsoft Edge (yalnızca Windows)
  • Google Chrome
  • Safari
  • Firefox

Entegre portallar

Apigee entegre portalları Apigee Edge ile aynı tarayıcı sürümlerini destekler.

Drupal tabanlı geliştirici portalları

Yalnızca Drupal core kullanılarak oluşturulan Drupal tabanlı geliştirici portalları, Drupal dokümanlarındaki Tarayıcı gereksinimleri bölümünde listelenen tarayıcıları destekler. Drupal tabanlı geliştirici portalları için ek katkıda bulunulan modüller kullanan aracı desteği daha sınırlı olabilir.