サポート対象ソフトウェアとサポート対象バージョン

以下に、Apigee Edge Public Cloud および Apigee Edge for Private Cloud(オンプレミス)のサポート対象ソフトウェア バージョンを示します。

Apigee Edge Cloud

Apigee Edge Cloud のサポート対象は、以下のとおりです。

Java(JDK)

  • Oracle JDK 7/8
  • OpenJDK 7/8

API プロキシフローでの Java Callout は、Apigee Edge Enterprise アカウントでのみ利用できます。Edge の料金と機能のページもご覧ください。

TLS

TLS バージョン 1.2

Node.js(Trireme)

Trireme 0.8.9(Node.js 0.10.32 と Rhino JavaScript エンジン 1.7.7.1 をサポート)。Node.js モジュールの Edge サポートについてもご覧ください。

JaveScript

Rhino JavaScript エンジン 1.7.7.1

Edge for Private Cloud のサポート対象バージョン

サポート対象のオペレーティング システムは、Intel 64 ビット プロセッサのみです。

バージョン オペレーティング システム JDK TLS その他のソフトウェア
4.19.01.xx
  • Red Hat Enterprise Linux(Intel 64 ビット):
    6.9、7.4、7.5、7.6
  • CentOS(Intel 64 ビット):
    6.9、7.4、7.5、7.6
  • Oracle Linux(Intel 64 ビット):
    6.9、7.3、7.4、7.5
  • Amazon Linux AMI 1
    (Amazon Linux AMI 2 はサポートされていません)
  • Oracle JDK 8
  • OpenJDK 8
1.0、1.1、1.2
  • Cassandra 2.1.16
  • Zookeeper 3.4.5
  • QPID 1.35
  • Postgres 9.6.1
  • Play(UI)2.4
  • OpenLDAP 2.4.44-20.el7
  • Node.js 0.10.32
  • Nginx 1.15.6
  • Trireme 0.8.9(Node.js 0.10.32、Rhino JavaScript エンジン 1.7.7.1)
4.18.05.xx
  • Red Hat Enterprise Linux(Intel 64 ビット):
    6.8、6.9、7.3、7.4、7.5
  • CentOS(Intel 64 ビット):
    6.8、6.9、7.3、7.4、7.5
  • Oracle Linux(Intel 64 ビット):
    6.8、6.9、7.3、7.4、7.5
  • Amazon Linux AMI 1
    (Amazon Linux AMI 2 はサポートされていません)
  • Oracle JDK 8
  • OpenJDK 8
1.0、1.1、1.2
  • Cassandra 2.1.16
  • Zookeeper 3.4.5
  • QPID 1.35
  • Postgres 9.6
  • Play(UI)2.4
  • OpenLDAP 2.4
  • Node.js 0.10.32
  • Nginx 1.14.0
  • Trireme 0.8.9(Node.js 0.10.32、Rhino JavaScript エンジン 1.7.7.1)
4.18.01.xx
  • Red Hat Enterprise Linux(Intel 64 ビット):
    6.7、6.8、7.2、7.3、7.4
  • CentOS(Intel 64 ビット):
    6.7、6.8、7.2、7.3、7.4
  • Oracle Linux(Intel 64 ビット):
    6.7、7.2、7.3、7.4
  • Amazon Linux AMI 1
    (Amazon Linux AMI 2 はサポートされていません)
  • Oracle JDK 8
  • OpenJDK 8
1.0、1.1、1.2
  • Cassandra 2.1.16
  • Zookeeper 3.4.5
  • QPID 1.35
  • Postgres 9.6
  • Play(UI)2.4
  • OpenLDAP 2.4
  • Node.js 0.10.32
  • Nginx 1.12.1
  • Trireme 0.8.9(Node.js 0.10.32、Rhino JavaScript エンジン 1.7.7.1)
4.17.09.xx 以前 not_interested

サポート対象外。引き続きサポートを受けるには 4.18.01.xx 以降にアップグレードする必要があります。 詳細については、Apigee Edge リリース プロセスをご覧ください。

Apigee Edge Microgateway

Apigee Edge Microgateway は、Node.js をサポートするすべての標準的なプラットフォームでサポートされています。詳細については、Node.js ダウンロード ページをご覧ください。Windows、macOS、Linux で Node.js LTS バージョン 4.5 以降がサポートされています。

なお、Edge Microgateway は、Node.js ダウンロード ページの追加プラットフォームの一覧にあるプラットフォームはサポートしていませんので、ご注意ください。

Apigee デベロッパー ポータル(Drupal)

サポート対象のオペレーティング システムは、Intel 64 ビット プロセッサに対応のものに限られます。

バージョン オペレーティング システム TLS その他のソフトウェア
4.19.01.xx

Apigee デベロッパー ポータル 4.19.01 では、Apigee Edge 4.15.07 以降が必要です。

  • Red Hat Enterprise Linux(Intel 64 ビット)*:
    6.9、7.4、7.5、7.6
  • CentOS(Intel 64 ビット):
    6.9、7.4、7.5、7.6
  • Oracle Linux(Intel 64 ビット):
    6.9、7.3、7.4、7.5
  • Amazon Linux AMI 1
    (Amazon Linux AMI 2 はサポートされていません)
1.0、1.1、1.2
  • Drupal 7 - 最新の安定マイナー バージョン
  • PHP 7.0.32
  • Postgres 9.6
  • Nginx 1.12.1

4.18.05.xx

Apigee デベロッパー ポータル 4.18.05 では、Apigee Edge 4.15.07 以降が必要です。

  • Red Hat Enterprise Linux(Intel 64 ビット)*:
    6.8、6.9、7.3、7.4、7.5
  • CentOS(Intel 64 ビット):
    6.8、6.9、7.3、7.4、7.5
  • Oracle Linux(Intel 64 ビット):
    6.8、6.9、7.3、7.4、7.5
  • Amazon Linux AMI 1
    (Amazon Linux AMI 2 はサポートされていません)
1.0、1.1、1.2
  • Drupal 7 - 最新の安定マイナー バージョン
  • PHP 7.0.32
  • Postgres 9.6
  • Nginx 1.12.1

4.18.01.xx

Apigee デベロッパー ポータル 4.18.01 では、Apigee Edge 4.15.07 以降が必要です。

  • Red Hat Enterprise Linux(Intel 64 ビット)*:
    7.2、7.3、7.4
  • CentOS(Intel 64 ビット):
    7.2、7.3、7.4
  • Oracle Linux(Intel 64 ビット):
    6.7、7.2、7.3、7.4
1.0、1.1、1.2
  • Drupal 7 - 最新の安定マイナー バージョン
  • PHP 7.0.23
  • Postgres 9.6
  • Nginx 1.12.1
4.17.09.xx 以前 not_interested

サポート対象外。引き続きサポートを受けるには 4.18.01.xx 以降にアップグレードする必要があります。詳細については、Apigee Edge リリース プロセスをご覧ください。

* Red Hat Enterprise Linux(RHEL)のライセンス付きコピー。Red Hat では、すべての必須 RPM のダウンロードとインストールにライセンスが必要です。

ブラウザ

Apigee Edge

Windows および Mac の場合、次のブラウザの現在および 1 つ前のメジャー バージョン:

  • Microsoft Edge(Windows のみ)
  • Google Chrome
  • Safari
  • Firefox
  • Microsoft Internet Explorer(Windows のみ) - 従来の Edge UI でのみサポート

Apigee デベロッパー ポータル(Drupal)

デベロッパー ポータルは、通常、Bootstrap 3 と互換性のあるモバイルおよびパソコンのプラットフォームをサポートしています。また、主要なブラウザ(Chrome、Firefox、Internet Explorer、Safari など)の現在のメジャー バージョンおよび 1 つ前のバージョンをサポートしています。